summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2015-07-05 07:37:58 +0200
committerJörg Frings-Fürst <debian@jff-webhosting.net>2015-07-05 07:37:58 +0200
commita88a84f5fe03b943527267114cceffba2a1f0f6a (patch)
tree690d54b3bb83fed996abcc00b19ccfb1cbdb7107
parent34e2b40ffe0be70d44567ab349282c09413c1fde (diff)
Add 30_gcc5.patch
-rw-r--r--debian/patches/30_gcc5.patch20
-rw-r--r--debian/patches/series1
-rwxr-xr-xdebian/rules3
3 files changed, 24 insertions, 0 deletions
diff --git a/debian/patches/30_gcc5.patch b/debian/patches/30_gcc5.patch
new file mode 100644
index 0000000..2806745
--- /dev/null
+++ b/debian/patches/30_gcc5.patch
@@ -0,0 +1,20 @@
+Description: Fix FTBFS with GCC 5
+Author: James Cowgill <james410@cowgill.org.uk>
+Bug-Debian: https://bugs.debian.org/777779
+Forwarded: no
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+--- a/icc/icc.h
++++ b/icc/icc.h
+@@ -100,7 +100,11 @@
+ #define CF64PREC "LL" /* Constant precision specifier */
+
+ #ifndef ATTRIBUTE_NORETURN
++#ifdef _MSC_VER
+ # define ATTRIBUTE_NORETURN __declspec(noreturn)
++#else
++# define ATTRIBUTE_NORETURN __attribute__((noreturn))
++#endif
+ #endif
+
+ #else /* !__STDC_VERSION__ */
diff --git a/debian/patches/series b/debian/patches/series
index 3e71aa7..bb02b3b 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -4,3 +4,4 @@
#20_hurd_PATH_MAX.patch
#120_usb-db_new.patch
#25_kfreebsd.patch
+30_gcc5.patch
diff --git a/debian/rules b/debian/rules
index 3943e49..c3de241 100755
--- a/debian/rules
+++ b/debian/rules
@@ -11,6 +11,9 @@ JAMCMDLINE = -q -fJambase -j$(NO_PROC) -sPREFIX=/usr -sDESTDIR=$(CURDIR)/debian/
CHDATE=$(shell dpkg-parsechangelog -S Date)
CRDATE=$(shell date --utc -d "$(CHDATE)" "+%a %b %d %T %Y")
+export CC=gcc-5
+export CXX=g++-5
+
%:
dh $@