summaryrefslogtreecommitdiff
path: root/plot/Jamfile
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2015-05-01 16:24:15 +0200
committerJörg Frings-Fürst <debian@jff-webhosting.net>2015-05-01 16:24:15 +0200
commita30ba67504ffd12c4db499adbb5ce47a7d1f6036 (patch)
tree9ae1a7e3849dda6bbb5c578232f6f2fa5b2e7e7e /plot/Jamfile
parent89e99e8a827859729729dfc92d74be4a8f96f1a4 (diff)
parent094535c010320967639e8e86f974d878e80baa72 (diff)
New release 1.7.0
Diffstat (limited to 'plot/Jamfile')
-rw-r--r--plot/Jamfile20
1 files changed, 19 insertions, 1 deletions
diff --git a/plot/Jamfile b/plot/Jamfile
index 47bc09e..5468cd6 100644
--- a/plot/Jamfile
+++ b/plot/Jamfile
@@ -11,6 +11,11 @@ if $(OS) = MACOSX {
ObjectCcFlags plot_plot : -ObjC ;
}
+# Stop MS compiler running out of heap space
+if $(MSVCNT) {
+ CCFLAGS += "/Zm400" ;
+}
+
# PLOT library
Library libplot : plot.c : : : ../h ../numlib ../spectro ;
if $(UNIX) && $(OS) != MACOSX {
@@ -18,10 +23,23 @@ if $(UNIX) && $(OS) != MACOSX {
}
# Individual stand alone test of plot library
-MainVariant plot : plot.c : : STANDALONE_TEST : ../h ../numlib ../spectro : : ../spectro/libconv.lib ../numlib/libnum.lib ;
+MainVariant plot : plot.c : : STANDALONE_TEST : ../h ../numlib ../spectro : : ../spectro/libconv.lib ../numlib/libnum.lib ../numlib/libui.lib ;
# VRML plot library
Library libvrml : vrml.c : : : ../h ../icc ../cgats ../numlib ../gamut ;
+
+# X3DOM files x3dom.css & x3dom.js are from /src/x3dom/dist after using
+# /src/x3dom/src/Makefile python script to assemble them.
+if [ GLOB $(PATH) : xxd xxd.exe ] {
+ Echo "xxd seems to be available" ;
+
+ GenFileNNDnc x3dom.css.h : xxd -i "<" [ NormPaths x3dom.css ] ">" [ NormPaths x3dom.css.h ] ;
+ GenFileNNDnc x3dom.js.h : xxd -i "<" [ NormPaths x3dom.js ] ">" [ NormPaths x3dom.js.h ] ;
+}
+
+#MainsFromSources ttt.c : : : ../numlib ;
+#Main ttt : ttt.c : : : ../numlib : : ../numlib/libnum libplot : ;
+
#MainsFromSources t.c ;