summaryrefslogtreecommitdiff
path: root/target/Makefile.am
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2014-09-01 15:42:20 +0200
committerJörg Frings-Fürst <debian@jff-webhosting.net>2014-09-01 15:42:20 +0200
commit556dffcdad42b938bc196819aa463247de709765 (patch)
tree12f5b4ae97025ace63eecd9112cf45fbc151039f /target/Makefile.am
parentad6ab4cb4c8086c9b8854c965c984ab848c6b6c2 (diff)
Remove patches from source
Diffstat (limited to 'target/Makefile.am')
-rw-r--r--target/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/target/Makefile.am b/target/Makefile.am
new file mode 100644
index 0000000..d9f050b
--- /dev/null
+++ b/target/Makefile.am
@@ -0,0 +1,28 @@
+include $(top_srcdir)/Makefile.shared
+
+CPPFLAGS+=-D_FORTIFY_SOURCE=2
+
+privatelib_LTLIBRARIES = libtarget.la
+privatelibdir = $(pkglibdir)
+
+libtarget_la_SOURCES = alphix.c alphix.h randix.c randix.h
+
+LDADD = ./libtarget.la ../rspl/librspl.la ../plot/libvrml.la \
+ $(ICC_LIBS) ../render/librender.la ../cgats/libcgats.la \
+ ../xicc/libxicc.la ../gamut/libgamut.la \
+ ../spectro/libinsttypes.la ../spectro/libconv.la \
+ ../numlib/libargyllnum.la ../libargyll.la $(TIFF_LIBS)
+
+bin_PROGRAMS = targen printtarg
+
+targen_DEPENDENCIES = ../spectro/libinsttypes.la
+targen_SOURCES = targen.c targen.h ofps.c ofps.h ifarp.c ifarp.h \
+ simplat.c simplat.h simdlat.c simdlat.h prand.c prand.h
+
+printtarg_SOURCES = printtarg.c
+
+refdir = $(datadir)/color/argyll/ref
+
+ref_DATA = $(wildcard *.ti2)
+
+EXTRA_DIST = License.txt Readme.txt