summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog14
-rw-r--r--debian/patches/20_hurd_PATH_MAX.patch30
-rw-r--r--debian/patches/series2
-rwxr-xr-xdebian/rules7
4 files changed, 30 insertions, 23 deletions
diff --git a/debian/changelog b/debian/changelog
index 2cdfaae..0b53e08 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,10 +1,14 @@
-argyll (1.7.0+repack-4) UNRELEASED; urgency=medium
+argyll (1.7.0+repack-4) unstable; urgency=medium
* debian/rules:
- - Add --utc to the command date to make the results reproducible
- over different timezones.
-
- -- Jörg Frings-Fürst <debian@jff-webhosting.net> Sun, 14 Jun 2015 13:09:12 +0200
+ - Add --utc to the command date for CRDATE to make the results
+ reproducible over different timezones.
+ * New debian/patches/30_gcc5.patch:
+ - Add gcc-5 support (Closes: #777779).
+ + Thanks to James Cowgill <james410@cowgill.org.uk>.
+ * Re-enable and refresh debian/patches/20_hurd_PATH_MAX.patch.
+
+ -- Jörg Frings-Fürst <debian@jff-webhosting.net> Sun, 05 Jul 2015 12:30:03 +0200
argyll (1.7.0+repack-3) unstable; urgency=medium
diff --git a/debian/patches/20_hurd_PATH_MAX.patch b/debian/patches/20_hurd_PATH_MAX.patch
index e5b2b40..0079adb 100644
--- a/debian/patches/20_hurd_PATH_MAX.patch
+++ b/debian/patches/20_hurd_PATH_MAX.patch
@@ -6,9 +6,9 @@ Last-Update: 2014-09-25
This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
Index: trunk/numlib/numsup.c
===================================================================
---- trunk.orig/numlib/numsup.c 2014-01-31 05:08:43.000000000 +0100
-+++ trunk/numlib/numsup.c 2014-09-25 14:02:54.718876001 +0200
-@@ -39,6 +39,10 @@
+--- trunk.orig/numlib/numsup.c
++++ trunk/numlib/numsup.c
+@@ -40,6 +40,10 @@
/* Globals */
@@ -21,11 +21,11 @@ Index: trunk/numlib/numsup.c
Index: trunk/spectro/mongoose.c
===================================================================
---- trunk.orig/spectro/mongoose.c 2014-01-31 05:08:55.000000000 +0100
-+++ trunk/spectro/mongoose.c 2014-09-25 14:06:05.274863478 +0200
-@@ -18,6 +18,10 @@
- // OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
- // THE SOFTWARE.
+--- trunk.orig/spectro/mongoose.c
++++ trunk/spectro/mongoose.c
+@@ -46,6 +46,10 @@
+ added to /usr/lib/firewalld/services
+ */
+#ifndef PATH_MAX
+#define PATH_MAX 4096
@@ -36,8 +36,8 @@ Index: trunk/spectro/mongoose.c
#else
Index: trunk/spectro/usbio_lx.c
===================================================================
---- trunk.orig/spectro/usbio_lx.c 2014-01-31 05:08:58.000000000 +0100
-+++ trunk/spectro/usbio_lx.c 2014-09-25 14:07:12.552271544 +0200
+--- trunk.orig/spectro/usbio_lx.c
++++ trunk/spectro/usbio_lx.c
@@ -33,6 +33,10 @@
#define poll_x poll
#endif
@@ -51,8 +51,8 @@ Index: trunk/spectro/usbio_lx.c
/* Take a word sized return buffer, and convert it to an unsigned int */
Index: trunk/spectro/usbio_nt.c
===================================================================
---- trunk.orig/spectro/usbio_nt.c 2014-01-31 05:08:58.000000000 +0100
-+++ trunk/spectro/usbio_nt.c 2014-09-25 14:07:37.048784270 +0200
+--- trunk.orig/spectro/usbio_nt.c
++++ trunk/spectro/usbio_nt.c
@@ -31,6 +31,10 @@
#define LIBUSBW1_PATH_MAX 512
#define LIBUSBW1_DEFAULT_TIMEOUT 5000
@@ -66,9 +66,9 @@ Index: trunk/spectro/usbio_nt.c
/* Take a word sized return buffer, and convert it to an unsigned int */
Index: trunk/spectro/hidio.c
===================================================================
---- trunk.orig/spectro/hidio.c 2014-09-25 11:17:32.000000000 +0200
-+++ trunk/spectro/hidio.c 2014-09-25 14:08:43.834182211 +0200
-@@ -97,6 +97,10 @@
+--- trunk.orig/spectro/hidio.c
++++ trunk/spectro/hidio.c
+@@ -100,6 +100,10 @@
#endif
#endif
diff --git a/debian/patches/series b/debian/patches/series
index 5e5a77f..8f5d038 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -3,5 +3,5 @@
15_jam.patch
20_hurd_PATH_MAX.patch
#120_usb-db_new.patch
-25_kfreebsd.patch
+#25_kfreebsd.patch
30_gcc5.patch
diff --git a/debian/rules b/debian/rules
index c3de241..af973db 100755
--- a/debian/rules
+++ b/debian/rules
@@ -11,8 +11,11 @@ JAMCMDLINE = -q -fJambase -j$(NO_PROC) -sPREFIX=/usr -sDESTDIR=$(CURDIR)/debian/
CHDATE=$(shell dpkg-parsechangelog -S Date)
CRDATE=$(shell date --utc -d "$(CHDATE)" "+%a %b %d %T %Y")
-export CC=gcc-5
-export CXX=g++-5
+#
+# Test for gcc-5 support
+#
+#export CC=gcc-5
+#export CXX=g++-5
%: