summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..6bddae8
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,23 @@
+include $(top_srcdir)/Makefile.shared
+
+ACLOCAL_AMFLAGS = -I m4
+
+privatelib_LTLIBRARIES = libargyll.la
+privatelibdir = $(pkglibdir)
+
+libargyll_la_SOURCES = xicc/xicc.c xicc/xicc.h xicc/xcam.c xicc/xcam.h \
+ gamut/gamut.c gamut/gamut.h xicc/xfit.c xicc/xfit.h \
+ xicc/cam97s3.c xicc/cam97s3.h xicc/cam02.c xicc/cam02.h \
+ xicc/moncurve.c xicc/moncurve.h xicc/xspect.c xicc/xspect.h \
+ xicc/xcal.c xicc/xcal.h xicc/xcolorants.h xicc/xcolorants.c xicc/ccmx.c
+libargyll_la_LIBADD = ./rspl/librspl.la $(ICC_LIBS) \
+ ./numlib/libargyllnum.la ./cgats/libcgats.la
+
+SUBDIRS = h doc ref numlib cgats $(ICC_SUBDIRS) plot rspl jcnf ucmm render . gamut \
+ spectro xicc target link tweak profile scanin imdi
+
+#SUBDIRS = h doc ref numlib cgats $(ICC_SUBDIRS) plot rspl jcnf ucmm render . gamut \
+# spectro xicc target link tweak profile scanin imdi
+
+
+EXTRA_DIST = Readme.txt ttbd.txt log.txt