summaryrefslogtreecommitdiff
path: root/debian/patches/01_autotools-support.diff
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/01_autotools-support.diff')
-rw-r--r--debian/patches/01_autotools-support.diff233
1 files changed, 155 insertions, 78 deletions
diff --git a/debian/patches/01_autotools-support.diff b/debian/patches/01_autotools-support.diff
index 8e0a6fe..13b7649 100644
--- a/debian/patches/01_autotools-support.diff
+++ b/debian/patches/01_autotools-support.diff
@@ -1,5 +1,7 @@
---- /dev/null
-+++ b/Makefile.shared
+Index: trunk/Makefile.shared
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ trunk/Makefile.shared 2014-09-01 21:40:52.561137062 +0200
@@ -0,0 +1,15 @@
+# Common CFLAGS for Argyll components
+
@@ -16,8 +18,10 @@
+ $(MAKE) -C $(@D) $(@F)
+./%.la:
+ $(MAKE) -C $(@D) $(@F)
---- /dev/null
-+++ b/config.h.in
+Index: trunk/config.h.in
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ trunk/config.h.in 2014-09-01 21:40:52.561137062 +0200
@@ -0,0 +1,95 @@
+/* config.h.in. Generated from configure.ac by autoheader. */
+
@@ -114,8 +118,10 @@
+
+/* Define to 1 if the X Window System is missing or not being used. */
+#undef X_DISPLAY_MISSING
---- /dev/null
-+++ b/Makefile.am
+Index: trunk/Makefile.am
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ trunk/Makefile.am 2014-09-01 21:40:52.561137062 +0200
@@ -0,0 +1,23 @@
+include $(top_srcdir)/Makefile.shared
+
@@ -140,8 +146,10 @@
+
+
+EXTRA_DIST = Readme.txt ttbd.txt log.txt
---- /dev/null
-+++ b/configure.ac
+Index: trunk/configure.ac
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ trunk/configure.ac 2014-09-01 21:40:52.561137062 +0200
@@ -0,0 +1,133 @@
+AC_INIT([argyll], [1.3.7])
+AM_INIT_AUTOMAKE([1.9 foreign])
@@ -276,8 +284,10 @@
+ ucmm/Makefile])
+
+AC_OUTPUT
---- /dev/null
-+++ b/tweak/Makefile.am
+Index: trunk/tweak/Makefile.am
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ trunk/tweak/Makefile.am 2014-09-01 21:40:52.561137062 +0200
@@ -0,0 +1,11 @@
+include $(top_srcdir)/Makefile.shared
+
@@ -290,8 +300,10 @@
+bin_PROGRAMS = refine
+
+EXTRA_DIST = License.txt Readme.txt
---- /dev/null
-+++ b/rspl/Makefile.am
+Index: trunk/rspl/Makefile.am
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ trunk/rspl/Makefile.am 2014-09-01 21:40:52.561137062 +0200
@@ -0,0 +1,15 @@
+include $(top_srcdir)/Makefile.shared
+
@@ -308,8 +320,10 @@
+check_PROGRAMS = revbench c1 c1df t2d t2ddf t3d t3ddf tnd trnd
+
+EXTRA_DIST = License.txt Readme.txt
---- /dev/null
-+++ b/plot/Makefile.am
+Index: trunk/plot/Makefile.am
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ trunk/plot/Makefile.am 2014-09-01 21:40:52.561137062 +0200
@@ -0,0 +1,12 @@
+include $(top_srcdir)/Makefile.shared
+
@@ -323,8 +337,10 @@
+libvrml_la_LIBADD = $(ICC_LIBS) ../numlib/libargyllnum.la
+
+EXTRA_DIST = License.txt Readme.txt
---- /dev/null
-+++ b/doc/Makefile.am
+Index: trunk/doc/Makefile.am
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ trunk/doc/Makefile.am 2014-09-01 21:40:52.561137062 +0200
@@ -0,0 +1,6 @@
+docdir = $(datadir)/doc/argyll
+
@@ -332,8 +348,10 @@
+ $(wildcard *.gif)
+
+EXTRA_DIST = $(doc_DATA)
---- /dev/null
-+++ b/numlib/Makefile.am
+Index: trunk/numlib/Makefile.am
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ trunk/numlib/Makefile.am 2014-09-01 21:40:52.561137062 +0200
@@ -0,0 +1,15 @@
+include $(top_srcdir)/Makefile.shared
+
@@ -350,9 +368,11 @@
+ soboltest
+
+EXTRA_DIST = License.txt Readme.txt
---- /dev/null
-+++ b/spectro/Makefile.am
-@@ -0,0 +1,53 @@
+Index: trunk/spectro/Makefile.am
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ trunk/spectro/Makefile.am 2014-09-01 21:41:09.629460471 +0200
+@@ -0,0 +1,54 @@
+include $(top_srcdir)/Makefile.shared
+
+privatelib_LTLIBRARIES = libinsttypes.la libconv.la libinst.la libinstapp.la libdisp.la
@@ -368,7 +388,8 @@
+ spyd2.c spyd2.h spyd2setup.h spyd2PLD.h huey.c huey.h \
+ usbio.c hidio.c pollem.c pollem.h icoms.h conv.h usbio.h \
+ hidio.h i1d3.h i1d3.c colorhug.c colorhug.h icoms.c \
-+ oemarch.h oemarch.c iusb.h vinflate.c inflate.c
++ oemarch.h oemarch.c iusb.h vinflate.c inflate.c \
++ specbos.c
+libinst_la_LIBADD = $(ICC_LIBS) ../numlib/libargyllnum.la \
+ ../libargyll.la ../rspl/librspl.la libconv.la
+
@@ -406,8 +427,10 @@
+ref_DATA = ccxx.ti1 SOtele.sp $(wildcard *.cal)
+
+EXTRA_DIST = Readme.txt
---- /dev/null
-+++ b/ref/Makefile.am
+Index: trunk/ref/Makefile.am
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ trunk/ref/Makefile.am 2014-09-01 21:40:52.561137062 +0200
@@ -0,0 +1,7 @@
+refdir = $(datadir)/color/argyll/ref
+
@@ -416,8 +439,10 @@
+ $(wildcard *.ti2)
+
+EXTRA_DIST = $(ref_DATA)
---- /dev/null
-+++ b/link/Makefile.am
+Index: trunk/link/Makefile.am
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ trunk/link/Makefile.am 2014-09-01 21:40:52.561137062 +0200
@@ -0,0 +1,11 @@
+include $(top_srcdir)/Makefile.shared
+
@@ -430,8 +455,10 @@
+bin_PROGRAMS = collink pathplot
+
+EXTRA_DIST = License.txt Readme.txt
---- /dev/null
-+++ b/imdi/Makefile.am
+Index: trunk/imdi/Makefile.am
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ trunk/imdi/Makefile.am 2014-09-01 21:40:52.561137062 +0200
@@ -0,0 +1,40 @@
+include $(top_srcdir)/Makefile.shared
+
@@ -473,8 +500,10 @@
+ ./imdi_make
+
+EXTRA_DIST = License.txt Readme.txt
---- /dev/null
-+++ b/scanin/Makefile.am
+Index: trunk/scanin/Makefile.am
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ trunk/scanin/Makefile.am 2014-09-01 21:40:52.561137062 +0200
@@ -0,0 +1,19 @@
+include $(top_srcdir)/Makefile.shared
+
@@ -495,8 +524,10 @@
+ref_DATA = $(wildcard *.cht) $(wildcard *.cie) $(wildcard *.ti2)
+
+EXTRA_DIST = $(ref_DATA) License.txt Readme.txt
---- /dev/null
-+++ b/cgats/Makefile.am
+Index: trunk/cgats/Makefile.am
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ trunk/cgats/Makefile.am 2014-09-01 21:40:52.561137062 +0200
@@ -0,0 +1,9 @@
+include $(top_srcdir)/Makefile.shared
+
@@ -507,8 +538,10 @@
+ cgatsstd.c
+
+EXTRA_DIST = License.txt Readme.txt
---- /dev/null
-+++ b/render/Makefile.am
+Index: trunk/render/Makefile.am
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ trunk/render/Makefile.am 2014-09-01 21:40:52.561137062 +0200
@@ -0,0 +1,13 @@
+include $(top_srcdir)/Makefile.shared
+
@@ -523,8 +556,10 @@
+check_PROGRAMS = timage
+
+EXTRA_DIST = License.txt Readme.txt
---- /dev/null
-+++ b/jcnf/Makefile.am
+Index: trunk/jcnf/Makefile.am
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ trunk/jcnf/Makefile.am 2014-09-01 21:40:52.565137138 +0200
@@ -0,0 +1,15 @@
+include $(top_srcdir)/Makefile.shared
+
@@ -541,8 +576,10 @@
+check_PROGRAMS = test
+
+EXTRA_DIST = Readme.txt
---- /dev/null
-+++ b/jcnf/yajl/Makefile.am
+Index: trunk/jcnf/yajl/Makefile.am
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ trunk/jcnf/yajl/Makefile.am 2014-09-01 21:40:52.565137138 +0200
@@ -0,0 +1,13 @@
+include $(top_srcdir)/Makefile.shared
+
@@ -557,14 +594,18 @@
+LDADD = ./libyajl.la
+
+check_PROGRAMS = yajl_test json_verify
---- /dev/null
-+++ b/h/Makefile.am
+Index: trunk/h/Makefile.am
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ trunk/h/Makefile.am 2014-09-01 21:40:52.565137138 +0200
@@ -0,0 +1,3 @@
+EXTRA_DIST = Readme.txt copyright.h config.h sort.h llist.h xlist.h \
+ counters.h
+
---- /dev/null
-+++ b/icc/Makefile.am
+Index: trunk/icc/Makefile.am
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ trunk/icc/Makefile.am 2014-09-01 21:40:52.565137138 +0200
@@ -0,0 +1,22 @@
+include $(top_srcdir)/Makefile.shared
+
@@ -588,8 +629,10 @@
+ref_DATA = $(wildcard *.icm)
+
+EXTRA_DIST = License.txt Readme.txt
---- /dev/null
-+++ b/ucmm/Makefile.am
+Index: trunk/ucmm/Makefile.am
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ trunk/ucmm/Makefile.am 2014-09-01 21:40:52.565137138 +0200
@@ -0,0 +1,9 @@
+include $(top_srcdir)/Makefile.shared
+
@@ -600,8 +643,10 @@
+libucmm_la_LIBADD = $(ICC_LIBS) ../jcnf/libjcnf.la ../spectro/libconv.la
+
+LDADD = libucmm.la
---- /dev/null
-+++ b/xicc/Makefile.am
+Index: trunk/xicc/Makefile.am
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ trunk/xicc/Makefile.am 2014-09-01 21:40:52.565137138 +0200
@@ -0,0 +1,28 @@
+include $(top_srcdir)/Makefile.shared
+
@@ -631,8 +676,10 @@
+ ../gamut/libgammap.la ../target/libtarget.la
+
+EXTRA_DIST = xmono.c xmatrix.c xlut.c
---- /dev/null
-+++ b/target/Makefile.am
+Index: trunk/target/Makefile.am
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ trunk/target/Makefile.am 2014-09-01 21:40:52.565137138 +0200
@@ -0,0 +1,28 @@
+include $(top_srcdir)/Makefile.shared
+
@@ -662,8 +709,10 @@
+ref_DATA = $(wildcard *.ti2)
+
+EXTRA_DIST = License.txt Readme.txt
---- /dev/null
-+++ b/profile/Makefile.am
+Index: trunk/profile/Makefile.am
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ trunk/profile/Makefile.am 2014-09-01 21:40:52.565137138 +0200
@@ -0,0 +1,27 @@
+include $(top_srcdir)/Makefile.shared
+
@@ -692,8 +741,10 @@
+ref_DATA = $(wildcard *.sp)
+
+EXTRA_DIST = License.txt Readme.txt
---- /dev/null
-+++ b/gamut/Makefile.am
+Index: trunk/gamut/Makefile.am
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ trunk/gamut/Makefile.am 2014-09-01 21:40:52.565137138 +0200
@@ -0,0 +1,27 @@
+include $(top_srcdir)/Makefile.shared
+
@@ -722,8 +773,10 @@
+##ref_DATA = RefMediumGamut.gam
+
+EXTRA_DIST = License.txt Readme.txt
---- /dev/null
-+++ b/imdi/imdi_k.h
+Index: trunk/imdi/imdi_k.h
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ trunk/imdi/imdi_k.h 2014-09-01 21:40:52.565137138 +0200
@@ -0,0 +1,910 @@
+/* Integer Multi-Dimensional Interpolation */
+/* Declarations for all the generated kernel functions */
@@ -1635,8 +1688,10 @@
+
+int no_kfuncs = 891;
+
---- /dev/null
-+++ b/configure
+Index: trunk/configure
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ trunk/configure 2014-09-01 21:40:52.573137290 +0200
@@ -0,0 +1,15216 @@
+#! /bin/sh
+# Guess values for system-dependent variables and create Makefiles.
@@ -16854,8 +16909,10 @@
+$as_echo "$as_me: WARNING: unrecognized options: $ac_unrecognized_opts" >&2;}
+fi
+
---- /dev/null
-+++ b/config.sub
+Index: trunk/config.sub
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ trunk/config.sub 2014-09-01 21:40:52.573137290 +0200
@@ -0,0 +1,1791 @@
+#! /bin/sh
+# Configuration validation subroutine script.
@@ -18648,8 +18705,10 @@
+# time-stamp-format: "%:y-%02m-%02d"
+# time-stamp-end: "'"
+# End:
---- /dev/null
-+++ b/aclocal.m4
+Index: trunk/aclocal.m4
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ trunk/aclocal.m4 2014-09-01 21:40:52.577137366 +0200
@@ -0,0 +1,1073 @@
+# generated automatically by aclocal 1.13.3 -*- Autoconf -*-
+
@@ -19724,8 +19783,10 @@
+m4_include([m4/ltsugar.m4])
+m4_include([m4/ltversion.m4])
+m4_include([m4/lt~obsolete.m4])
---- /dev/null
-+++ b/missing
+Index: trunk/missing
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ trunk/missing 2014-09-01 21:40:52.577137366 +0200
@@ -0,0 +1,215 @@
+#! /bin/sh
+# Common wrapper for a few potentially missing GNU programs.
@@ -19942,8 +20003,10 @@
+# time-stamp-time-zone: "UTC"
+# time-stamp-end: "; # UTC"
+# End:
---- /dev/null
-+++ b/depcomp
+Index: trunk/depcomp
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ trunk/depcomp 2014-09-01 21:40:52.577137366 +0200
@@ -0,0 +1,791 @@
+#! /bin/sh
+# depcomp - compile a program generating dependencies as side-effects
@@ -20736,8 +20799,10 @@
+# time-stamp-time-zone: "UTC"
+# time-stamp-end: "; # UTC"
+# End:
---- /dev/null
-+++ b/install-sh
+Index: trunk/install-sh
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ trunk/install-sh 2014-09-01 21:40:52.577137366 +0200
@@ -0,0 +1,527 @@
+#!/bin/sh
+# install - install a program, script, or datafile
@@ -21266,8 +21331,10 @@
+# time-stamp-time-zone: "UTC"
+# time-stamp-end: "; # UTC"
+# End:
---- /dev/null
-+++ b/config.guess
+Index: trunk/config.guess
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ trunk/config.guess 2014-09-01 21:40:52.577137366 +0200
@@ -0,0 +1,1558 @@
+#! /bin/sh
+# Attempt to guess a canonical system name.
@@ -22827,8 +22894,10 @@
+# time-stamp-format: "%:y-%02m-%02d"
+# time-stamp-end: "'"
+# End:
---- /dev/null
-+++ b/m4/ltoptions.m4
+Index: trunk/m4/ltoptions.m4
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ trunk/m4/ltoptions.m4 2014-09-01 21:40:52.577137366 +0200
@@ -0,0 +1,384 @@
+# Helper functions for option handling. -*- Autoconf -*-
+#
@@ -23214,8 +23283,10 @@
+ [m4_define([_LTDL_TYPE], [installable])])
+LT_OPTION_DEFINE([LTDL_INIT], [convenience],
+ [m4_define([_LTDL_TYPE], [convenience])])
---- /dev/null
-+++ b/m4/libtool.m4
+Index: trunk/m4/libtool.m4
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ trunk/m4/libtool.m4 2014-09-01 21:40:52.581137441 +0200
@@ -0,0 +1,7991 @@
+# libtool.m4 - Configure libtool for the host system. -*-Autoconf-*-
+#
@@ -31208,8 +31279,10 @@
+_LT_DECL([to_tool_file_cmd], [lt_cv_to_tool_file_cmd],
+ [0], [convert $build files to toolchain format])dnl
+])# _LT_PATH_CONVERSION_FUNCTIONS
---- /dev/null
-+++ b/m4/ltversion.m4
+Index: trunk/m4/ltversion.m4
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ trunk/m4/ltversion.m4 2014-09-01 21:40:52.585137517 +0200
@@ -0,0 +1,23 @@
+# ltversion.m4 -- version numbers -*- Autoconf -*-
+#
@@ -31234,8 +31307,10 @@
+_LT_DECL(, macro_version, 0, [Which release of libtool.m4 was used?])
+_LT_DECL(, macro_revision, 0)
+])
---- /dev/null
-+++ b/m4/ltsugar.m4
+Index: trunk/m4/ltsugar.m4
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ trunk/m4/ltsugar.m4 2014-09-01 21:40:52.585137517 +0200
@@ -0,0 +1,123 @@
+# ltsugar.m4 -- libtool m4 base layer. -*-Autoconf-*-
+#
@@ -31360,8 +31435,10 @@
+ lt_unquote(m4_split(m4_normalize(m4_foreach(_Lt_key, lt_car([m4_shiftn(4, $@)]),
+ [lt_if_dict_fetch([$1], _Lt_key, [$2], [$3], [_Lt_key ])])))))])[]dnl
+])
---- /dev/null
-+++ b/m4/lt~obsolete.m4
+Index: trunk/m4/lt~obsolete.m4
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ trunk/m4/lt~obsolete.m4 2014-09-01 21:40:52.585137517 +0200
@@ -0,0 +1,98 @@
+# lt~obsolete.m4 -- aclocal satisfying obsolete definitions. -*-Autoconf-*-
+#