summaryrefslogtreecommitdiff
path: root/debian/patches/15_jam.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/15_jam.patch')
-rw-r--r--debian/patches/15_jam.patch87
1 files changed, 87 insertions, 0 deletions
diff --git a/debian/patches/15_jam.patch b/debian/patches/15_jam.patch
new file mode 100644
index 0000000..a2cc91a
--- /dev/null
+++ b/debian/patches/15_jam.patch
@@ -0,0 +1,87 @@
+Description: Add multiarch support to jam files
+Author: Jörg Frings Fürst <debian@jff-webhosting.net>
+Forwarded:
+Last-Update: 2014-09-06
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+Index: trunk/Jamtop
+===================================================================
+--- trunk.orig/Jamtop 2014-09-06 10:26:03.492738912 +0200
++++ trunk/Jamtop 2014-09-06 10:26:03.484738743 +0200
+@@ -108,13 +108,18 @@
+ }
+
+ # See if we have a system TIFF library.
+-if ! $(BUILTIN_TIFF) && $(UNIX) {
+- if [ GLOB /usr/include : tiffio.h ] || [ GLOB /usr/local/include : tiffio.h ] {
++if ! $(BUILDIN_TIFF) {
++if $(UNIX) {
++ if [ GLOB /usr/include : tiffio.h ] || [ GLOB /usr/local/include : tiffio.h ]
++ || [ GLOB /usr/include/x86_64-linux-gnu : tiffio.h ]
++ || [ GLOB /usr/include/i386-linux-gnu : tiffio.h ] {
+ if [ GLOB /usr/lib : libtiff.so ] || [ GLOB /usr/lib : libtiff.a ]
+ || [ GLOB /usr/lib64 : libtiff.so ] || [ GLOB /usr/lib64 : libtiff.a ]
+ || [ GLOB /usr/lib/x86_64-linux-gnu : libtiff.so ]
+ || [ GLOB /usr/lib/x86_64-linux-gnu : libtiff.a ]
+- || [ GLOB /usr/local/lib : libtiff.so ] || [ GLOB /usr/local/lib : libtiff.a ] {
++ || [ GLOB /usr/lib/lib/i386-linux-gnu : libtiff.so ]
++ || [ GLOB /usr/lib/lib/i386-linux-gnu : libtiff.a ]
++ || [ GLOB /usr/local/lib : libtiff.so ] || [ GLOB /usr/local/lib : libtiff.a ] {
+ echo "Using system TIFF library" ;
+ TIFFLIB = ;
+ TIFFINC = ;
+@@ -123,12 +128,13 @@
+ }
+ }
+ }
++}
+
+ # If nothing else, use Argyll supplied TIFF library
+ if ! $(HAVE_TIFF) || $(BUILTIN_TIFF) {
+ echo "Using Argyll TIFF library" ;
+- TIFFLIB = ../tiff/libtiff.lib ;
+- TIFFINC = ../tiff ;
++# TIFFLIB = ../tiff/libtiff.lib ;
++# TIFFINC = ../tiff ;
+ }
+
+ # See if we have a system JPEG library.
+Index: trunk/Jambase
+===================================================================
+--- trunk.orig/Jambase 2014-09-06 10:26:03.492738912 +0200
++++ trunk/Jambase 2014-09-06 10:26:03.484738743 +0200
+@@ -880,7 +880,7 @@
+
+ # UNIX defaults
+
+- CCFLAGS ?= -DUNIX -D_THREAD_SAFE -pipe ;
++ CCFLAGS ?= $(CPPFLAGS) -g -DUNIX -D_THREAD_SAFE -pipe ;
+ CCOPTFLAG ?= -O2 ;
+ CCDEBUGFLAG ?= -g ;
+ CCPROFFLAG ?= ;
+@@ -890,7 +890,7 @@
+ CHGRP ?= chgrp ;
+ CHOWN ?= chown ;
+ LEX ?= lex ;
+- LINKFLAGS ?= ;
++ LINKFLAGS ?= $(LDFLAGS) ;
+ LINKOPTFLAG ?= -O ; # Affects creating .so's
+ LINKSTRIPFLAG ?= -s ;
+ LINKDEBUGFLAG ?= ;
+Index: trunk/imdi/Makefile
+===================================================================
+--- trunk.orig/imdi/Makefile 2014-09-06 10:26:03.492738912 +0200
++++ trunk/imdi/Makefile 2014-09-06 10:26:03.484738743 +0200
+@@ -9,10 +9,10 @@
+ # by uncommenting the appropriate line:
+
+ # Microsoft VC++, WinNT setup
+-include Makefile.WNT
++#include Makefile.WNT
+
+ # Generic UNIX setup
+-#include Makefile.UNIX
++include Makefile.UNIX
+
+ # Apple OS X
+ #include Makefile.OSX