summaryrefslogtreecommitdiff
path: root/debian/patches/15_jam.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/15_jam.patch')
-rw-r--r--debian/patches/15_jam.patch57
1 files changed, 19 insertions, 38 deletions
diff --git a/debian/patches/15_jam.patch b/debian/patches/15_jam.patch
index a2cc91a..2ca1ae4 100644
--- a/debian/patches/15_jam.patch
+++ b/debian/patches/15_jam.patch
@@ -6,16 +6,13 @@ Last-Update: 2014-09-06
This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
Index: trunk/Jamtop
===================================================================
---- trunk.orig/Jamtop 2014-09-06 10:26:03.492738912 +0200
-+++ trunk/Jamtop 2014-09-06 10:26:03.484738743 +0200
-@@ -108,13 +108,18 @@
- }
+--- trunk.orig/Jamtop 2014-09-07 20:15:02.520225484 +0200
++++ trunk/Jamtop 2014-09-07 20:15:43.909089670 +0200
+@@ -109,12 +109,16 @@
# See if we have a system TIFF library.
--if ! $(BUILTIN_TIFF) && $(UNIX) {
+ if ! $(BUILTIN_TIFF) && $(UNIX) {
- if [ GLOB /usr/include : tiffio.h ] || [ GLOB /usr/local/include : tiffio.h ] {
-+if ! $(BUILDIN_TIFF) {
-+if $(UNIX) {
+ if [ GLOB /usr/include : tiffio.h ] || [ GLOB /usr/local/include : tiffio.h ]
+ || [ GLOB /usr/include/x86_64-linux-gnu : tiffio.h ]
+ || [ GLOB /usr/include/i386-linux-gnu : tiffio.h ] {
@@ -24,32 +21,24 @@ Index: trunk/Jamtop
|| [ GLOB /usr/lib/x86_64-linux-gnu : libtiff.so ]
|| [ GLOB /usr/lib/x86_64-linux-gnu : libtiff.a ]
- || [ GLOB /usr/local/lib : libtiff.so ] || [ GLOB /usr/local/lib : libtiff.a ] {
-+ || [ GLOB /usr/lib/lib/i386-linux-gnu : libtiff.so ]
-+ || [ GLOB /usr/lib/lib/i386-linux-gnu : libtiff.a ]
++ || [ GLOB /usr/lib/i386-linux-gnu : libtiff.so ]
++ || [ GLOB /usr/lib/i386-linux-gnu : libtiff.a ]
+ || [ GLOB /usr/local/lib : libtiff.so ] || [ GLOB /usr/local/lib : libtiff.a ] {
echo "Using system TIFF library" ;
TIFFLIB = ;
TIFFINC = ;
-@@ -123,12 +128,13 @@
- }
+@@ -124,6 +128,7 @@
}
}
-+}
++
# If nothing else, use Argyll supplied TIFF library
if ! $(HAVE_TIFF) || $(BUILTIN_TIFF) {
echo "Using Argyll TIFF library" ;
-- TIFFLIB = ../tiff/libtiff.lib ;
-- TIFFINC = ../tiff ;
-+# TIFFLIB = ../tiff/libtiff.lib ;
-+# TIFFINC = ../tiff ;
- }
-
- # See if we have a system JPEG library.
Index: trunk/Jambase
===================================================================
---- trunk.orig/Jambase 2014-09-06 10:26:03.492738912 +0200
-+++ trunk/Jambase 2014-09-06 10:26:03.484738743 +0200
+--- trunk.orig/Jambase 2014-09-07 20:15:02.520225484 +0200
++++ trunk/Jambase 2014-09-07 20:15:02.512225317 +0200
@@ -880,7 +880,7 @@
# UNIX defaults
@@ -68,20 +57,12 @@ Index: trunk/Jambase
LINKOPTFLAG ?= -O ; # Affects creating .so's
LINKSTRIPFLAG ?= -s ;
LINKDEBUGFLAG ?= ;
-Index: trunk/imdi/Makefile
-===================================================================
---- trunk.orig/imdi/Makefile 2014-09-06 10:26:03.492738912 +0200
-+++ trunk/imdi/Makefile 2014-09-06 10:26:03.484738743 +0200
-@@ -9,10 +9,10 @@
- # by uncommenting the appropriate line:
-
- # Microsoft VC++, WinNT setup
--include Makefile.WNT
-+#include Makefile.WNT
-
- # Generic UNIX setup
--#include Makefile.UNIX
-+include Makefile.UNIX
-
- # Apple OS X
- #include Makefile.OSX
+@@ -971,7 +971,7 @@
+ RMDIR ?= $(RM) ;
+ RSH ?= rsh ;
+ SED ?= sed ;
+- SHELLHEADER ?= "#!/bin/sh" ;
++ SHELLHEADER ?= "#!/bin/bash" ;
+ SHELLMODE ?= 755 ;
+ SLASH ?= / ;
+ STDHDRS ?= /usr/include ;