summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules11
1 files changed, 6 insertions, 5 deletions
diff --git a/debian/rules b/debian/rules
index 8cd2669..fe01084 100755
--- a/debian/rules
+++ b/debian/rules
@@ -3,6 +3,8 @@
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
+include /usr/share/dpkg/pkg-info.mk
+
export DH_OPTIONS
# hardening
@@ -11,8 +13,7 @@ export DEB_BUILD_MAINT_OPTIONS = hardening=+all
NO_PROC=$(shell cat /proc/cpuinfo | grep processor | wc -l)
JAMCMDLINE = -q -fJambase -j$(NO_PROC) -sPREFIX=/usr -sDESTDIR=$(CURDIR)/debian/tmp -sREFSUBDIR=share/color/argyll/ref
-CHDATE=$(shell dpkg-parsechangelog -S Date)
-CRDATE=$(shell LC_ALL=C date --utc -d "$(CHDATE)" "+%a %b %d %T %Y")
+CRDATE=$(shell LC_ALL=C date --utc --date='@$(SOURCE_DATE_EPOCH)' "+%a %b %d %T %Y")
%:
dh $@
@@ -43,15 +44,15 @@ override_dh_installdocs:
override_dh_installchangelogs:
dh_installchangelogs log.txt
-override_dh_strip:
- dh_strip --dbg-package=argyll-dbg
-
override_dh_builddeb:
dh_builddeb
override_dh_compress:
dh_compress -X.html
+override_dh_strip:
+ dh_strip --dbgsym-migration='argyll-dbg (<< 1.9.2+repack-2~)'
+
build-manpages:
help2man -N --no-discard-stderr --name="Apply device calibration to an ICC profile." debian/tmp/usr/bin/applycal > debian/man/applycal.1
help2man -N --no-discard-stderr --name="Dump an ICC file in human readable form." debian/tmp/usr/bin/iccdump > debian/man/iccdump.1