summaryrefslogtreecommitdiff
path: root/numlib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'numlib/Makefile.am')
-rw-r--r--numlib/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/numlib/Makefile.am b/numlib/Makefile.am
new file mode 100644
index 0000000..da95596
--- /dev/null
+++ b/numlib/Makefile.am
@@ -0,0 +1,15 @@
+include $(top_srcdir)/Makefile.shared
+
+privatelib_LTLIBRARIES = libargyllnum.la
+privatelibdir = $(pkglibdir)
+
+libargyllnum_la_SOURCES = numlib.h numsup.c numsup.h dnsq.c dnsq.h \
+ powell.c powell.h dhsx.c dhsx.h ludecomp.c ludecomp.h svd.c \
+ svd.h zbrent.c zbrent.h rand.c rand.h sobol.c sobol.h aatree.c
+
+LDADD = ./libargyllnum.la
+
+check_PROGRAMS = dnsqtest tpowell tdhsx LUtest svdtest zbrenttest \
+ soboltest
+
+EXTRA_DIST = License.txt Readme.txt