summaryrefslogtreecommitdiff
path: root/rspl/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'rspl/Makefile.am')
-rw-r--r--rspl/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/rspl/Makefile.am b/rspl/Makefile.am
new file mode 100644
index 0000000..cfa0ec2
--- /dev/null
+++ b/rspl/Makefile.am
@@ -0,0 +1,15 @@
+include $(top_srcdir)/Makefile.shared
+
+privatelib_LTLIBRARIES = librspl.la
+privatelibdir = $(pkglibdir)
+
+librspl_la_SOURCES = rspl.h rspl_imp.h mlbs.h rspl.c scat.c rev.c \
+ rev.h gam.c spline.c opt.c
+librspl_la_LIBADD = ../numlib/libargyllnum.la ../plot/libvrml.la
+
+LDADD = ./librspl.la ../numlib/libargyllnum.la ../plot/libplot.la \
+ ../plot/libvrml.la $(X_LIBS) $(TIFF_LIBS) $(ICC_LIBS)
+
+check_PROGRAMS = revbench c1 c1df t2d t2ddf t3d t3ddf tnd trnd
+
+EXTRA_DIST = License.txt Readme.txt