summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am32
1 files changed, 32 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..201a051
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,32 @@
+## src/
+AUTOMAKE_OPTIONS = subdir-objects
+AM_CPPFLAGS = -I$(top_srcdir)/lib ${libconfig_CFLAGS} ${log4cpp_CFLAGS}
+
+bitzincludedir = $(pkgincludedir)
+sbin_PROGRAMS = bitz-server
+bitz_server_LDFLAGS = -ldl -export-dynamic
+bitz_server_LDADD = $(top_builddir)/lib/socket/libsocket.la \
+ $(top_builddir)/lib/icap/libicap.la \
+ ${libconfig_LIBS} ${log4cpp_LIBS}
+
+bitz_server_SOURCES = main.cpp \
+ bitz-server.h bitz-server.cpp \
+ bitz/exception.h bitz/exception.cpp \
+ bitz/manager_exception.h bitz/manager_exception.cpp \
+ bitz/config.h bitz/config.cpp \
+ bitz/logger.h bitz/logger.cpp \
+ bitz/common.h \
+ bitz/util.h bitz/util.cpp \
+ bitz/manager.h bitz/manager.cpp \
+ bitz/worker.h bitz/worker.cpp \
+ bitz/request_handler.h bitz/request_handler.cpp \
+ bitz/options_request_handler.h bitz/options_request_handler.cpp \
+ bitz/reqmod_request_handler.h bitz/reqmod_request_handler.cpp \
+ bitz/respmod_request_handler.h bitz/respmod_request_handler.cpp \
+ bitz/modifier.cpp
+
+bitzinclude_HEADERS = \
+ bitz/config.h \
+ bitz/logger.h \
+ bitz/modifier.h
+