summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules54
1 files changed, 5 insertions, 49 deletions
diff --git a/debian/rules b/debian/rules
index 122387c..4d00de0 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,53 +1,9 @@
#!/usr/bin/make -f
-## ----------------------------------------------------------------------------
+# -*- makefile -*-
-## ----------------------------------------------------------------------------
-## uncomment this to turn on verbose mode
+%:
+ dh $@
-# export DH_VERBOSE=1
-
-## ----------------------------------------------------------------------------
-
-clean:
- dh_testdir
- dh_testroot
- rm -f build-stamp install-stamp
- [ ! -f Makefile ] || $(MAKE) clean
- rm -f $(CURDIR)/cil.1
- dh_clean
-
-build: build-stamp
-build-stamp:
- dh_testdir
- echo Doing MAN...
+override_dh_auto_build:
+ dh_auto_build
pod2man $(CURDIR)/bin/cil > $(CURDIR)/cil.1
- touch build-stamp
-
-binary:
- dh_testdir
- dh_testroot
- dh_prep
-
- dh_install
- dh_installdirs
- dh_installdocs
- dh_installdebconf
- dh_installman
- dh_installchangelogs Changes
- dh_compress
- dh_fixperms
- dh_installdeb
-
- dh_perl
-
- dh_gencontrol
- dh_md5sums
- dh_builddeb
-
-binary-arch:
-
-binary: binary-indep binary-arch
-
-.PHONY: clean install binary-indep binary-arch binary
-
-## ----------------------------------------------------------------------------