summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2015-09-28 12:32:24 +0200
committerJörg Frings-Fürst <debian@jff-webhosting.net>2015-09-28 12:32:24 +0200
commitc86ea762ab8845450ed8e142a11848b5f42f5863 (patch)
treee16f703980536c34b2a02974b422f5bb5c1404c5 /Makefile
parent06f6f3f787798e36d097a07873bd2e6e6b44c257 (diff)
parent53bafb796b654d1f7206196fd97cf8ba0b08ad7a (diff)
Merge to new upstream release 3.0
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 55378bb..1f54a1f 100644
--- a/Makefile
+++ b/Makefile
@@ -4,7 +4,7 @@
# VPD Decode
#
# Copyright (C) 2000-2002 Alan Cox <alan@redhat.com>
-# Copyright (C) 2002-2007 Jean Delvare <khali@linux-fr.org>
+# Copyright (C) 2002-2015 Jean Delvare <jdelvare@suse.de>
#
# This program is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -15,6 +15,10 @@
CC = gcc
CFLAGS = -W -Wall -Wshadow -Wstrict-prototypes -Wpointer-arith -Wcast-qual \
-Wcast-align -Wwrite-strings -Wmissing-prototypes -Winline -Wundef
+
+# Let lseek and mmap support 64-bit wide offsets
+CFLAGS += -D_FILE_OFFSET_BITS=64
+
#CFLAGS += -DBIGENDIAN
#CFLAGS += -DALIGNMENT_WORKAROUND