summaryrefslogtreecommitdiff
path: root/debian/patches/0005-build.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/0005-build.patch')
-rw-r--r--debian/patches/0005-build.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/debian/patches/0005-build.patch b/debian/patches/0005-build.patch
new file mode 100644
index 0000000..b9361eb
--- /dev/null
+++ b/debian/patches/0005-build.patch
@@ -0,0 +1,25 @@
+Author: Daniel Baumann <daniel.baumann@progress-technologies.net>
+Description: Avoid overwriting build environment rather than to just extend it.
+
+Index: trunk/Makefile
+===================================================================
+--- trunk.orig/Makefile
++++ trunk/Makefile
+@@ -13,7 +13,7 @@
+ #
+
+ CC = gcc
+-CFLAGS = -W -Wall -Wshadow -Wstrict-prototypes -Wpointer-arith -Wcast-qual \
++CFLAGS += -W -Wall -Wshadow -Wstrict-prototypes -Wpointer-arith -Wcast-qual \
+ -Wcast-align -Wwrite-strings -Wmissing-prototypes -Winline -Wundef
+
+ # Let lseek and mmap support 64-bit wide offsets
+@@ -27,7 +27,7 @@ CFLAGS += -O2
+ #CFLAGS += -g
+
+ # Pass linker flags here
+-LDFLAGS =
++#LDFLAGS =
+
+ DESTDIR =
+ prefix = /usr/local