summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDidier Raboud <didier@raboud.com>2010-07-19 17:12:21 +0200
committerDidier Raboud <didier@raboud.com>2010-07-19 17:12:21 +0200
commit317d5e606ac1718f31cb58237e07e52772684376 (patch)
tree0240feffd597e574ed556245b1a394d94e9492c7
parent3352e98692c59df6f1cb78bde6f92de4c40d269c (diff)
Convert to tiny dh7 style.
-rw-r--r--debian/changelog6
-rw-r--r--debian/control2
-rw-r--r--debian/foomatic-filters.examples1
-rw-r--r--debian/foomatic-filters.links7
-rwxr-xr-xdebian/rules114
5 files changed, 22 insertions, 108 deletions
diff --git a/debian/changelog b/debian/changelog
index 031c2b7..64e0895 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,4 +1,4 @@
-foomatic-filters (4.0.4-1) UNRELEASED; urgency=low
+foomatic-filters (4.0.4-1+dh) UNRELEASED; urgency=low
* New upstream release.
@@ -14,13 +14,13 @@ foomatic-filters (4.0.4-1) UNRELEASED; urgency=low
* Add myself to Uploaders as I'll help Chris in maintaining foomatic-filters.
* Convert to 3.0 (quilt) source format.
- × * Convert to tiny dh7 style.
+ * Convert to tiny dh7 style.
* debian/watch: update.
× * Add Vcs-* fields with new packaging repository.
× * Update README.Debian.
× * Bump Standards to 3.9.0.0 - Rework some Conflicts/Replaces/Breaks.
- -- Didier Raboud <didier@raboud.com> Mon, 19 Jul 2010 15:08:19 +0200
+ -- Didier Raboud <didier@raboud.com> Mon, 19 Jul 2010 17:11:42 +0200
foomatic-filters (4.0.4-0ubuntu1) lucid; urgency=low
diff --git a/debian/control b/debian/control
index a075977..8111d34 100644
--- a/debian/control
+++ b/debian/control
@@ -3,7 +3,7 @@ Section: text
Priority: optional
Maintainer: Chris Lawrence <lawrencc@debian.org>
Uploaders: Didier Raboud <didier@raboud.com>
-Build-Depends: debhelper (>> 7), po-debconf, libgs-dev, perl, libcups2-dev
+Build-Depends: debhelper (>> 7.0.50~), po-debconf, libgs-dev, perl, libcups2-dev
Homepage: http://www.openprinting.org/
Standards-Version: 3.8.1
diff --git a/debian/foomatic-filters.examples b/debian/foomatic-filters.examples
new file mode 100644
index 0000000..930b11e
--- /dev/null
+++ b/debian/foomatic-filters.examples
@@ -0,0 +1 @@
+filter.conf
diff --git a/debian/foomatic-filters.links b/debian/foomatic-filters.links
new file mode 100644
index 0000000..e94bbad
--- /dev/null
+++ b/debian/foomatic-filters.links
@@ -0,0 +1,7 @@
+/usr/lib/ppr/lib/foomatic-rip /usr/lib/ppr/lib/ppromatic
+/usr/lib/ppr/interfaces/foomatic-rip /usr/lib/ppr/interfaces/ppromatic
+/usr/lib/cups/filter/foomatic-rip /usr/lib/cups/filter/cupsomatic
+/usr/bin/foomatic-rip /usr/sbin/lpdomatic
+/usr/bin/foomatic-rip /usr/bin/directomatic
+/usr/share/man/man1/foomatic-rip.1.gz /usr/share/man/man8/lpdomatic.8.gz
+/usr/share/man/man1/foomatic-rip.1.gz /usr/share/man/man1/directomatic.1.gz
diff --git a/debian/rules b/debian/rules
index 25752a3..99053ae 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,114 +1,20 @@
#!/usr/bin/make -f
-# Sample debian/rules that uses debhelper.
-# GNU copyright 1997 to 1999 by Joey Hess.
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
+derives_from_ubuntu := $(shell (dpkg-vendor --derives-from Ubuntu && echo "yes") || echo "no")
+%:
+ dh $@
+
-# These are used for cross-compiling and for saving the configure script
-# from having to guess our platform (since we know it already)
-DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
-DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+override_dh_auto_configure:
+ dh_auto_configure -- --disable-file-converter-check
-
-CFLAGS = -Wall -g
-
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
- CFLAGS += -O0
-else
- CFLAGS += -O2
-endif
-ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
- INSTALL_PROGRAM += -s
-endif
-
-config.status: configure
- dh_testdir
- # Add here commands to configure the package.
-ifneq "$(wildcard /usr/share/misc/config.sub)" ""
- cp -f /usr/share/misc/config.sub config.sub
-endif
-ifneq "$(wildcard /usr/share/misc/config.guess)" ""
- cp -f /usr/share/misc/config.guess config.guess
-endif
- ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info --sysconfdir=/etc --disable-file-converter-check
-
-
-build: build-stamp
-
-build-stamp: config.status
- dh_testdir
-
- # Add here commands to compile the package.
- $(MAKE)
-
- touch build-stamp
-
-clean:
- dh_testdir
- dh_testroot
- rm -f build-stamp config.sub config.guess tests/Makefile
-
- # Add here commands to clean up after the build process.
- [ ! -f Makefile ] || $(MAKE) distclean
+override_dh_auto_build:
+ dh_auto_build
chmod -x filter.conf
- debconf-updatepo
-
- dh_clean
-
-install: build
- dh_testdir
- dh_testroot
- dh_prep
- dh_installdirs
- # Add here commands to install the package into debian/foomatic-filters.
- $(MAKE) install DESTDIR=$(CURDIR)/debian/foomatic-filters
+override_dh_auto_install:
+ dh_auto_install
rm -f $(CURDIR)/debian/foomatic-filters/etc/foomatic/filter.conf*
cp -p debian/parseconfig.pl $(CURDIR)/debian/foomatic-filters/usr/share/foomatic
chmod +x $(CURDIR)/debian/foomatic-filters/usr/share/foomatic/parseconfig.pl
-
-# Build architecture-independent files here.
-binary-indep: build install
-# We have nothing to do by default.
-
-# Build architecture-dependent files here.
-binary-arch: build install
- dh_testdir
- dh_testroot
- dh_installchangelogs ChangeLog
- dh_installdocs
- dh_installexamples filter.conf
-# dh_install
-# dh_installmenu
- dh_installdebconf
-# dh_installlogrotate
-# dh_installemacsen
-# dh_installpam
-# dh_installmime
-# dh_installinit
-# dh_installcron
-# dh_installinfo
- dh_installman
- (cd $(CURDIR)/debian/foomatic-filters/usr/lib/ppr/lib; ln -s foomatic-rip ppromatic)
- (cd $(CURDIR)/debian/foomatic-filters/usr/lib/ppr/interfaces; ln -s foomatic-rip ppromatic)
- (cd $(CURDIR)/debian/foomatic-filters/usr/lib/cups/filter; ln -s foomatic-rip cupsomatic)
- (cd $(CURDIR)/debian/foomatic-filters/usr/sbin; ln -s ../bin/foomatic-rip lpdomatic)
- (cd $(CURDIR)/debian/foomatic-filters/usr/bin; ln -s foomatic-rip directomatic)
- (cd $(CURDIR)/debian/foomatic-filters/usr/share/man/man8; ln -s ../man1/foomatic-rip.1.gz lpdomatic.8.gz; cd ../man1; ln -s foomatic-rip.1.gz directomatic.1.gz)
- dh_link
- dh_strip
- dh_compress
- dh_fixperms
- dh_perl
-# dh_python
-# dh_makeshlibs
- dh_installdeb
- dh_shlibdeps
- dh_gencontrol
- dh_md5sums
- dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install