summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDidier Raboud <didier@raboud.com>2010-07-19 17:23:23 +0200
committerDidier Raboud <didier@raboud.com>2010-07-19 17:23:35 +0200
commitdbc258e9e690f2751c2841316b729a5367fe8f79 (patch)
tree222080257b9926245b2668e99df2cddec8fa76da
parent54f23d196b7cd440a6b545c88bb0334524fb2c5c (diff)
Install the apport hook on Ubuntu
-rw-r--r--debian/changelog6
-rwxr-xr-xdebian/rules9
-rw-r--r--debian/ubuntu/apport-hook.py11
3 files changed, 21 insertions, 5 deletions
diff --git a/debian/changelog b/debian/changelog
index 5ade25c..e065554 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,9 +1,9 @@
-foomatic-filters (4.0.4-1+dh) UNRELEASED; urgency=low
+foomatic-filters (4.0.4-1) UNRELEASED; urgency=low
* New upstream release.
* Merge from Ubuntu:
- × - Install the apport hook on Ubuntu
+ - Install the apport hook on Ubuntu
- Merge the changelog entries.
- Merge most package relationships.
- Merge package descriptions (Closes: #467380)
@@ -21,7 +21,7 @@ foomatic-filters (4.0.4-1+dh) UNRELEASED; urgency=low
* Update README.Debian.
× * Bump Standards to 3.9.0.0 - Rework some Conflicts/Replaces/Breaks.
- -- Didier Raboud <didier@raboud.com> Mon, 19 Jul 2010 17:14:52 +0200
+ -- Didier Raboud <didier@raboud.com> Mon, 19 Jul 2010 17:23:09 +0200
foomatic-filters (4.0.4-0ubuntu1) lucid; urgency=low
diff --git a/debian/rules b/debian/rules
index 99053ae..06d71d5 100755
--- a/debian/rules
+++ b/debian/rules
@@ -13,8 +13,13 @@ override_dh_auto_build:
dh_auto_build
chmod -x filter.conf
-override_dh_auto_install:
- dh_auto_install
+override_dh_install:
+ dh_install
+
rm -f $(CURDIR)/debian/foomatic-filters/etc/foomatic/filter.conf*
cp -p debian/parseconfig.pl $(CURDIR)/debian/foomatic-filters/usr/share/foomatic
chmod +x $(CURDIR)/debian/foomatic-filters/usr/share/foomatic/parseconfig.pl
+ # Install the apport hook on Ubuntu and derivatives
+ifeq ($(derives_from_ubuntu),yes)
+ install -D -m 644 debian/ubuntu/apport-hook.py $(CURDIR)/debian/foomatic-filters/usr/share/apport/package-hooks/source_foomatic-filters.py
+endif
diff --git a/debian/ubuntu/apport-hook.py b/debian/ubuntu/apport-hook.py
new file mode 100644
index 0000000..343d7a3
--- /dev/null
+++ b/debian/ubuntu/apport-hook.py
@@ -0,0 +1,11 @@
+'''apport package hook for foomatic-filters
+
+(c) 2009 Canonical Ltd.
+Author: Brian Murray <brian@ubuntu.com>
+'''
+
+from apport.hookutils import *
+
+def add_info(report):
+ attach_hardware(report)
+ attach_printing(report)