summaryrefslogtreecommitdiff
path: root/ChangeLog
diff options
context:
space:
mode:
Diffstat (limited to 'ChangeLog')
-rw-r--r--ChangeLog74
1 files changed, 74 insertions, 0 deletions
diff --git a/ChangeLog b/ChangeLog
index ed9eac8..53f992b 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,77 @@
+2010-08-10 Till Kamppeter <till.kamppeter@gmail.com>
+
+ * Tagged branch for release 4.0.5.
+
+ * VERSION, README, USAGE, configure.ac: Updated for release 4.0.5.
+
+2010-07-07 Till Kamppeter <till.kamppeter@gmail.com>
+
+ * options.c: Make substitution of zeros by the the user-defined
+ page size in the prototype string for the custom page size
+ working. Before, only substitution of %0 and %1 worked reliably.
+ Thanks to Lutz Sammer (johns98 at web dot de) for reporting this
+ problem.
+
+ * options.c: Make custom page size settings also work if the custom
+ size is set via embedded PostScript code and the comment to mark
+ the selected option setting is only "%% FoomaticRIPOptionSetting:
+ PageSize=Custom", without the size and unit parameters. Thanks to
+ Lutz Sammer for reporting this problem.
+
+2010-07-02 Till Kamppeter <till.kamppeter@gmail.com>
+
+ * spooler.c: Config file for the default printer in spooler-less
+ (direct) printing mode was not read correctly. Thanks to Lutz
+ Sammer (johns98 at web dot de) for reporting this problem.
+
+ * spooler.c: Fixed error message output if a printer's PPD is missing
+ in spooler-less mode. There was a segfault due to the printer name
+ not specified in the _log() function call. Thanks to Lutz Sammer
+ for reporting this problem.
+
+ * util.c: The isempty() function did not consider NULL as an empty
+ string. This caused segfaults when a string is considered non-empty
+ but in fact it is NULL. Thanks to Lutz Sammer for reporting this
+ problem.
+
+ * util.c: strncpy_tochar() did not check whether the input string
+ is empty and returned a pointer one character beyond the input
+ string, leading to segfaults in the code calling this function.
+ Thanks to Lutz Sammer for reporting this problem.
+
+2010-06-08 Till Kamppeter <till.kamppeter@gmail.com>
+
+ * USAGE: Documentation correction.
+
+2010-06-07 Till Kamppeter <till.kamppeter@gmail.com>
+
+ * USAGE: Finally completed the documentation update to reflect that
+ the Ghostscript library is not needed any more.
+
+ * configure.ac, util.h, util.c: Added implementation of strcasestr()
+ function for non-GNU systems (completes fix of bug #303, thanks
+ to Tim Mooney for this fix).
+
+ * foomaticrip.c, foomaticrip.h, pdf.c: Let foomatic-rip actually
+ error out if something goes wrong. It simply continued or closed
+ silently (exit status 0) on the following events: Failure of
+ print_file() function call, failure of Ghostscript to determine
+ the number of pages of a PDF input file (causes Ubuntu bug
+ #570522), failure to start Ghostscript to render a PDF file,
+ failure to create a temporary file for extracting selected pages
+ from a PDF file, failure to run Ghostscript to extract pages from
+ a PDF file, page count result being a negative number.
+
+ * foomaticrip.c: Use EXIT_PRINTED constant and not hard-coded "0"
+ as exit value when terminating successfully.
+
+ * foomaticrip.h: Correct definition of EXIT_STARVED constant.
+
+2010-03-26 Till Kamppeter <till.kamppeter@gmail.com>
+
+ * options.c, options.h: Made some strings longer, to avoid space
+ problems.
+
2010-02-15 Till Kamppeter <till.kamppeter@gmail.com>
* Tagged branch for release 4.0.4.