summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 03e437e..1f12fbb 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -53,6 +53,15 @@ foomatic_rip_SOURCES = \
fileconverter.c \
fileconverter.h
+if BUILD_DBUS
+foomatic_rip_SOURCES += \
+ colord.c \
+ colord.h
+
+foomatic_rip_CFLAGS = $(DBUS_CFLAGS) -DHAVE_DBUS
+foomatic_rip_LDADD = $(DBUS_LIBS)
+endif
+
AM_CPPFLAGS = -DCONFIG_PATH='"$(sysconfdir)/foomatic"'
# Masks for trash files which have to be removed before packaging Foomatic