summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlessandro Ghedini <al3xbio@gmail.com>2012-01-24 09:42:26 +0100
committerAlessandro Ghedini <al3xbio@gmail.com>2012-01-24 09:42:26 +0100
commitd1d354100822d77ff25ef9606d91a93062ecf234 (patch)
tree9e4bb8783e452b35c9e4586f1b0c9ab009cf1009 /CMakeLists.txt
parentb1677fafabacc4fa70296731552e9eb52ebe6f0b (diff)
parent21c8b0c749be00fff27e41e4c2d677dd7d320fa0 (diff)
Merge commit 'upstream/0.4.1'
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c1327bf..9e06bc7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -50,6 +50,7 @@ pkg_check_modules(XTST REQUIRED xtst)
pkg_check_modules(GMENU3 libgnome-menu-3.0)
find_library(M_LIB m)
+find_library(GTHREAD_LIB gthread-2.0)
set(CFLAGS
${GIO_CFLAGS}
@@ -81,9 +82,8 @@ endif (${GMENU3_FOUND})
if (${INDICATOR_FOUND})
LIST(APPEND CFLAGS -DHAVE_APPINDICATOR)
endif (${INDICATOR_FOUND})
-
if (${INDICATOR3_FOUND})
- LIST(APPEND CFLAGS -DHAVE_APPINDICATOR3)
+ LIST(APPEND CFLAGS -DHAVE_APPINDICATOR)
endif (${INDICATOR3_FOUND})
add_definitions(${CFLAGS})
@@ -105,6 +105,7 @@ set(LIBS
${WNCK_LIBRARIES}
${BAMF_LIBRARIES}
${M_LIB}
+ ${GTHREAD_LIB}
)
link_libraries(${LIBS})