summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorAlessandro Ghedini <al3xbio@gmail.com>2012-01-24 09:42:26 +0100
committerAlessandro Ghedini <al3xbio@gmail.com>2012-01-24 09:42:26 +0100
commitd1d354100822d77ff25ef9606d91a93062ecf234 (patch)
tree9e4bb8783e452b35c9e4586f1b0c9ab009cf1009 /src/CMakeLists.txt
parentb1677fafabacc4fa70296731552e9eb52ebe6f0b (diff)
parent21c8b0c749be00fff27e41e4c2d677dd7d320fa0 (diff)
Merge commit 'upstream/0.4.1'
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index b809c48..91ed3ab 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -6,11 +6,14 @@
file(GLOB VALA_SRC RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} *.vala */*.vala)
if (${INDICATOR_FOUND})
- SET(DEFINES --define HAVE_APPINDICATOR)
+ LIST(APPEND DEFINES --define HAVE_APPINDICATOR)
endif(${INDICATOR_FOUND})
+if (${INDICATOR3_FOUND})
+ LIST(APPEND DEFINES --define HAVE_APPINDICATOR)
+endif(${INDICATOR3_FOUND})
if (${GTK3_FOUND})
- SET(DEFINES --define HAVE_GTK_3)
+ LIST(APPEND DEFINES --define HAVE_GTK_3)
endif(${GTK3_FOUND})
if (${GMENU3_FOUND})