summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2017-07-24 19:58:27 +0200
committerJörg Frings-Fürst <debian@jff-webhosting.net>2017-07-24 19:58:27 +0200
commit5ad5531baa3ab7729427caf821fde6a6856da34e (patch)
tree016644484b3c5814879a0e910394e9b064d2b2d2 /src/CMakeLists.txt
parent394ad3b32f9f79775bcac4c6cc2a4dfa74586800 (diff)
parent309d161f6d464fcea2de200bb3cb5a7cb784b6d3 (diff)
Updated version 0.7.1 from 'upstream/0.7.1'
with Debian dir 55ec79e844cfb79babaf0535d64bfdb9bd5b22f7
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt13
1 files changed, 1 insertions, 12 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 4d1194f..fcbe1e9 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -5,17 +5,6 @@
# determine source and header files
file(GLOB VALA_SRC RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} *.vala */*.vala)
-if (${INDICATOR_FOUND})
- LIST(APPEND DEFINES --define HAVE_APPINDICATOR)
-endif(${INDICATOR_FOUND})
-if (${INDICATOR3_FOUND})
- LIST(APPEND DEFINES --define HAVE_APPINDICATOR)
-endif(${INDICATOR3_FOUND})
-
-if (${GMENU3_FOUND})
- LIST(APPEND DEFINES --define HAVE_GMENU_3)
-endif (${GMENU3_FOUND})
-
# use valac to compile sources to c files
vala_precompile(
VALA_C
@@ -24,7 +13,7 @@ vala_precompile(
${VALA_PKGS}
OPTIONS
--thread
- ${DEFINES}
+ ${VALA_DEFINES}
)
# compile c-sources