summaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/0100-fix-ftbfs_vala_0_42.patch66
-rw-r--r--debian/patches/0105-spelling_errors.patch590
-rw-r--r--debian/patches/0500_bamf3-vapi.patch203
-rw-r--r--debian/patches/0700-ayatana-appindicator.patch77
-rw-r--r--debian/patches/series4
5 files changed, 940 insertions, 0 deletions
diff --git a/debian/patches/0100-fix-ftbfs_vala_0_42.patch b/debian/patches/0100-fix-ftbfs_vala_0_42.patch
new file mode 100644
index 0000000..f60fbed
--- /dev/null
+++ b/debian/patches/0100-fix-ftbfs_vala_0_42.patch
@@ -0,0 +1,66 @@
+Description: Fix FTBFS with vala 0.42
+Origin: upstream, https://github.com/Simmesimme/Gnome-Pie/commit/86412ee09b7f8bc11f163bc8b6c3a061be279c43
+Bug: https://github.com/Simmesimme/Gnome-Pie/issues/164
+Bug-Debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=907943
+Forwarded: not-needed
+Last-Update: 2018-09-07
+--
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+Index: trunk/src/utilities/archiveReader.vala
+===================================================================
+--- trunk.orig/src/utilities/archiveReader.vala
++++ trunk/src/utilities/archiveReader.vala
+@@ -84,9 +84,13 @@ public class ArchiveReader : GLib.Object
+ if (entry.size() > 0) {
+ while (true) {
+ size_t offset, size;
+- void *buff;
++ uint8[] buff;
+
++#if VALA_0_42
++ r = this.archive.read_data_block(out buff, out offset);
++#else
+ r = this.archive.read_data_block(out buff, out size, out offset);
++#endif
+ if (r == Archive.Result.EOF) {
+ break;
+ }
+@@ -96,7 +100,11 @@ public class ArchiveReader : GLib.Object
+ return false;
+ }
+
++#if VALA_0_42
++ this.writer.write_data_block(buff, offset);
++#else
+ this.writer.write_data_block(buff, size, offset);
++#endif
+ }
+ }
+
+Index: trunk/src/utilities/archiveWriter.vala
+===================================================================
+--- trunk.orig/src/utilities/archiveWriter.vala
++++ trunk/src/utilities/archiveWriter.vala
+@@ -112,13 +112,17 @@ public class ArchiveWriter : GLib.Object
+ if (this.archive.write_header(entry) == Archive.Result.OK) {
+ try {
+ var reader = File.new_for_path(path).read();
+- uint8 buffer[4096];
++ uint8[] buffer = new uint8[4096];
+
+- var len = reader.read(buffer);
++ buffer.length = (int) reader.read(buffer);
+
+- while(len > 0) {
+- this.archive.write_data(buffer, len);
+- len = reader.read(buffer);
++ while(buffer.length > 0) {
++#if VALA_0_42
++ this.archive.write_data(buffer);
++#else
++ this.archive.write_data(buffer, buffer.length);
++#endif
++ buffer.length = (int) reader.read(buffer);
+ }
+
+ this.archive.finish_entry();
diff --git a/debian/patches/0105-spelling_errors.patch b/debian/patches/0105-spelling_errors.patch
new file mode 100644
index 0000000..3fefbb5
--- /dev/null
+++ b/debian/patches/0105-spelling_errors.patch
@@ -0,0 +1,590 @@
+Description: Fix spelling errors
+Author: Jörg Frings-Fürst <debian@jff.email>
+Forwarded: https://github.com/Simmesimme/Gnome-Pie/issues/165
+Last-Update: 2018-09-07
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+Index: trunk/resources/locale/bg/LC_MESSAGES/bg.po
+===================================================================
+--- trunk.orig/resources/locale/bg/LC_MESSAGES/bg.po
++++ trunk/resources/locale/bg/LC_MESSAGES/bg.po
+@@ -377,28 +377,28 @@ msgid ""
+ msgstr ""
+
+ #: ../../src/gui/preferencesWindow.vala:401
+-msgid "Sucessfully imported new theme!"
++msgid "Successfully imported new theme!"
+ msgstr ""
+
+ #: ../../src/gui/preferencesWindow.vala:415
+-msgid "An error occured while importing the theme: Failed to extract theme!"
++msgid "An error occurred while importing the theme: Failed to extract theme!"
+ msgstr ""
+
+ #: ../../src/gui/preferencesWindow.vala:419
+ msgid ""
+-"An error occured while importing the theme: A theme with this name does "
++"An error occurred while importing the theme: A theme with this name does "
+ "already exist!"
+ msgstr ""
+
+ #: ../../src/gui/preferencesWindow.vala:423
+ msgid ""
+-"An error occured while importing the theme: Theme archive does not contain a "
++"An error occurred while importing the theme: Theme archive does not contain a "
+ "valid theme!"
+ msgstr ""
+
+ #: ../../src/gui/preferencesWindow.vala:427
+ msgid ""
+-"An error occured while importing the theme: Failed to open theme archive!"
++"An error occurred while importing the theme: Failed to open theme archive!"
+ msgstr ""
+
+ #: ../../src/gui/preferencesWindow.vala:451
+@@ -584,7 +584,7 @@ msgstr ""
+
+ #: ../../src/themes/theme.vala:176
+ msgid ""
+-"An error occured while exporting the theme \"%s\"! Please check the console "
++"An error occurred while exporting the theme \"%s\"! Please check the console "
+ "output."
+ msgstr ""
+
+Index: trunk/resources/locale/de/LC_MESSAGES/de.po
+===================================================================
+--- trunk.orig/resources/locale/de/LC_MESSAGES/de.po
++++ trunk/resources/locale/de/LC_MESSAGES/de.po
+@@ -416,18 +416,18 @@ msgstr ""
+ "oder in dein Dock ziehen, um einen Starter zu erstellen!"
+
+ #: ../../src/gui/preferencesWindow.vala:401
+-msgid "Sucessfully imported new theme!"
++msgid "Successfully imported new theme!"
+ msgstr "Das neue Design wurde erfolgreich imprtiert!"
+
+ #: ../../src/gui/preferencesWindow.vala:415
+-msgid "An error occured while importing the theme: Failed to extract theme!"
++msgid "An error occurred while importing the theme: Failed to extract theme!"
+ msgstr ""
+ "Beim Importieren ist ein Fehler aufgetreten: Das Design konnte nicht "
+ "entpackt werden!"
+
+ #: ../../src/gui/preferencesWindow.vala:419
+ msgid ""
+-"An error occured while importing the theme: A theme with this name does "
++"An error occurred while importing the theme: A theme with this name does "
+ "already exist!"
+ msgstr ""
+ "Beim Importieren ist ein Fehler aufgetreten: Es existiert bereits ein Design "
+@@ -435,7 +435,7 @@ msgstr ""
+
+ #: ../../src/gui/preferencesWindow.vala:423
+ msgid ""
+-"An error occured while importing the theme: Theme archive does not contain a "
++"An error occurred while importing the theme: Theme archive does not contain a "
+ "valid theme!"
+ msgstr ""
+ "Beim Importieren ist ein Fehler aufgetreten: Das gwählte Archiv enthält kein "
+@@ -443,7 +443,7 @@ msgstr ""
+
+ #: ../../src/gui/preferencesWindow.vala:427
+ msgid ""
+-"An error occured while importing the theme: Failed to open theme archive!"
++"An error occurred while importing the theme: Failed to open theme archive!"
+ msgstr ""
+ "Beim Importieren ist ein Fehler aufgetreten: Das Archive konnte nicht "
+ "gelesen werden!"
+@@ -629,7 +629,7 @@ msgstr "Das Design \"%s\" wurde erfolgre
+
+ #: ../../src/themes/theme.vala:176
+ msgid ""
+-"An error occured while exporting the theme \"%s\"! Please check the console "
++"An error occurred while exporting the theme \"%s\"! Please check the console "
+ "output."
+ msgstr ""
+ "Beim Exportieren des Designs \"%s\" ist ein Fehler aufgetreten! Weitere "
+Index: trunk/resources/locale/es/LC_MESSAGES/es.po
+===================================================================
+--- trunk.orig/resources/locale/es/LC_MESSAGES/es.po
++++ trunk/resources/locale/es/LC_MESSAGES/es.po
+@@ -410,23 +410,23 @@ msgstr ""
+ "Pastel."
+
+ #: ../../src/gui/preferencesWindow.vala:401
+-msgid "Sucessfully imported new theme!"
++msgid "Successfully imported new theme!"
+ msgstr "El nuevo tema fue correctamente importado!"
+
+ #: ../../src/gui/preferencesWindow.vala:415
+-msgid "An error occured while importing the theme: Failed to extract theme!"
++msgid "An error occurred while importing the theme: Failed to extract theme!"
+ msgstr "Ocurrió un error al importar el tema: Falló la extracción del tema!"
+
+ #: ../../src/gui/preferencesWindow.vala:419
+ msgid ""
+-"An error occured while importing the theme: A theme with this name does "
++"An error occurred while importing the theme: A theme with this name does "
+ "already exist!"
+ msgstr ""
+ "Ocurrió un error al importar el tema: Ya existe un tema con ese nombre!"
+
+ #: ../../src/gui/preferencesWindow.vala:423
+ msgid ""
+-"An error occured while importing the theme: Theme archive does not contain a "
++"An error occurred while importing the theme: Theme archive does not contain a "
+ "valid theme!"
+ msgstr ""
+ "Ocurrió un error al importar el tema: El archivo no contiene un tema "
+@@ -434,7 +434,7 @@ msgstr ""
+
+ #: ../../src/gui/preferencesWindow.vala:427
+ msgid ""
+-"An error occured while importing the theme: Failed to open theme archive!"
++"An error occurred while importing the theme: Failed to open theme archive!"
+ msgstr ""
+ "Ocurrió un error al importar el tema: El archivo del tema no pudo ser "
+ "abierto!"
+@@ -622,7 +622,7 @@ msgstr "El tema %s fue exportado correct
+
+ #: ../../src/themes/theme.vala:176
+ msgid ""
+-"An error occured while exporting the theme \"%s\"! Please check the console "
++"An error occurred while exporting the theme \"%s\"! Please check the console "
+ "output."
+ msgstr ""
+ "Ocurrió un error al exportar el tema %s! Por favor verifique la consola."
+Index: trunk/resources/locale/fr/LC_MESSAGES/fr.po
+===================================================================
+--- trunk.orig/resources/locale/fr/LC_MESSAGES/fr.po
++++ trunk/resources/locale/fr/LC_MESSAGES/fr.po
+@@ -416,18 +416,18 @@ msgstr ""
+ "bureau ou votre dock pour créer un lanceur."
+
+ #: ../../src/gui/preferencesWindow.vala:401
+-msgid "Sucessfully imported new theme!"
++msgid "Successfully imported new theme!"
+ msgstr "Nouveau thème importé avec succès !"
+
+ #: ../../src/gui/preferencesWindow.vala:415
+-msgid "An error occured while importing the theme: Failed to extract theme!"
++msgid "An error occurred while importing the theme: Failed to extract theme!"
+ msgstr ""
+ "Une erreur est survenue pendant l'importation du thème : impossible "
+ "d'extraire le thème !"
+
+ #: ../../src/gui/preferencesWindow.vala:419
+ msgid ""
+-"An error occured while importing the theme: A theme with this name does "
++"An error occurred while importing the theme: A theme with this name does "
+ "already exist!"
+ msgstr ""
+ "Une erreur est survenue pendant l'importation du thème : Un thème avec ce "
+@@ -435,7 +435,7 @@ msgstr ""
+
+ #: ../../src/gui/preferencesWindow.vala:423
+ msgid ""
+-"An error occured while importing the theme: Theme archive does not contain a "
++"An error occurred while importing the theme: Theme archive does not contain a "
+ "valid theme!"
+ msgstr ""
+ "Une erreur est survenue pendant l'importation du thème : L'archive ne "
+@@ -443,7 +443,7 @@ msgstr ""
+
+ #: ../../src/gui/preferencesWindow.vala:427
+ msgid ""
+-"An error occured while importing the theme: Failed to open theme archive!"
++"An error occurred while importing the theme: Failed to open theme archive!"
+ msgstr ""
+ "Une erreur est survenue pendant l'importation du thème : Impossible d'ouvrir "
+ "l'archive !"
+@@ -632,7 +632,7 @@ msgstr "Thème \"%s\" exporté avec succ
+
+ #: ../../src/themes/theme.vala:176
+ msgid ""
+-"An error occured while exporting the theme \"%s\"! Please check the console "
++"An error occurred while exporting the theme \"%s\"! Please check the console "
+ "output."
+ msgstr ""
+ "Une erreur est survenue pendant l'importation du thème \"%s\" : Plus "
+Index: trunk/resources/locale/it/LC_MESSAGES/it.po
+===================================================================
+--- trunk.orig/resources/locale/it/LC_MESSAGES/it.po
++++ trunk/resources/locale/it/LC_MESSAGES/it.po
+@@ -378,28 +378,28 @@ msgid ""
+ msgstr ""
+
+ #: ../../src/gui/preferencesWindow.vala:401
+-msgid "Sucessfully imported new theme!"
++msgid "Successfully imported new theme!"
+ msgstr ""
+
+ #: ../../src/gui/preferencesWindow.vala:415
+-msgid "An error occured while importing the theme: Failed to extract theme!"
++msgid "An error occurred while importing the theme: Failed to extract theme!"
+ msgstr ""
+
+ #: ../../src/gui/preferencesWindow.vala:419
+ msgid ""
+-"An error occured while importing the theme: A theme with this name does "
++"An error occurred while importing the theme: A theme with this name does "
+ "already exist!"
+ msgstr ""
+
+ #: ../../src/gui/preferencesWindow.vala:423
+ msgid ""
+-"An error occured while importing the theme: Theme archive does not contain a "
++"An error occurred while importing the theme: Theme archive does not contain a "
+ "valid theme!"
+ msgstr ""
+
+ #: ../../src/gui/preferencesWindow.vala:427
+ msgid ""
+-"An error occured while importing the theme: Failed to open theme archive!"
++"An error occurred while importing the theme: Failed to open theme archive!"
+ msgstr ""
+
+ #: ../../src/gui/preferencesWindow.vala:451
+@@ -589,7 +589,7 @@ msgstr ""
+
+ #: ../../src/themes/theme.vala:176
+ msgid ""
+-"An error occured while exporting the theme \"%s\"! Please check the console "
++"An error occurred while exporting the theme \"%s\"! Please check the console "
+ "output."
+ msgstr ""
+
+Index: trunk/resources/locale/ko/LC_MESSAGES/ko.po
+===================================================================
+--- trunk.orig/resources/locale/ko/LC_MESSAGES/ko.po
++++ trunk/resources/locale/ko/LC_MESSAGES/ko.po
+@@ -367,28 +367,28 @@ msgid ""
+ msgstr ""
+
+ #: ../../src/gui/preferencesWindow.vala:401
+-msgid "Sucessfully imported new theme!"
++msgid "Successfully imported new theme!"
+ msgstr ""
+
+ #: ../../src/gui/preferencesWindow.vala:415
+-msgid "An error occured while importing the theme: Failed to extract theme!"
++msgid "An error occurred while importing the theme: Failed to extract theme!"
+ msgstr ""
+
+ #: ../../src/gui/preferencesWindow.vala:419
+ msgid ""
+-"An error occured while importing the theme: A theme with this name does "
++"An error occurred while importing the theme: A theme with this name does "
+ "already exist!"
+ msgstr ""
+
+ #: ../../src/gui/preferencesWindow.vala:423
+ msgid ""
+-"An error occured while importing the theme: Theme archive does not contain a "
++"An error occurred while importing the theme: Theme archive does not contain a "
+ "valid theme!"
+ msgstr ""
+
+ #: ../../src/gui/preferencesWindow.vala:427
+ msgid ""
+-"An error occured while importing the theme: Failed to open theme archive!"
++"An error occurred while importing the theme: Failed to open theme archive!"
+ msgstr ""
+
+ #: ../../src/gui/preferencesWindow.vala:451
+@@ -571,7 +571,7 @@ msgstr ""
+
+ #: ../../src/themes/theme.vala:176
+ msgid ""
+-"An error occured while exporting the theme \"%s\"! Please check the console "
++"An error occurred while exporting the theme \"%s\"! Please check the console "
+ "output."
+ msgstr ""
+
+Index: trunk/resources/locale/lt/LC_MESSAGES/lt.po
+===================================================================
+--- trunk.orig/resources/locale/lt/LC_MESSAGES/lt.po
++++ trunk/resources/locale/lt/LC_MESSAGES/lt.po
+@@ -417,29 +417,29 @@ msgstr ""
+ "sukurtumėte šio pyrago leistuką."
+
+ #: ../../src/gui/preferencesWindow.vala:401
+-msgid "Sucessfully imported new theme!"
++msgid "Successfully imported new theme!"
+ msgstr "Nauja tema buvo sėkmingai importuota!"
+
+ #: ../../src/gui/preferencesWindow.vala:415
+-msgid "An error occured while importing the theme: Failed to extract theme!"
++msgid "An error occurred while importing the theme: Failed to extract theme!"
+ msgstr "Importuojant temą, įvyko klaida: Nepavyko išskleisti temos!"
+
+ #: ../../src/gui/preferencesWindow.vala:419
+ msgid ""
+-"An error occured while importing the theme: A theme with this name does "
++"An error occurred while importing the theme: A theme with this name does "
+ "already exist!"
+ msgstr "Importuojant temą, įvyko klaida: Tema tokiu pavadinimu jau yra!"
+
+ #: ../../src/gui/preferencesWindow.vala:423
+ msgid ""
+-"An error occured while importing the theme: Theme archive does not contain a "
++"An error occurred while importing the theme: Theme archive does not contain a "
+ "valid theme!"
+ msgstr ""
+ "Importuojant temą, įvyko klaida: Temos archyve nėra taisyklingos temos!"
+
+ #: ../../src/gui/preferencesWindow.vala:427
+ msgid ""
+-"An error occured while importing the theme: Failed to open theme archive!"
++"An error occurred while importing the theme: Failed to open theme archive!"
+ msgstr "Importuojant temą, įvyko klaida: Nepavyko atverti temos archyvo!"
+
+ #: ../../src/gui/preferencesWindow.vala:451
+@@ -624,7 +624,7 @@ msgstr "\"%s\" tema buvo sėkmingai eksp
+
+ #: ../../src/themes/theme.vala:176
+ msgid ""
+-"An error occured while exporting the theme \"%s\"! Please check the console "
++"An error occurred while exporting the theme \"%s\"! Please check the console "
+ "output."
+ msgstr "Eksportuojant \"%s\" temą, įvyko klaida! Prašome žiūrėti pulto išvestį."
+
+Index: trunk/resources/locale/pl/LC_MESSAGES/pl.po
+===================================================================
+--- trunk.orig/resources/locale/pl/LC_MESSAGES/pl.po
++++ trunk/resources/locale/pl/LC_MESSAGES/pl.po
+@@ -386,28 +386,28 @@ msgid ""
+ msgstr ""
+
+ #: ../../src/gui/preferencesWindow.vala:401
+-msgid "Sucessfully imported new theme!"
++msgid "Successfully imported new theme!"
+ msgstr ""
+
+ #: ../../src/gui/preferencesWindow.vala:415
+-msgid "An error occured while importing the theme: Failed to extract theme!"
++msgid "An error occurred while importing the theme: Failed to extract theme!"
+ msgstr ""
+
+ #: ../../src/gui/preferencesWindow.vala:419
+ msgid ""
+-"An error occured while importing the theme: A theme with this name does "
++"An error occurred while importing the theme: A theme with this name does "
+ "already exist!"
+ msgstr ""
+
+ #: ../../src/gui/preferencesWindow.vala:423
+ msgid ""
+-"An error occured while importing the theme: Theme archive does not contain a "
++"An error occurred while importing the theme: Theme archive does not contain a "
+ "valid theme!"
+ msgstr ""
+
+ #: ../../src/gui/preferencesWindow.vala:427
+ msgid ""
+-"An error occured while importing the theme: Failed to open theme archive!"
++"An error occurred while importing the theme: Failed to open theme archive!"
+ msgstr ""
+
+ #: ../../src/gui/preferencesWindow.vala:451
+@@ -588,7 +588,7 @@ msgstr ""
+
+ #: ../../src/themes/theme.vala:176
+ msgid ""
+-"An error occured while exporting the theme \"%s\"! Please check the console "
++"An error occurred while exporting the theme \"%s\"! Please check the console "
+ "output."
+ msgstr ""
+
+Index: trunk/resources/locale/pt_BR/LC_MESSAGES/pt_BR.po
+===================================================================
+--- trunk.orig/resources/locale/pt_BR/LC_MESSAGES/pt_BR.po
++++ trunk/resources/locale/pt_BR/LC_MESSAGES/pt_BR.po
+@@ -376,28 +376,28 @@ msgid ""
+ msgstr ""
+
+ #: ../../src/gui/preferencesWindow.vala:401
+-msgid "Sucessfully imported new theme!"
++msgid "Successfully imported new theme!"
+ msgstr ""
+
+ #: ../../src/gui/preferencesWindow.vala:415
+-msgid "An error occured while importing the theme: Failed to extract theme!"
++msgid "An error occurred while importing the theme: Failed to extract theme!"
+ msgstr ""
+
+ #: ../../src/gui/preferencesWindow.vala:419
+ msgid ""
+-"An error occured while importing the theme: A theme with this name does "
++"An error occurred while importing the theme: A theme with this name does "
+ "already exist!"
+ msgstr ""
+
+ #: ../../src/gui/preferencesWindow.vala:423
+ msgid ""
+-"An error occured while importing the theme: Theme archive does not contain a "
++"An error occurred while importing the theme: Theme archive does not contain a "
+ "valid theme!"
+ msgstr ""
+
+ #: ../../src/gui/preferencesWindow.vala:427
+ msgid ""
+-"An error occured while importing the theme: Failed to open theme archive!"
++"An error occurred while importing the theme: Failed to open theme archive!"
+ msgstr ""
+
+ #: ../../src/gui/preferencesWindow.vala:451
+@@ -582,7 +582,7 @@ msgstr ""
+
+ #: ../../src/themes/theme.vala:176
+ msgid ""
+-"An error occured while exporting the theme \"%s\"! Please check the console "
++"An error occurred while exporting the theme \"%s\"! Please check the console "
+ "output."
+ msgstr ""
+
+Index: trunk/resources/locale/ru/LC_MESSAGES/ru.po
+===================================================================
+--- trunk.orig/resources/locale/ru/LC_MESSAGES/ru.po
++++ trunk/resources/locale/ru/LC_MESSAGES/ru.po
+@@ -408,29 +408,29 @@ msgstr ""
+ "чтобы создать ярлык запуска для этого Пая."
+
+ #: ../../src/gui/preferencesWindow.vala:401
+-msgid "Sucessfully imported new theme!"
++msgid "Successfully imported new theme!"
+ msgstr "Успешно импортирована новая тема!"
+
+ #: ../../src/gui/preferencesWindow.vala:415
+-msgid "An error occured while importing the theme: Failed to extract theme!"
++msgid "An error occurred while importing the theme: Failed to extract theme!"
+ msgstr "При импорте темы произошла ошибка: Не удалось извлечь тему!"
+
+ #: ../../src/gui/preferencesWindow.vala:419
+ msgid ""
+-"An error occured while importing the theme: A theme with this name does "
++"An error occurred while importing the theme: A theme with this name does "
+ "already exist!"
+ msgstr "При импорте темы произошла ошибка: тема с этим именем уже существует!"
+
+ #: ../../src/gui/preferencesWindow.vala:423
+ msgid ""
+-"An error occured while importing the theme: Theme archive does not contain a "
++"An error occurred while importing the theme: Theme archive does not contain a "
+ "valid theme!"
+ msgstr ""
+ "При импорте темы произошла ошибка: в архиве темы нет действительной темы!"
+
+ #: ../../src/gui/preferencesWindow.vala:427
+ msgid ""
+-"An error occured while importing the theme: Failed to open theme archive!"
++"An error occurred while importing the theme: Failed to open theme archive!"
+ msgstr "При импорте темы произошла ошибка: Не удалось открыть тему!"
+
+ #: ../../src/gui/preferencesWindow.vala:451
+@@ -616,7 +616,7 @@ msgstr "Тема экспортиров
+
+ #: ../../src/themes/theme.vala:176
+ msgid ""
+-"An error occured while exporting the theme \"%s\"! Please check the console "
++"An error occurred while exporting the theme \"%s\"! Please check the console "
+ "output."
+ msgstr "При экспорте темы произошла ошибка \"%s\"! Проверьте вывод консоли."
+
+Index: trunk/resources/locale/zh_CN/LC_MESSAGES/zh_CN.po
+===================================================================
+--- trunk.orig/resources/locale/zh_CN/LC_MESSAGES/zh_CN.po
++++ trunk/resources/locale/zh_CN/LC_MESSAGES/zh_CN.po
+@@ -367,28 +367,28 @@ msgid ""
+ msgstr ""
+
+ #: ../../src/gui/preferencesWindow.vala:401
+-msgid "Sucessfully imported new theme!"
++msgid "Successfully imported new theme!"
+ msgstr ""
+
+ #: ../../src/gui/preferencesWindow.vala:415
+-msgid "An error occured while importing the theme: Failed to extract theme!"
++msgid "An error occurred while importing the theme: Failed to extract theme!"
+ msgstr ""
+
+ #: ../../src/gui/preferencesWindow.vala:419
+ msgid ""
+-"An error occured while importing the theme: A theme with this name does "
++"An error occurred while importing the theme: A theme with this name does "
+ "already exist!"
+ msgstr ""
+
+ #: ../../src/gui/preferencesWindow.vala:423
+ msgid ""
+-"An error occured while importing the theme: Theme archive does not contain a "
++"An error occurred while importing the theme: Theme archive does not contain a "
+ "valid theme!"
+ msgstr ""
+
+ #: ../../src/gui/preferencesWindow.vala:427
+ msgid ""
+-"An error occured while importing the theme: Failed to open theme archive!"
++"An error occurred while importing the theme: Failed to open theme archive!"
+ msgstr ""
+
+ #: ../../src/gui/preferencesWindow.vala:451
+@@ -571,7 +571,7 @@ msgstr ""
+
+ #: ../../src/themes/theme.vala:176
+ msgid ""
+-"An error occured while exporting the theme \"%s\"! Please check the console "
++"An error occurred while exporting the theme \"%s\"! Please check the console "
+ "output."
+ msgstr ""
+
+Index: trunk/src/gui/preferencesWindow.vala
+===================================================================
+--- trunk.orig/src/gui/preferencesWindow.vala
++++ trunk/src/gui/preferencesWindow.vala
+@@ -398,7 +398,7 @@ public class PreferencesWindow : GLib.Ob
+ dialog.filter.add_pattern ("*.tar.gz");
+
+ var result = Gtk.MessageType.INFO;
+- var message = _("Sucessfully imported new theme!");
++ var message = _("Successfully imported new theme!");
+
+ dialog.response.connect((d, r) => {
+ if (r == Gtk.ResponseType.ACCEPT) {
+@@ -412,19 +412,19 @@ public class PreferencesWindow : GLib.Ob
+ Config.global.load_themes(a.theme_name);
+ this.theme_list.reload();
+ } else {
+- message = _("An error occured while importing the theme: Failed to extract theme!");
++ message = _("An error occurred while importing the theme: Failed to extract theme!");
+ result = Gtk.MessageType.ERROR;
+ }
+ } else {
+- message = _("An error occured while importing the theme: A theme with this name does already exist!");
++ message = _("An error occurred while importing the theme: A theme with this name does already exist!");
+ result = Gtk.MessageType.ERROR;
+ }
+ } else {
+- message = _("An error occured while importing the theme: Theme archive does not contain a valid theme!");
++ message = _("An error occurred while importing the theme: Theme archive does not contain a valid theme!");
+ result = Gtk.MessageType.ERROR;
+ }
+ } else {
+- message = _("An error occured while importing the theme: Failed to open theme archive!");
++ message = _("An error occurred while importing the theme: Failed to open theme archive!");
+ result = Gtk.MessageType.ERROR;
+ }
+ a.close();
+Index: trunk/src/themes/theme.vala
+===================================================================
+--- trunk.orig/src/themes/theme.vala
++++ trunk/src/themes/theme.vala
+@@ -173,7 +173,7 @@ public class Theme : GLib.Object {
+ dialog.destroy();
+
+ } else {
+- var message = _("An error occured while exporting the theme \"%s\"! Please check the console output.").printf(this.name);
++ var message = _("An error occurred while exporting the theme \"%s\"! Please check the console output.").printf(this.name);
+ var dialog = new Gtk.MessageDialog(null, Gtk.DialogFlags.MODAL,
+ Gtk.MessageType.ERROR, Gtk.ButtonsType.CLOSE, message);
+ dialog.run();
diff --git a/debian/patches/0500_bamf3-vapi.patch b/debian/patches/0500_bamf3-vapi.patch
new file mode 100644
index 0000000..f185cfe
--- /dev/null
+++ b/debian/patches/0500_bamf3-vapi.patch
@@ -0,0 +1,203 @@
+Description: Add libbamf3.vapi to prevent build errors
+Author: Jörg Frings-Fürst <debian@jff-webhosting.net>
+Last-Update: 2015-05-11>
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+Index: trunk/vapi/libbamf3.vapi
+===================================================================
+--- /dev/null
++++ trunk/vapi/libbamf3.vapi
+@@ -0,0 +1,181 @@
++/* libbamf3.vapi generated by vapigen, do not modify. */
++
++[CCode (cprefix = "Bamf", gir_namespace = "Bamf", gir_version = "3", lower_case_cprefix = "bamf_")]
++namespace Bamf {
++ [CCode (cheader_filename = "libbamf/libbamf.h", type_id = "bamf_application_get_type ()")]
++ public class Application : Bamf.View {
++ [CCode (has_construct_function = false)]
++ protected Application ();
++ public bool get_application_menu (string name, string object_path);
++ public unowned string get_application_type ();
++ public unowned string get_desktop_file ();
++ public unowned Bamf.View get_focusable_child ();
++ public bool get_show_menu_stubs ();
++ [CCode (array_length = false, array_null_terminated = true)]
++ public string[] get_supported_mime_types ();
++ public GLib.List<weak Bamf.Window> get_windows ();
++ public GLib.Array<uint32> get_xids ();
++ public signal void window_added (Bamf.View object);
++ public signal void window_removed (Bamf.View object);
++ }
++ [CCode (cheader_filename = "libbamf/libbamf.h", type_id = "bamf_control_get_type ()")]
++ public class Control : GLib.Object {
++ [CCode (has_construct_function = false)]
++ protected Control ();
++ public static unowned Bamf.Control get_default ();
++ public void insert_desktop_file (string desktop_file);
++ public void register_application_for_pid (string application, int32 pid);
++ public void register_tab_provider (string path);
++ }
++ [CCode (cheader_filename = "libbamf/libbamf.h", type_id = "bamf_matcher_get_type ()")]
++ public class Matcher : GLib.Object {
++ [CCode (has_construct_function = false)]
++ protected Matcher ();
++ public bool application_is_running (string application);
++ public unowned Bamf.Application get_active_application ();
++ public unowned Bamf.Window get_active_window ();
++ public unowned Bamf.Application get_application_for_desktop_file (string desktop_file_path, bool create_if_not_found);
++ public unowned Bamf.Application get_application_for_window (Bamf.Window window);
++ public unowned Bamf.Application get_application_for_xid (uint32 xid);
++ public GLib.List<weak Bamf.Application> get_applications ();
++ public static Bamf.Matcher get_default ();
++ public GLib.List<weak Bamf.Application> get_running_applications ();
++ public GLib.List<weak Bamf.View> get_tabs ();
++ public GLib.List<weak Bamf.View> get_window_stack_for_monitor (int monitor);
++ public GLib.List<weak Bamf.View> get_windows ();
++ public GLib.Array<uint32> get_xids_for_application (string application);
++ public void register_favorites ([CCode (array_length = false)] string[] favorites);
++ public signal void active_application_changed (Bamf.View object, Bamf.View p0);
++ public signal void active_window_changed (Bamf.View object, Bamf.View p0);
++ public signal void stacking_order_changed ();
++ public signal void view_closed (Bamf.View object);
++ public signal void view_opened (Bamf.View object);
++ }
++ [CCode (cheader_filename = "libbamf/libbamf.h", type_id = "bamf_tab_get_type ()")]
++ public class Tab : Bamf.View {
++ [CCode (has_construct_function = false)]
++ public Tab (string path);
++ public bool close ();
++ public virtual unowned string get_desktop_name ();
++ public virtual bool get_is_foreground_tab ();
++ public virtual unowned string get_location ();
++ public virtual uint64 get_xid ();
++ public bool raise ();
++ [NoAccessorMethod]
++ public string desktop_id { owned get; set; }
++ [NoAccessorMethod]
++ public bool is_foreground_tab { get; set; }
++ [NoAccessorMethod]
++ public string location { owned get; set; }
++ [NoAccessorMethod]
++ public uint64 xid { get; set; }
++ }
++ [CCode (cheader_filename = "libbamf/libbamf.h", type_id = "bamf_tab_source_get_type ()")]
++ public class TabSource : GLib.Object {
++ [CCode (has_construct_function = false)]
++ protected TabSource ();
++ [CCode (array_length = false, array_null_terminated = true)]
++ public unowned string[] get_tab_ids ();
++ public string get_tab_uri (string tab_id);
++ public uint32 get_tab_xid (string tab_id);
++ [NoWrapper]
++ public virtual string tab_uri (string tab_id);
++ [NoWrapper]
++ public virtual uint32 tab_xid (string tab_id);
++ [NoAccessorMethod]
++ public string id { owned get; set construct; }
++ public signal void tab_closed (string object);
++ public signal void tab_opened (string object);
++ public signal void tab_uri_changed (string object, string p0, string p1);
++ }
++ [CCode (cheader_filename = "libbamf/libbamf.h", type_id = "bamf_view_get_type ()")]
++ public class View : GLib.InitiallyUnowned {
++ [CCode (has_construct_function = false)]
++ protected View ();
++ [NoWrapper]
++ public virtual Bamf.ClickBehavior click_behavior ();
++ public virtual GLib.List<weak Bamf.View> get_children ();
++ public Bamf.ClickBehavior get_click_suggestion ();
++ public virtual string get_icon ();
++ public virtual string get_name ();
++ [CCode (vfunc_name = "view_type")]
++ public virtual unowned string get_view_type ();
++ public virtual bool is_active ();
++ public bool is_closed ();
++ public virtual bool is_running ();
++ public bool is_sticky ();
++ public virtual bool is_urgent ();
++#if !HAVE_BAMF_0_4
++ [CCode (cname = "bamf_view_user_visible")]
++#endif
++ public bool is_user_visible ();
++ [NoWrapper]
++ public virtual void set_path (string path);
++ public void set_sticky (bool value);
++ [NoAccessorMethod]
++ public bool active { get; }
++ [NoAccessorMethod]
++ public string path { owned get; }
++ [NoAccessorMethod]
++ public bool running { get; }
++ [NoAccessorMethod]
++ public bool urgent { get; }
++ [NoAccessorMethod]
++ public bool user_visible { get; }
++ public virtual signal void active_changed (bool active);
++ public virtual signal void child_added (Bamf.View child);
++ public virtual signal void child_moved (Bamf.View child);
++ public virtual signal void child_removed (Bamf.View child);
++ public virtual signal void closed ();
++ public virtual signal void name_changed (string old_name, string new_name);
++ public virtual signal void running_changed (bool running);
++ public virtual signal void urgent_changed (bool urgent);
++ public virtual signal void user_visible_changed (bool user_visible);
++ }
++ [CCode (cheader_filename = "libbamf/libbamf.h", type_id = "bamf_window_get_type ()")]
++ public class Window : Bamf.View {
++ [CCode (has_construct_function = false)]
++ protected Window ();
++ public virtual int get_monitor ();
++ public virtual uint32 get_pid ();
++ public virtual unowned Bamf.Window get_transient ();
++ public virtual string get_utf8_prop (string prop);
++ public virtual Bamf.WindowType get_window_type ();
++ public virtual uint32 get_xid ();
++ public virtual long last_active ();
++ public virtual Bamf.WindowMaximizationType maximized ();
++ public virtual signal void maximized_changed (int old_value, int new_value);
++ public virtual signal void monitor_changed (int old_value, int new_value);
++ }
++ [CCode (cheader_filename = "libbamf/libbamf.h", cprefix = "BAMF_CLICK_BEHAVIOR_", has_type_id = false)]
++ public enum ClickBehavior {
++ NONE,
++ OPEN,
++ FOCUS,
++ FOCUS_ALL,
++ MINIMIZE,
++ RESTORE,
++ RESTORE_ALL,
++ PICKER
++ }
++ [CCode (cheader_filename = "libbamf/libbamf.h", cprefix = "BAMF_WINDOW_", has_type_id = false)]
++ public enum WindowMaximizationType {
++ FLOATING,
++ HORIZONTAL_MAXIMIZED,
++ VERTICAL_MAXIMIZED,
++ MAXIMIZED
++ }
++ [CCode (cheader_filename = "libbamf/libbamf.h", cprefix = "BAMF_WINDOW_", has_type_id = false)]
++ public enum WindowType {
++ NORMAL,
++ DESKTOP,
++ DOCK,
++ DIALOG,
++ TOOLBAR,
++ MENU,
++ UTILITY,
++ SPLASHSCREEN
++ }
++ [CCode (cheader_filename = "libbamf/libbamf.h", instance_pos = 2.9)]
++ public delegate void TabPreviewReadyCallback (Bamf.Tab self, string preview_data);
++}
+Index: trunk/src/CMakeLists.txt
+===================================================================
+--- trunk.orig/src/CMakeLists.txt
++++ trunk/src/CMakeLists.txt
+@@ -23,6 +23,7 @@ vala_precompile(
+ PACKAGES
+ ${VALA_PKGS}
+ OPTIONS
++ --vapidir=${CMAKE_SOURCE_DIR}/vapi/
+ --thread
+ ${DEFINES}
+ )
diff --git a/debian/patches/0700-ayatana-appindicator.patch b/debian/patches/0700-ayatana-appindicator.patch
new file mode 100644
index 0000000..d8a9905
--- /dev/null
+++ b/debian/patches/0700-ayatana-appindicator.patch
@@ -0,0 +1,77 @@
+Description: Switch to Ayatana AppIndicator
+Author: Mike Gabriel <mike.gabriel@das-netzwerkteam.de>
+Bug-Debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=907551
+Forwarded: not-needed
+Last-Update: 2018-09-07
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -26,7 +26,7 @@
+ find_package(PkgConfig)
+
+ pkg_check_modules(GTK3 REQUIRED gtk+-3.0)
+-pkg_check_modules(INDICATOR3 appindicator3-0.1)
++pkg_check_modules(INDICATOR3 ayatana-appindicator3-0.1)
+ pkg_check_modules(WNCK REQUIRED libwnck-3.0)
+ pkg_check_modules(BAMF libbamf3)
+ pkg_check_modules(GIO REQUIRED gio-unix-2.0)
+@@ -75,11 +75,7 @@
+ pkg_check_modules(GMENU REQUIRED libgnome-menu)
+ endif (${GMENU3_FOUND})
+
+-# notify application of presence of libappindicator
+-if (${INDICATOR_FOUND})
+- LIST(APPEND CFLAGS -DHAVE_APPINDICATOR)
+- LIST(APPEND VALA_DEFINES --define HAVE_APPINDICATOR)
+-endif (${INDICATOR_FOUND})
++# notify application of presence of libayatana-appindicator
+ if (${INDICATOR3_FOUND})
+ LIST(APPEND CFLAGS -DHAVE_APPINDICATOR)
+ LIST(APPEND VALA_DEFINES --define HAVE_APPINDICATOR)
+@@ -97,7 +93,6 @@
+ ${GTK3_LIBRARIES}
+ ${CAIRO_LIBRARIES}
+ ${GEE_LIBRARIES}
+- ${INDICATOR_LIBRARIES}
+ ${INDICATOR3_LIBRARIES}
+ ${XML_LIBRARIES}
+ ${XTST_LIBRARIES}
+@@ -117,7 +112,6 @@
+ ${GTK3_LIBRARY_DIRS}
+ ${CAIRO_LIBRARY_DIRS}
+ ${GEE_LIBRARY_DIRS}
+- ${INDICATOR_LIBRARY_DIRS}
+ ${INDICATOR3_LIBRARY_DIRS}
+ ${XML_LIBRARY_DIRS}
+ ${XTST_LIBRARY_DIRS}
+@@ -134,7 +128,6 @@
+ ${GTK3_INCLUDE_DIRS}
+ ${CAIRO_INCLUDE_DIRS}
+ ${GEE_INCLUDE_DIRS}
+- ${INDICATOR_INCLUDE_DIRS}
+ ${INDICATOR3_INCLUDE_DIRS}
+ ${XML_INCLUDE_DIRS}
+ ${XTST_INCLUDE_DIRS}
+@@ -166,12 +159,8 @@
+ libarchive
+ )
+
+-if (${INDICATOR_FOUND})
+- LIST(APPEND VALA_PKGS appindicator-0.1)
+-endif (${INDICATOR_FOUND})
+-
+ if (${INDICATOR3_FOUND})
+- LIST(APPEND VALA_PKGS appindicator3-0.1)
++ LIST(APPEND VALA_PKGS ayatana-appindicator3-0.1)
+ endif (${INDICATOR3_FOUND})
+
+ if (${GMENU3_FOUND})
+@@ -210,7 +199,6 @@
+ message( " GTK3_LIBRARIES = ${GTK3_LIBRARIES}" )
+ message( " CAIRO_LIBRARIES = ${CAIRO_LIBRARIES}" )
+ message( " GEE_LIBRARIES = ${GEE_LIBRARIES}" )
+-message( " INDICATOR_LIBRARIES = ${INDICATOR_LIBRARIES}" )
+ message( " INDICATOR3_LIBRARIES = ${INDICATOR3_LIBRARIES}" )
+ message( " XML_LIBRARIES = ${XML_LIBRARIES}" )
+ message( " XTST_LIBRARIES = ${XTST_LIBRARIES}" )
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..5d085d7
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1,4 @@
+#0500_bamf3-vapi.patch
+0700-ayatana-appindicator.patch
+0105-spelling_errors.patch
+0100-fix-ftbfs_vala_0_42.patch