summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index b809c48..91ed3ab 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -6,11 +6,14 @@
file(GLOB VALA_SRC RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} *.vala */*.vala)
if (${INDICATOR_FOUND})
- SET(DEFINES --define HAVE_APPINDICATOR)
+ LIST(APPEND DEFINES --define HAVE_APPINDICATOR)
endif(${INDICATOR_FOUND})
+if (${INDICATOR3_FOUND})
+ LIST(APPEND DEFINES --define HAVE_APPINDICATOR)
+endif(${INDICATOR3_FOUND})
if (${GTK3_FOUND})
- SET(DEFINES --define HAVE_GTK_3)
+ LIST(APPEND DEFINES --define HAVE_GTK_3)
endif(${GTK3_FOUND})
if (${GMENU3_FOUND})