summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt15
1 files changed, 13 insertions, 2 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 23b9474..b809c48 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -9,6 +9,10 @@ if (${INDICATOR_FOUND})
SET(DEFINES --define HAVE_APPINDICATOR)
endif(${INDICATOR_FOUND})
+if (${GTK3_FOUND})
+ SET(DEFINES --define HAVE_GTK_3)
+endif(${GTK3_FOUND})
+
if (${GMENU3_FOUND})
LIST(APPEND DEFINES --define HAVE_GMENU_3)
endif (${GMENU3_FOUND})
@@ -39,7 +43,7 @@ install(
# install credits
install(
FILES
- ${CMAKE_SOURCE_DIR}/README
+ ${CMAKE_SOURCE_DIR}/README.md
DESTINATION
${CMAKE_INSTALL_PREFIX}/share/doc/gnome-pie
)
@@ -63,11 +67,18 @@ install(
${CMAKE_INSTALL_PREFIX}/share/gnome-pie
)
+# install UI files
+install(
+ DIRECTORY
+ ${CMAKE_SOURCE_DIR}/resources/ui
+ DESTINATION
+ ${CMAKE_INSTALL_PREFIX}/share/gnome-pie
+)
+
# install icons
install(
FILES
${CMAKE_SOURCE_DIR}/resources/gnome-pie.svg
- ${CMAKE_SOURCE_DIR}/resources/gnome-pie-indicator.svg
DESTINATION
${CMAKE_INSTALL_PREFIX}/share/icons/hicolor/scalable/apps
)