summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuk Claes <luk@debian.org>2011-09-19 19:36:25 +0200
committerLuk Claes <luk@debian.org>2011-09-19 19:36:25 +0200
commit87e408db30cef024d3843fc5d938fbef29adb633 (patch)
tree5d93025babe312ffa001435e793d61332775fc80
parent82d2e4f7ac5bce298f782bff952486045ce37e0e (diff)
Only approach rsp->data when rsp is set (Closes: #637423).
-rw-r--r--debian/changelog3
-rw-r--r--debian/patches/fix_sdr_segfault13
-rw-r--r--debian/patches/series1
3 files changed, 16 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 6d8bf92..36596a9 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -5,8 +5,9 @@ ipmitool (1.8.11-4) unstable; urgency=low
- Add Vcs entries.
- Update Architecture to any as ipmitool can be used for
remote devices.
+ * Only approach rsp->data when rsp is set (Closes: #637423).
- -- Luk Claes <luk@debian.org> Mon, 19 Sep 2011 19:31:12 +0200
+ -- Luk Claes <luk@debian.org> Mon, 19 Sep 2011 19:35:04 +0200
ipmitool (1.8.11-3) unstable; urgency=low
diff --git a/debian/patches/fix_sdr_segfault b/debian/patches/fix_sdr_segfault
new file mode 100644
index 0000000..b9680e0
--- /dev/null
+++ b/debian/patches/fix_sdr_segfault
@@ -0,0 +1,13 @@
+diff -Nur ipmitool-1.8.11/lib/ipmi_sdr.c ipmitool-1.8.11.fix/lib/ipmi_sdr.c
+--- ipmitool-1.8.11/lib/ipmi_sdr.c 2009-02-25 21:38:52.000000000 +0100
++++ ipmitool-1.8.11.fix/lib/ipmi_sdr.c 2011-08-10 18:21:26.000000000 +0200
+@@ -1828,7 +1828,7 @@
+ printf("ns | %2d.%1d | ",
+ sensor->entity.id,
+ sensor->entity.instance);
+- if (IS_SCANNING_DISABLED(rsp->data[1]))
++ if (rsp && IS_SCANNING_DISABLED(rsp->data[1]))
+ printf("Disabled");
+ else
+ printf("No Reading");
+
diff --git a/debian/patches/series b/debian/patches/series
index 8a6e84e..ca8572e 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,2 +1,3 @@
99_readme_typo
passwd_option
+fix_sdr_segfault