summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2016-03-03 06:42:28 +0100
committerJörg Frings-Fürst <debian@jff-webhosting.net>2016-03-03 06:42:28 +0100
commit9b9f1c8a93147ff93d285424e3b6d17b271c8a70 (patch)
treeb79d507bed55d8fe93760e52adf84f7ec85ccfc3
parent6781cf859abee78f14d4d88e5271c302ee21f11e (diff)
add 0001-Dialect_change.patch
-rw-r--r--debian/changelog9
-rw-r--r--debian/control3
-rw-r--r--debian/patches/0001-Dialect_change.patch22
-rw-r--r--debian/patches/series1
-rwxr-xr-xdebian/rules7
5 files changed, 40 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index f4075c5..7f8f772 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,12 @@
+ipmitool (1.8.16-2) UNRELEASED; urgency=medium
+
+ * New debian/patches/0001-Dialect_change.patch (Closes: #816491):
+ - Change dialect from c99 to gnu99 to prevend segfaults
+ on missing functions.
+ - Add autoreconf to debian/rules and debian/control.
+
+ -- Jörg Frings-Fürst <debian@jff-webhosting.net> Thu, 03 Mar 2016 02:13:25 +0100
+
ipmitool (1.8.16-1) unstable; urgency=medium
* New upstream release (Closes: #810827).
diff --git a/debian/control b/debian/control
index b7dbf58..475c79d 100644
--- a/debian/control
+++ b/debian/control
@@ -3,8 +3,9 @@ Section: utils
Priority: optional
Maintainer: Jörg Frings-Fürst <debian@jff-webhosting.net>
Build-Depends:
- autotools-dev,
+ autotools-dev,,
debhelper (>> 9),
+ dh-autoreconf,
dh-systemd (>= 1.5),
libncurses-dev,
libfreeipmi-dev [!hurd-i386],
diff --git a/debian/patches/0001-Dialect_change.patch b/debian/patches/0001-Dialect_change.patch
new file mode 100644
index 0000000..8fb322a
--- /dev/null
+++ b/debian/patches/0001-Dialect_change.patch
@@ -0,0 +1,22 @@
+Description: Change Dialect to -std=gnu99
+ based in comments from dann frazier <dannf@debian.org>
+Author: Jörg Frings-Fürst <debian@jff-webhosting.net>
+Bug:
+Bug-Debian: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=816491
+Forwarded:
+Last-Update: 2016-03-03
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+Index: trunk/configure.ac
+===================================================================
+--- trunk.orig/configure.ac
++++ trunk/configure.ac
+@@ -32,7 +32,7 @@ AC_CHECK_FUNCS([alarm gethostbyname geta
+ AC_CHECK_FUNCS([memmove memset strchr strdup strerror])
+ AC_CHECK_FUNCS([getpassphrase])
+
+-CFLAGS="$CFLAGS -Wall -Wextra -std=c99 -pedantic -Wformat -Wformat-nonliteral"
++CFLAGS="$CFLAGS -Wall -Wextra -std=gnu99 -pedantic -Wformat -Wformat-nonliteral"
+
+ AM_PROG_LIBTOOL
+ LIBTOOL="$LIBTOOL --silent"
diff --git a/debian/patches/series b/debian/patches/series
index 389336b..14e2949 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -4,3 +4,4 @@
0500-fix_CVE-2011-4339.patch
0610-readme_typo.patch
0600-manpage_longlines.patch
+0001-Dialect_change.patch
diff --git a/debian/rules b/debian/rules
index 52a96a6..76cd5ac 100755
--- a/debian/rules
+++ b/debian/rules
@@ -11,7 +11,12 @@ export DH_OPTIONS
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
%:
- dh $@ --with systemd,autotools-dev
+ dh $@ --with systemd,autotools-dev,autoreconf
+
+override_dh_autoreconf:
+ touch NEWS
+ dh_autoreconf
+ $(RM) NEWS
override_dh_auto_install:
dh_auto_install