summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2016-12-27 14:20:17 +0100
committerJörg Frings-Fürst <debian@jff-webhosting.net>2016-12-27 14:20:17 +0100
commit26501b6781cc3a4c92c400a08fd9f2cabaded161 (patch)
tree757445180e2e4a5f1ad5fe8ab4cd35034f26be2f
parenta49b4aa0d641155be104423e05028851491313e0 (diff)
Fix enablement of usb interface; Drop both dh-autoreconf/dh-systemd
-rw-r--r--debian/changelog11
-rw-r--r--debian/control2
-rw-r--r--debian/files1
-rwxr-xr-xdebian/rules7
4 files changed, 15 insertions, 6 deletions
diff --git a/debian/changelog b/debian/changelog
index 84216ff..b963273 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,14 @@
+ipmitool (1.8.18-3) unstable; urgency=medium
+
+ * debian/rules:
+ - Fix enablement of usb interface (Closes: #849349).
+ Thanks to Steve Langasek <steve.langasek@canonical.com>.
+ * Drop both dh-autoreconf/dh-systemd from both build-depends
+ and dh --with arguments because this is all defaults when
+ using dh compat 10.
+
+ -- Jörg Frings-Fürst <debian@jff-webhosting.net> Tue, 27 Dec 2016 14:19:02 +0100
+
ipmitool (1.8.18-2) unstable; urgency=medium
* debian/control:
diff --git a/debian/control b/debian/control
index 0d58f17..82207f9 100644
--- a/debian/control
+++ b/debian/control
@@ -4,8 +4,6 @@ Priority: optional
Maintainer: Jörg Frings-Fürst <debian@jff-webhosting.net>
Build-Depends:
debhelper (>> 10),
- dh-autoreconf,
- dh-systemd (>= 1.5),
libncurses-dev,
libfreeipmi-dev [!hurd-i386],
libreadline-dev,
diff --git a/debian/files b/debian/files
deleted file mode 100644
index 5a233e9..0000000
--- a/debian/files
+++ /dev/null
@@ -1 +0,0 @@
-ipmitool_1.8.18-2_20161118T095529z-4a69cdf2.buildinfo utils optional
diff --git a/debian/rules b/debian/rules
index d8256c4..5bb138a 100755
--- a/debian/rules
+++ b/debian/rules
@@ -13,14 +13,15 @@ export DEB_BUILD_MAINT_OPTIONS = hardening=+all
# Platform-specific features
DEB_HOST_ARCH_OS ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_OS)
-ifneq ($(DEB_HOST_ARCH_OS),linux)
+ifeq ($(DEB_HOST_ARCH_OS),linux)
# USB implementation is Linux-specific
+ extra_config_opts += --enable-intf-usb
+else
extra_config_opts += --disable-intf-usb
endif
-
%:
- dh $@ --with systemd,autoreconf
+ dh $@
override_dh_auto_install:
dh_auto_install