summaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/0001-Dialect_change.patch22
-rw-r--r--debian/patches/0100-fix_buf_overflow.patch22
-rw-r--r--debian/patches/0105-typo.patch217
-rw-r--r--debian/patches/0110-getpass-prototype.patch23
-rw-r--r--debian/patches/0115-typo.patch31
-rw-r--r--debian/patches/0500-fix_CVE-2011-4339.patch21
-rw-r--r--debian/patches/0600-manpage_longlines.patch56
-rw-r--r--debian/patches/0605-manpage_typo.patch272
-rw-r--r--debian/patches/0610-readme_typo.patch29
-rw-r--r--debian/patches/series9
10 files changed, 702 insertions, 0 deletions
diff --git a/debian/patches/0001-Dialect_change.patch b/debian/patches/0001-Dialect_change.patch
new file mode 100644
index 0000000..8fb322a
--- /dev/null
+++ b/debian/patches/0001-Dialect_change.patch
@@ -0,0 +1,22 @@
+Description: Change Dialect to -std=gnu99
+ based in comments from dann frazier <dannf@debian.org>
+Author: Jörg Frings-Fürst <debian@jff-webhosting.net>
+Bug:
+Bug-Debian: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=816491
+Forwarded:
+Last-Update: 2016-03-03
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+Index: trunk/configure.ac
+===================================================================
+--- trunk.orig/configure.ac
++++ trunk/configure.ac
+@@ -32,7 +32,7 @@ AC_CHECK_FUNCS([alarm gethostbyname geta
+ AC_CHECK_FUNCS([memmove memset strchr strdup strerror])
+ AC_CHECK_FUNCS([getpassphrase])
+
+-CFLAGS="$CFLAGS -Wall -Wextra -std=c99 -pedantic -Wformat -Wformat-nonliteral"
++CFLAGS="$CFLAGS -Wall -Wextra -std=gnu99 -pedantic -Wformat -Wformat-nonliteral"
+
+ AM_PROG_LIBTOOL
+ LIBTOOL="$LIBTOOL --silent"
diff --git a/debian/patches/0100-fix_buf_overflow.patch b/debian/patches/0100-fix_buf_overflow.patch
new file mode 100644
index 0000000..174d205
--- /dev/null
+++ b/debian/patches/0100-fix_buf_overflow.patch
@@ -0,0 +1,22 @@
+Description: fix buffer overflow
+ based on 101_fix_buf_overflow from Leo Iannacone <l3on@ubuntu.com>
+Author: Jörg Frings-Fürst <debian@jff-webhosting.net>
+Bug: TSOL buffer overflow
+Bug-ubuntu: https://bugs.launchpad.net/ubuntu/+source/ipmitool/+bug/633054
+Forwarded: https://sourceforge.net/p/ipmitool/patches/100/
+Last-Update: 2014-12-01
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+Index: trunk/lib/ipmi_tsol.c
+===================================================================
+--- trunk.orig/lib/ipmi_tsol.c
++++ trunk/lib/ipmi_tsol.c
+@@ -375,7 +375,7 @@ ipmi_tsol_main(struct ipmi_intf *intf, i
+ char *recvip = NULL;
+ char in_buff[IPMI_BUF_SIZE];
+ char out_buff[IPMI_BUF_SIZE * 8];
+- char buff[IPMI_BUF_SIZE + 4];
++ char buff[IPMI_BUF_SIZE * 8 + 4];
+ int fd_socket, result, i;
+ int out_buff_fill, in_buff_fill;
+ int ip1, ip2, ip3, ip4;
diff --git a/debian/patches/0105-typo.patch b/debian/patches/0105-typo.patch
new file mode 100644
index 0000000..a755cb4
--- /dev/null
+++ b/debian/patches/0105-typo.patch
@@ -0,0 +1,217 @@
+Description: Some source typos
+Author: Jörg Frings-Fürst <debian@jff-webhosting.net>
+Forwarded: https://sourceforge.net/p/ipmitool/bugs/417/
+Last-Update: 2016-02-20
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+Index: trunk/lib/ipmi_hpmfwupg.c
+===================================================================
+--- trunk.orig/lib/ipmi_hpmfwupg.c
++++ trunk/lib/ipmi_hpmfwupg.c
+@@ -2021,13 +2021,13 @@ HpmfwupgQueryRollbackStatus(struct ipmi_
+ memcpy(&pCtx->resp, rsp->data,
+ sizeof(struct HpmfwupgQueryRollbackStatusResp));
+ if (pCtx->resp.rollbackComp.ComponentBits.byte != 0) {
+- /* Rollback occured */
++ /* Rollback occurred */
+ lprintf(LOG_NOTICE,
+- "Rollback occured on component mask: 0x%02x",
++ "Rollback occurred on component mask: 0x%02x",
+ pCtx->resp.rollbackComp.ComponentBits.byte);
+ } else {
+ lprintf(LOG_NOTICE,
+- "No Firmware rollback occured");
++ "No Firmware rollback occurred");
+ }
+ } else if (rsp->ccode == 0x81) {
+ lprintf(LOG_ERR,
+Index: trunk/include/ipmitool/ipmi_sel.h
+===================================================================
+--- trunk.orig/include/ipmitool/ipmi_sel.h
++++ trunk/include/ipmitool/ipmi_sel.h
+@@ -194,7 +194,7 @@ static struct ipmi_event_sensor_types oe
+ { 0xC7 , 0x01 , 0xff, IPMI_EVENT_CLASS_DISCRETE , "FWUM Status", "First Boot After Rollback(error)" },
+ { 0xC7 , 0x02 , 0xff, IPMI_EVENT_CLASS_DISCRETE , "FWUM Status", "First Boot After Errors (watchdog)" },
+ { 0xC7 , 0x03 , 0xff, IPMI_EVENT_CLASS_DISCRETE , "FWUM Status", "First Boot After Manual Rollback" },
+- { 0xC7 , 0x08 , 0xff, IPMI_EVENT_CLASS_DISCRETE , "FWUM Status", "Firmware Watchdog Bite, reset occured" },
++ { 0xC7 , 0x08 , 0xff, IPMI_EVENT_CLASS_DISCRETE , "FWUM Status", "Firmware Watchdog Bite, reset occurred" },
+
+ { 0xC8 , 0x00 , 0xff, IPMI_EVENT_CLASS_DISCRETE , "Switch Mngt Software Status", "Not Loaded" },
+ { 0xC8 , 0x01 , 0xff, IPMI_EVENT_CLASS_DISCRETE , "Switch Mngt Software Status", "Initializing" },
+Index: trunk/lib/ipmi_mc.c
+===================================================================
+--- trunk.orig/lib/ipmi_mc.c
++++ trunk/lib/ipmi_mc.c
+@@ -779,7 +779,7 @@ ipmi_mc_rst_watchdog(struct ipmi_intf *
+ if (rsp->ccode) {
+ lprintf(LOG_ERR, "Reset Watchdog Timer command failed: %s",
+ (rsp->ccode == IPM_WATCHDOG_RESET_ERROR) ?
+- "Attempt to reset unitialized watchdog" :
++ "Attempt to reset uninitialized watchdog" :
+ val2str(rsp->ccode, completion_code_vals));
+ return -1;
+ }
+Index: trunk/lib/ipmi_sunoem.c
+===================================================================
+--- trunk.orig/lib/ipmi_sunoem.c
++++ trunk/lib/ipmi_sunoem.c
+@@ -469,7 +469,7 @@ ipmi_sunoem_led_get(struct ipmi_intf * i
+ ledtype = str2val(argv[1], sunoem_led_type_vals);
+ if (ledtype == 0xFF)
+ lprintf(LOG_ERR,
+- "Unknow ledtype, will use data from the SDR oem field");
++ "Unknown ledtype, will use data from the SDR oem field");
+ }
+
+ if (strncasecmp(argv[0], "all", 3) == 0) {
+@@ -676,7 +676,7 @@ ipmi_sunoem_led_set(struct ipmi_intf * i
+ ledtype = str2val(argv[2], sunoem_led_type_vals);
+ if (ledtype == 0xFF)
+ lprintf(LOG_ERR,
+- "Unknow ledtype, will use data from the SDR oem field");
++ "Unknown ledtype, will use data from the SDR oem field");
+ }
+
+ if (strncasecmp(argv[0], "all", 3) == 0) {
+Index: trunk/lib/ipmi_dcmi.c
+===================================================================
+--- trunk.orig/lib/ipmi_dcmi.c
++++ trunk/lib/ipmi_dcmi.c
+@@ -671,7 +671,7 @@ chk_nm_rsp(struct ipmi_rs * rsp)
+ * some issue and cannot complete the command
+ */
+ if (rsp == NULL) {
+- lprintf(LOG_ERR, "\n No reponse to NM request");
++ lprintf(LOG_ERR, "\n No response to NM request");
+ return 1;
+ }
+ /* if the completion code is greater than zero there was an error. We'll
+@@ -1426,7 +1426,7 @@ ipmi_dcmi_getthermalpolicy(struct ipmi_i
+ /* rsp->data[0] is equal to response data byte 2 in spec */
+ memcpy(&val, rsp->data, sizeof (val));
+ printf("\n");
+- printf(" Persistance flag is: %s\n",
++ printf(" Persistence flag is: %s\n",
+ ((val.exceptionActions & 0x80) ? "set" : "notset"));
+ printf(" Exception Actions, taken if the Temperature Limit exceeded:\n");
+ printf(" Hard Power Off system and log event: %s\n",
+@@ -3163,7 +3163,7 @@ ipmi_nm_thresh(struct ipmi_intf * intf,
+ return -1;
+ }
+ if (str2ushort(argv[0], &thresh.thresholds[i++]) < 0) {
+- lprintf(LOG_ERR,"threshold value %d count must be a positve integer.\n", i);
++ lprintf(LOG_ERR,"threshold value %d count must be a positive integer.\n", i);
+ return -1;
+ }
+ default:
+Index: trunk/include/ipmitool/ipmi_sol.h
+===================================================================
+--- trunk.orig/include/ipmitool/ipmi_sol.h
++++ trunk/include/ipmitool/ipmi_sol.h
+@@ -64,7 +64,7 @@ struct sol_config_parameters {
+
+
+ /*
+- * The ACTIVATE PAYLOAD command reponse structure
++ * The ACTIVATE PAYLOAD command response structure
+ * From table 24-2 of the IPMI v2.0 spec
+ */
+ #ifdef PRAGMA_PACK
+Index: trunk/src/plugins/lanplus/lanplus.c
+===================================================================
+--- trunk.orig/src/plugins/lanplus/lanplus.c
++++ trunk/src/plugins/lanplus/lanplus.c
+@@ -606,7 +606,7 @@ ipmiv2_lan_ping(struct ipmi_intf * intf)
+ * Receive whatever comes back. Ignore received packets that don't correspond
+ * to a request we've sent.
+ *
+- * Returns: the ipmi_rs packet describing the/a reponse we expect.
++ * Returns: the ipmi_rs packet describing the/a response we expect.
+ */
+ static struct ipmi_rs *
+ ipmi_lan_poll_single(struct ipmi_intf * intf)
+@@ -651,7 +651,7 @@ ipmi_lan_poll_single(struct ipmi_intf *
+ *
+ * 1) An IPMI 1.5 packet (the response to our GET CHANNEL
+ * AUTHENTICATION CAPABILITIES request)
+- * 2) An RMCP+ message with an IPMI reponse payload
++ * 2) An RMCP+ message with an IPMI response payload
+ * 3) AN RMCP+ open session response
+ * 4) An RAKP-2 message (response to an RAKP 1 message)
+ * 5) An RAKP-4 message (response to an RAKP 3 message)
+@@ -681,7 +681,7 @@ ipmi_lan_poll_single(struct ipmi_intf *
+ }
+
+ /*
+- * Handle IPMI responses (case #1 and #2) -- all IPMI reponses
++ * Handle IPMI responses (case #1 and #2) -- all IPMI responses
+ */
+ if (rsp->session.payloadtype == IPMI_PAYLOAD_TYPE_IPMI) {
+ struct ipmi_rq_entry * entry;
+@@ -863,7 +863,7 @@ ipmi_lan_poll_single(struct ipmi_intf *
+ * Receive whatever comes back. Ignore received packets that don't correspond
+ * to a request we've sent.
+ *
+- * Returns: the ipmi_rs packet describing the/a reponse we expect.
++ * Returns: the ipmi_rs packet describing the/a response we expect.
+ */
+ static struct ipmi_rs *
+ ipmi_lan_poll_recv(struct ipmi_intf * intf)
+@@ -881,7 +881,7 @@ ipmi_lan_poll_recv(struct ipmi_intf * in
+
+
+ /*
+- * read_open_session_reponse
++ * read_open_session_response
+ *
+ * Initialize the ipmi_rs from the IPMI 2.x open session response data.
+ *
+@@ -903,7 +903,7 @@ read_open_session_response(struct ipmi_r
+ /* Message tag */
+ rsp->payload.open_session_response.message_tag = rsp->data[offset];
+
+- /* RAKP reponse code */
++ /* RAKP response code */
+ rsp->payload.open_session_response.rakp_return_code = rsp->data[offset + 1];
+
+ /* Maximum privilege level */
+@@ -970,7 +970,7 @@ read_rakp2_message(
+ /* Message tag */
+ rsp->payload.rakp2_message.message_tag = rsp->data[offset];
+
+- /* RAKP reponse code */
++ /* RAKP response code */
+ rsp->payload.rakp2_message.rakp_return_code = rsp->data[offset + 1];
+
+ /* Console session ID */
+@@ -1051,7 +1051,7 @@ read_rakp4_message(
+ /* Message tag */
+ rsp->payload.rakp4_message.message_tag = rsp->data[offset];
+
+- /* RAKP reponse code */
++ /* RAKP response code */
+ rsp->payload.rakp4_message.rakp_return_code = rsp->data[offset + 1];
+
+ /* Console session ID */
+@@ -3416,7 +3416,7 @@ ipmi_lanplus_open(struct ipmi_intf * int
+ if (!ipmi_oem_active(intf, "i82571spt") &&
+ ipmi_get_auth_capabilities_cmd(intf, &auth_cap)) {
+ lprintf(LOG_INFO, "Error issuing Get Channel "
+- "Authentication Capabilies request");
++ "Authentication Capabilities request");
+ goto fail;
+ }
+
+Index: trunk/src/plugins/lan/lan.c
+===================================================================
+--- trunk.orig/src/plugins/lan/lan.c
++++ trunk/src/plugins/lan/lan.c
+@@ -970,7 +970,7 @@ ipmi_lan_send_cmd(struct ipmi_intf * int
+ // Example: We have to send command 23 and 2d.
+ // If we send command,seq as 23,10 and if we dont get any response it will
+ // retry 4 times with 23,10 and then come out here and indicate that there is no
+- // reponse from the remote controller and will send the next command for
++ // response from the remote controller and will send the next command for
+ // ie 2d,11. And if the BMC is slow to respond and returns 23,10 then it
+ // will match it in the list and will take response of command 23 as response
+ // for command 2d and return success. So ideally when retries are done and
diff --git a/debian/patches/0110-getpass-prototype.patch b/debian/patches/0110-getpass-prototype.patch
new file mode 100644
index 0000000..ecd8ee9
--- /dev/null
+++ b/debian/patches/0110-getpass-prototype.patch
@@ -0,0 +1,23 @@
+Description: use necessary source dialect to ensure getpass() availability
+ getpass is a deprecated function, and building with either c99 or gnu99
+ does not ensure this function's availability. So instead, declare
+ _DEFAULT_SOURCE so that the function remains available.
+Author: Steve Langasek <steve.langasek@ubuntu.com>
+Origin: <upstream|backport|vendor|other>, <URL, required except if Author is present>
+Bug: <URL to the upstream bug report if any, implies patch has been forwarded, optional>
+Bug-Debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=819340
+Last-Update: 2016-05-15
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+Index: trunk/lib/ipmi_main.c
+===================================================================
+--- trunk.orig/lib/ipmi_main.c
++++ trunk/lib/ipmi_main.c
+@@ -34,6 +34,7 @@
+ (_XOPEN_SOURCE >= 500 || \
+ _XOPEN_SOURCE && _XOPEN_SOURCE_EXTENDED) && \
+ !(_POSIX_C_SOURCE >= 200112L || _XOPEN_SOURCE >= 600)
++#define _DEFAULT_SOURCE
+
+ #include <stdlib.h>
+ #include <stdio.h>
diff --git a/debian/patches/0115-typo.patch b/debian/patches/0115-typo.patch
new file mode 100644
index 0000000..c2887c2
--- /dev/null
+++ b/debian/patches/0115-typo.patch
@@ -0,0 +1,31 @@
+Description: source typos
+Author: Jörg Frings-Fürst <debian@jff-webhosting.net>
+Last-Update: 2016-05-15
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+Index: trunk/lib/dimm_spd.c
+===================================================================
+--- trunk.orig/lib/dimm_spd.c
++++ trunk/lib/dimm_spd.c
+@@ -798,7 +798,7 @@ const struct valstr jedec_id5_vals[] = {
+ { 0xE3, "WIS Technologies" },
+ { 0x64, "GateChange Technologies" },
+ { 0xE5, "High Density Devices AS" },
+- { 0xE6, "Synopsys" },
++ { 0xE6, "Synopsis" },
+ { 0x67, "Gigaram" },
+ { 0x68, "Enigma Semiconductor Inc." },
+ { 0xE9, "Century Micro Inc." },
+Index: trunk/lib/ipmi_hpmfwupg.c
+===================================================================
+--- trunk.orig/lib/ipmi_hpmfwupg.c
++++ trunk/lib/ipmi_hpmfwupg.c
+@@ -1502,7 +1502,7 @@ HpmfwupgGetTargetUpgCapabilities(struct
+ pCtx->resp.GlobalCapabilities.bitField.autRollbackOverride ? 'y' : 'n');
+ lprintf(LOG_NOTICE, "IPMC degraded...........[%c] ",
+ pCtx->resp.GlobalCapabilities.bitField.ipmcDegradedDurinUpg ? 'y' : 'n');
+- lprintf(LOG_NOTICE, "Defered activation......[%c] ",
++ lprintf(LOG_NOTICE, "Deferred activation......[%c] ",
+ pCtx->resp.GlobalCapabilities.bitField.deferActivation ? 'y' : 'n');
+ lprintf(LOG_NOTICE, "Service affected........[%c] ",
+ pCtx->resp.GlobalCapabilities.bitField.servAffectDuringUpg ? 'y' : 'n');
diff --git a/debian/patches/0500-fix_CVE-2011-4339.patch b/debian/patches/0500-fix_CVE-2011-4339.patch
new file mode 100644
index 0000000..8360417
--- /dev/null
+++ b/debian/patches/0500-fix_CVE-2011-4339.patch
@@ -0,0 +1,21 @@
+Description: CVE-2011-4339
+ insecure file permission when creating PID files
+ based on 112_fix_CVE-2011-4339
+Author: Jörg Frings-Fürst <debian@jff-webhosting.net>
+Bug: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=651917
+Forwarded: https://sourceforge.net/p/ipmitool/patches/99/
+Last-Update: 2014-12-01
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+Index: trunk/lib/helper.c
+===================================================================
+--- trunk.orig/lib/helper.c
++++ trunk/lib/helper.c
+@@ -664,7 +664,6 @@ ipmi_start_daemon(struct ipmi_intf *intf
+ #endif
+
+ chdir("/");
+- umask(0);
+
+ for (fd=0; fd<64; fd++) {
+ if (fd != intf->fd)
diff --git a/debian/patches/0600-manpage_longlines.patch b/debian/patches/0600-manpage_longlines.patch
new file mode 100644
index 0000000..8fae0a9
--- /dev/null
+++ b/debian/patches/0600-manpage_longlines.patch
@@ -0,0 +1,56 @@
+Description: long lines in man-page
+ prevent "can't break line" warnings
+Author: Jörg Frings-Fürst <debian@jff-webhosting.net>
+Forwarded: not-needed
+Last-Update: 2014-05-20
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+Index: trunk/doc/ipmitool.1
+===================================================================
+--- trunk.orig/doc/ipmitool.1
++++ trunk/doc/ipmitool.1
+@@ -1035,7 +1035,7 @@ Display point to point physical connecti
+ AMC slot B2 topology:
+ Port 0 =====> On Carrier Device ID 0, Port 3
+ Port 2 =====> AMC slot B1, Port 2
+- *-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*
++ *-*-*-* *-*-* *-*-* *-*-* *-*-* *-*-* *-*-*
+ From Carrier file: carrierfru
+ On Carrier Device ID 0 topology:
+ Port 0 =====> AMC slot B1, Port 4
+@@ -1091,7 +1091,7 @@ and an AMC module or between 2 AMC modul
+ \-Link Type: AMC.2 Ethernet
+ \-Link Type extension: 1000BASE-BX (SerDES Gigabit) Ethernet link
+ \-Link Group ID: 0 || Link Asym. Match: exact match
+- *-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*
++ *-*-*-* *-*-* *-*-* *-*-* *-*-* *-*-* *-*-*
+ AMC slot B1 port 1 ==> On-Carrier Device 0 port 12
+ Matching Result
+ - From On-Carrier Device ID 0
+@@ -1104,7 +1104,7 @@ and an AMC module or between 2 AMC modul
+ \-Link Type: AMC.2 Ethernet
+ \-Link Type extension: 1000BASE-BX (SerDES Gigabit) Ethernet link
+ \-Link Group ID: 0 || Link Asym. Match: exact match
+- *-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*
++ *-*-*-* *-*-* *-*-* *-*-* *-*-* *-*-* *-*-*
+ On-Carrier Device vs AMC slot A2
+ AMC slot A2 port 0 ==> On-Carrier Device 0 port 3
+ Matching Result
+@@ -1118,7 +1118,7 @@ and an AMC module or between 2 AMC modul
+ \-Link Type: AMC.2 Ethernet
+ \-Link Type extension: 1000BASE-BX (SerDES Gigabit) Ethernet link
+ \-Link Group ID: 0 || Link Asym. Match: exact match
+- *-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*
++ *-*-*-* *-*-* *-*-* *-*-* *-*-* *-*-* *-*-*
+ AMC slot B1 vs AMC slot A2
+ AMC slot A2 port 2 ==> AMC slot B1 port 2
+ Matching Result
+@@ -1132,7 +1132,7 @@ and an AMC module or between 2 AMC modul
+ \-Link Type: AMC.3 Storage
+ \-Link Type extension: Serial Attached SCSI (SAS/SATA)
+ \-Link Group ID: 0 || Link Asym. Match: FC or SAS interface {exact match}
+- *-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*
++ *-*-*-* *-*-* *-*-* *-*-* *-*-* *-*-* *-*-*
+ .TP
+ \fIunmatch\fP <\fBxx=filename\fR> <\fBxx=filename\fR> \fB...\fr
+ .br
diff --git a/debian/patches/0605-manpage_typo.patch b/debian/patches/0605-manpage_typo.patch
new file mode 100644
index 0000000..c1adfdb
--- /dev/null
+++ b/debian/patches/0605-manpage_typo.patch
@@ -0,0 +1,272 @@
+Description: typo in man-page
+Author: Jörg Frings-Fürst <debian@jff-webhosting.net>
+Last-Update: 2014-05-19
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+Index: trunk/doc/ipmitool.1
+===================================================================
+--- trunk.orig/doc/ipmitool.1
++++ trunk/doc/ipmitool.1
+@@ -10,47 +10,47 @@ ipmitool [ <options> ] <command> [ <sub-
+ Any recognized option is accepted. Conditional options may be ignored or it's usage postponed until shell or exec processes relevant command.
+ .br
+
+-<general-options> := [ -h | -V | -v | -I <interface> | -H <address> |
+- -d <N> | -p <port> | -c | -U <username> |
+- -L <privlvl> | -l <lun> | -m <local_address> |
+- -N <sec> | -R <count> | <password-option> |
++<general\-options> := [ \-h | \-V | \-v | \-I <interface> | \-H <address> |
++ \-d <N> | \-p <port> | \-c | \-U <username> |
++ \-L <privlvl> | \-l <lun> | \-m <local_address> |
++ \-N <sec> | \-R <count> | <password\-option> |
+ <oem-option> | <bridge-options> ]
+
+-<conditional-opts> := [ <lan-options> | <lanplus-options> |
+- <command-options> ]
++<conditional\-opts> := [ <lan\-options> | <lanplus\-options> |
++ <command\-options> ]
+ .br
+ Bridging:
+ .br
+-<bridge-options> := -t <target_address> [ -b <channel> |
+- [ -T <address> | -B <channel> ] ]
++<bridge\-options> := \-t <target_address> [ \-b <channel> |
++ [ \-T <address> | \-B <channel> ] ]
+ .br
+
+-Options used with -I lan:
++Options used with \-I lan:
+ .br
+-<lan-options> := [ -A <authtype> ]
++<lan\-options> := [ \-A <authtype> ]
+ .br
+
+-Options used with -I lanplus:
++Options used with \-I lanplus:
+ .br
+-<lanplus-options> := [ -C <ciphersuite> | <key-option> ]
++<lanplus\-options> := [ \-C <ciphersuite> | <key\-option> ]
+ .br
+
+ Option groups setting same value:
+ .br
+-<key-option> := [ -k <key> | -K | -y <hex_key> | -Y ]
++<key\-option> := [ \-k <key> | \-K | \-y <hex_key> | \-Y ]
+ .br
+-<password-option> := [ -f <password_file> | -a | -P <password> | -E ]
++<password\-option> := [ \-f <password_file> | \-a | \-P <password> | \-E ]
+ .br
+-<oem-option> := [ -o <oemtype> | -g | -s ]
++<oem\-option> := [ \-o <oemtype> | \-g | \-s ]
+ .br
+
+ Options used with specific command <command-options>:
+ .br
+-<options-sdr> := [ -S <sdr_cache_file> ]
++<options\-sdr> := [ \-S <sdr_cache_file> ]
+ .br
+-<options-sel> := [ -O <sel_oem> ]
++<options\-sel> := [ \-O <sel_oem> ]
+ .br
+-<options-sol> := [ -e <sol_escape_char> ]
++<options\-sol> := [ \-e <sol_escape_char> ]
+
+
+ .SH "DESCRIPTION"
+@@ -120,7 +120,7 @@ option is absent, or if password_file is
+ will default to NULL.
+ .TP
+ \fB\-g\fR
+-Deprecated. Use: -o intelplus
++Deprecated. Use: \-o intelplus
+ .TP
+ \fB\-h\fR
+ Get basic usage help from the command line.
+@@ -151,7 +151,7 @@ combined with \fI-t target address\fP.
+ .TP
+ \fB\-m\fR <\fIlocal_address\fP>
+ Set the local IPMB address. The local address defaults to 0x20
+-or is auto discovered on PICMG platforms when -m is not specified.
++or is auto discovered on PICMG platforms when \-m is not specified.
+ There should be no need to change the local address for normal operation.
+ .TP
+ \fB\-N\fR <\fIsec\fP>
+@@ -185,7 +185,7 @@ Command \fIraw\fP uses fixed value of on
+ Command \fIhpm\fP uses fixed value of 10 retries.
+ .TP
+ \fB\-s\fR
+-Deprecated. Use: -o supermicro
++Deprecated. Use: \-o supermicro
+ .TP
+ \fB\-S\fR <\fIsdr_cache_file\fP>
+ Use local file for remote SDR cache. Using a local SDR cache
+@@ -223,7 +223,7 @@ Display version information.
+ \fB\-y\fR <\fIhex key\fP>
+ Use supplied Kg key for IPMIv2.0 authentication. The key is expected in
+ hexadecimal format and can be used to specify keys with non-printable
+-characters. E.g. '-k PASSWORD' and '-y 50415353574F5244' are
++characters. E.g. '\-k PASSWORD' and '\-y 50415353574F5244' are
+ equivalent.
+ The default is not to use any Kg key.
+ .TP
+@@ -1052,7 +1052,7 @@ Display point to point physical connecti
+ \fIpower\fP <\fBxx=filename1\fR> <\fBxx=filename2\fR> \fB...\fr
+ .br
+
+-Display power supply informations between carrier and AMC modules.
++Display power supply information between carrier and AMC modules.
+ .TP
+ \fIall\fP <\fBxx=filename\fR> <\fBxx=filename\fR> \fB...\fr
+ .br
+@@ -1064,7 +1064,7 @@ modules.
+ .TP
+ \fIfrushow\fP <\fBxx=filename\fR>
+ .br
+-Convert a binary FRU file into human readable text format. Use -v option to get
++Convert a binary FRU file into human readable text format. Use \-v option to get
+ more display information.
+
+ .RE
+@@ -1082,56 +1082,56 @@ and an AMC module or between 2 AMC modul
+ AMC slot B1 port 0 ==> On-Carrier Device 0 port 16
+ Matching Result
+ - From On-Carrier Device ID 0
+- -Channel ID 11 || Lane 0: enable
+- -Link Type: AMC.2 Ethernet
+- -Link Type extension: 1000BASE-BX (SerDES Gigabit) Ethernet link
+- -Link Group ID: 0 || Link Asym. Match: exact match
++ \-Channel ID 11 || Lane 0: enable
++ \-Link Type: AMC.2 Ethernet
++ \-Link Type extension: 1000BASE-BX (SerDES Gigabit) Ethernet link
++ \-Link Group ID: 0 || Link Asym. Match: exact match
+ - To AMC slot B1
+- -Channel ID 0 || Lane 0: enable
+- -Link Type: AMC.2 Ethernet
+- -Link Type extension: 1000BASE-BX (SerDES Gigabit) Ethernet link
+- -Link Group ID: 0 || Link Asym. Match: exact match
++ \-Channel ID 0 || Lane 0: enable
++ \-Link Type: AMC.2 Ethernet
++ \-Link Type extension: 1000BASE-BX (SerDES Gigabit) Ethernet link
++ \-Link Group ID: 0 || Link Asym. Match: exact match
+ *-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*
+ AMC slot B1 port 1 ==> On-Carrier Device 0 port 12
+ Matching Result
+ - From On-Carrier Device ID 0
+- -Channel ID 6 || Lane 0: enable
+- -Link Type: AMC.2 Ethernet
+- -Link Type extension: 1000BASE-BX (SerDES Gigabit) Ethernet link
+- -Link Group ID: 0 || Link Asym. Match: exact match
++ \-Channel ID 6 || Lane 0: enable
++ \-Link Type: AMC.2 Ethernet
++ \-Link Type extension: 1000BASE-BX (SerDES Gigabit) Ethernet link
++ \-Link Group ID: 0 || Link Asym. Match: exact match
+ - To AMC slot B1
+- -Channel ID 1 || Lane 0: enable
+- -Link Type: AMC.2 Ethernet
+- -Link Type extension: 1000BASE-BX (SerDES Gigabit) Ethernet link
+- -Link Group ID: 0 || Link Asym. Match: exact match
++ \-Channel ID 1 || Lane 0: enable
++ \-Link Type: AMC.2 Ethernet
++ \-Link Type extension: 1000BASE-BX (SerDES Gigabit) Ethernet link
++ \-Link Group ID: 0 || Link Asym. Match: exact match
+ *-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*
+ On-Carrier Device vs AMC slot A2
+ AMC slot A2 port 0 ==> On-Carrier Device 0 port 3
+ Matching Result
+ - From On-Carrier Device ID 0
+- -Channel ID 9 || Lane 0: enable
+- -Link Type: AMC.2 Ethernet
+- -Link Type extension: 1000BASE-BX (SerDES Gigabit) Ethernet link
+- -Link Group ID: 0 || Link Asym. Match: exact match
++ \-Channel ID 9 || Lane 0: enable
++ \-Link Type: AMC.2 Ethernet
++ \-Link Type extension: 1000BASE-BX (SerDES Gigabit) Ethernet link
++ \-Link Group ID: 0 || Link Asym. Match: exact match
+ - To AMC slot A2
+- -Channel ID 0 || Lane 0: enable
+- -Link Type: AMC.2 Ethernet
+- -Link Type extension: 1000BASE-BX (SerDES Gigabit) Ethernet link
+- -Link Group ID: 0 || Link Asym. Match: exact match
++ \-Channel ID 0 || Lane 0: enable
++ \-Link Type: AMC.2 Ethernet
++ \-Link Type extension: 1000BASE-BX (SerDES Gigabit) Ethernet link
++ \-Link Group ID: 0 || Link Asym. Match: exact match
+ *-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*
+ AMC slot B1 vs AMC slot A2
+ AMC slot A2 port 2 ==> AMC slot B1 port 2
+ Matching Result
+ - From AMC slot B1
+- -Channel ID 2 || Lane 0: enable
+- -Link Type: AMC.3 Storage
+- -Link Type extension: Serial Attached SCSI (SAS/SATA)
+- -Link Group ID: 0 || Link Asym. Match: FC or SAS interface {exact match}
++ \-Channel ID 2 || Lane 0: enable
++ \-Link Type: AMC.3 Storage
++ \-Link Type extension: Serial Attached SCSI (SAS/SATA)
++ \-Link Group ID: 0 || Link Asym. Match: FC or SAS interface {exact match}
+ - To AMC slot A2
+- -Channel ID 2 || Lane 0: enable
+- -Link Type: AMC.3 Storage
+- -Link Type extension: Serial Attached SCSI (SAS/SATA)
+- -Link Group ID: 0 || Link Asym. Match: FC or SAS interface {exact match}
++ \-Channel ID 2 || Lane 0: enable
++ \-Link Type: AMC.3 Storage
++ \-Link Type extension: Serial Attached SCSI (SAS/SATA)
++ \-Link Group ID: 0 || Link Asym. Match: FC or SAS interface {exact match}
+ *-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*
+ .TP
+ \fIunmatch\fP <\fBxx=filename\fR> <\fBxx=filename\fR> \fB...\fr
+@@ -2516,7 +2516,7 @@ Remove a policy. If domain is not suppli
+ \fIpower\fP \fImin\fP <minimum> \fImax\fP <maximum> [\fIdomain\fP <platform|CPU|Memory>]
+ .br
+
+-Configure Node Manager power minumum and maximum power draw limits.
++Configure Node Manager power minimum and maximum power draw limits.
+ The \fImin\fP and \fImax\fP values must be in the range of 0-65535.
+ If domain is not supplied a default of platform is used.
+
+@@ -3269,7 +3269,7 @@ I2C Master Write\-Read IPMI command.
+
+ Execute the service processor command line interface commands.
+ Without any command string, an interactive session is started
+-in the service processor command line environ ment. If a
++in the service processor command line environment. If a
+ command string is specified, the command string is executed
+ on the service processor and the connection is closed.
+ .TP
+@@ -3515,7 +3515,7 @@ a 2.4\-based kernel in order for ipmitoo
+ Incoming and outgoing message handler for IPMI interfaces.
+ .TP
+ .B ipmi_kcs_drv
+-An IPMI Keyboard Controler Style (KCS) interface driver for the message handler.
++An IPMI Keyboard Controller Style (KCS) interface driver for the message handler.
+ .TP
+ .B ipmi_devintf
+ Linux character device interface for the message handler.
+@@ -3553,7 +3553,7 @@ ipmitool includes some sample initializa
+ can perform this task automatically at start\-up.
+
+ In order to have ipmitool use the OpenIPMI device interface
+-you can specifiy it on the command line:
++you can specify it on the command line:
+ .PP
+ ipmitool \fB\-I\fR \fIopen\fP <\fIcommand\fP>
+ .SH "BMC INTERFACE"
+@@ -3664,7 +3664,7 @@ encryption algorightms.
+ The ipmitool \fIfree\fP interface utilizes the FreeIPMI libfreeipmi
+ drivers.
+ .LP
+-You can tell ipmitool to use the FreeIPMI interface with the -I option:
++You can tell ipmitool to use the FreeIPMI interface with the \-I option:
+ .PP
+ ipmitool \fB\-I\fR \fIfree\fP <\fIcommand\fP>
+
+@@ -3674,7 +3674,7 @@ ipmitool \fB\-I\fR \fIfree\fP <\fIcomman
+ The ipmitool \fIimb\fP interface supports the Intel IMB (Intel
+ Inter-module Bus) Interface through the /dev/imb device.
+ .LP
+-You can tell ipmitool to use the IMB interface with the -I option:
++You can tell ipmitool to use the IMB interface with the \-I option:
+ .PP
+ ipmitool \fB\-I\fR \fIimb\fP <\fIcommand\fP>
+
diff --git a/debian/patches/0610-readme_typo.patch b/debian/patches/0610-readme_typo.patch
new file mode 100644
index 0000000..89fb104
--- /dev/null
+++ b/debian/patches/0610-readme_typo.patch
@@ -0,0 +1,29 @@
+## 99_readme_typo.dpatch by dann frazier <dannf@hp.com>
+##
+## Typo in README. Closes: #508231
+Index: trunk/README
+===================================================================
+--- trunk.orig/README
++++ trunk/README
+@@ -24,7 +24,7 @@ Background
+ ==========
+ I originally wrote ipmitool while between projects and employeed at Sun
+ Microsystems. Sun had just embarked on a new line of general-purpose x86
+-servers that inclued an OEM Intel board with an IPMIv1.5 BMC on board.
++servers that included an OEM Intel board with an IPMIv1.5 BMC on board.
+ It started with an idea that remote chassis power control would be a handy
+ feature for my systems in the lab and from there it grew into a multi-
+ purpose tool that lots of people found useful. I decided to release it
+Index: trunk/doc/ipmitool.1
+===================================================================
+--- trunk.orig/doc/ipmitool.1
++++ trunk/doc/ipmitool.1
+@@ -63,7 +63,7 @@ chassis power control.
+ IPMI management of a local system interface requires a compatible IPMI
+ kernel driver to be installed and configured. On Linux this driver is
+ called \fIOpenIPMI\fP and it is included in standard distributions.
+-On Solaris this driver is called \fIBMC\fP and is inclued in Solaris 10.
++On Solaris this driver is called \fIBMC\fP and is included in Solaris 10.
+ Management of a remote station requires the IPMI\-over\-LAN interface to be
+ enabled and configured. Depending on the particular requirements of each
+ system it may be possible to enable the LAN interface using ipmitool over
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..d3b8208
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1,9 @@
+#0605-manpage_typo.patch
+#0105-typo.patch
+0100-fix_buf_overflow.patch
+0500-fix_CVE-2011-4339.patch
+#0610-readme_typo.patch
+0600-manpage_longlines.patch
+#0001-Dialect_change.patch
+0110-getpass-prototype.patch
+0115-typo.patch