summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules29
1 files changed, 29 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..52a96a6
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,29 @@
+#!/usr/bin/make -f
+
+#include /usr/share/quilt/quilt.make
+
+#export DH_VERBOSE=1
+export DH_OPTIONS
+
+#
+# Hardening
+#
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+
+%:
+ dh $@ --with systemd,autotools-dev
+
+override_dh_auto_install:
+ dh_auto_install
+ # No need to have two copies of the license text/changelog in the package.
+ $(RM) $(CURDIR)/debian/ipmitool/usr/share/doc/ipmitool/COPYING
+ $(RM) $(CURDIR)/debian/ipmitool/usr/share/doc/ipmitool/ChangeLog
+
+override_dh_installinit:
+ dh_installinit --name ipmievd --error-handler=ipmievd_initd_failed
+
+override_dh_systemd_enable:
+ dh_systemd_enable --no-enable ipmievd.service
+
+override_dh_auto_configure:
+ dh_auto_configure -- --prefix=/usr --with-kerneldir --mandir=/usr/share/man