summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules16
1 files changed, 3 insertions, 13 deletions
diff --git a/debian/rules b/debian/rules
index 320b420..f2c9474 100755
--- a/debian/rules
+++ b/debian/rules
@@ -8,21 +8,12 @@ export DH_OPTIONS
#
# Hardening
#
-export DEB_BUILD_HARDENING=1
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+DPKG_EXPORT_BUILDFLAGS = 1
+include /usr/share/dpkg/buildflags.mk
-CFLAGS = -Wall -g
-
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
- CFLAGS += -O0
-else
- CFLAGS += -O2
-endif
-ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
- INSTALL_PROGRAM += -s
-endif
-
%:
dh $@ --with systemd
@@ -38,4 +29,3 @@ override_dh_installinit:
override_dh_auto_configure:
dh_auto_configure -- --prefix=/usr --with-kerneldir --mandir=/usr/share/man
-