summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2017-01-03 02:33:48 +0100
committerJörg Frings-Fürst <debian@jff-webhosting.net>2017-01-03 02:33:48 +0100
commit96376f0df63c5df8c1380f0dd58b70d33566d48e (patch)
tree5c9eb82320f601e2f7637d36e58dd783d38a5914 /configure.ac
parent62a52f983e23e7b63b6bd5db6bd1f08a0259002a (diff)
parentf85b8b834b7ff85c80503faa73f237040330087b (diff)
Merge tag 'upstream/3.0.1'
Upstream version 3.0.1
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 15 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index f31123d..c16acb3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,5 +1,5 @@
dnl Process this file with autoconf to produce a configure script.
-AC_INIT(ipmiutil,3.0.0)
+AC_INIT(ipmiutil,3.0.1)
AC_CONFIG_SRCDIR(util/ipmiutil.c)
echo "ipmiutil version ${PACKAGE_VERSION}"
AM_CONFIG_HEADER(config.h)
@@ -404,15 +404,27 @@ else
sed -i 's/# Default-Start:/# Default-Start: 3 4 5/' $init_scripts
sed -i 's/# Default-Stop:/# Default-Stop: 0 1 2 6/' $init_scripts
fi
- if test -f "$LIB_DIR/libcrypto.so"; then
+ # The openssl rpm might not be installed
+ which rpm >/dev/null 2>&1
+ if test $? -eq 0 ; then
+ sslver=`rpm -q openssl-devel |cut -f3 -d'-' |cut -f1-2 -d'.'`
+ else
+ sslver=`openssl version |awk '{ print $2 }'|cut -f1-2 -d'.'`
+ fi
+ if test "$sslver" = "1.1"; then
+ echo "Detected openssl-$sslver"
+ MD2_CFLAGS="-DSKIP_MD2 -DSSL11"
+ else
+ if test -f "$LIB_DIR/libcrypto.so"; then
strings $LIB_DIR/libcrypto.so | grep EVP_md2 >/dev/null 2>&1
if test $? -ne 0; then
echo "No MD2 detected in openssl libcrypto.so"
MD2_CFLAGS="-DSKIP_MD2"
fi
- else
+ else
echo "No openssl $LIB_DIR/libcrypto.so detected"
MD2_CFLAGS="-DSKIP_MD2"
+ fi
fi
OS_CFLAGS="-DLINUX $MD2_CFLAGS -fPIC $cfwarn $cfgnu $cfhard"
else