summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2015-04-29 15:44:44 +0200
committerJörg Frings-Fürst <debian@jff-webhosting.net>2015-04-29 15:44:44 +0200
commitb18f5bf2db0fba2e7e539f68645836036d940d26 (patch)
tree23c4dd8f3d273f34ef9bbe1799d1958685559915 /debian/rules
parenta7f89980e5b3f4b9a74c70dbc5ffe8aabd28be28 (diff)
Imported Upstream version 2.9.6upstream/2.9.6
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules23
1 files changed, 0 insertions, 23 deletions
diff --git a/debian/rules b/debian/rules
deleted file mode 100755
index 49191d6..0000000
--- a/debian/rules
+++ /dev/null
@@ -1,23 +0,0 @@
-#!/usr/bin/make -f
-%:
- dh $@ --with autoreconf
-
-PKD = $(abspath $(dir $(MAKEFILE_LIST)))
-PKG = $(word 2,$(shell dpkg-parsechangelog -l$(PKD)/changelog | grep ^Source))
-VER ?= $(shell dpkg-parsechangelog -l$(PKD)/changelog | perl -ne 'print $$1 if m{^Version:\s+(?:\d+:)?(\d.*)(?:\-\d+.*)};')
-
-.PHONY: get-orig-source
-## http://wiki.debian.org/onlyjob/get-orig-source
-get-orig-source: $(info I: $(PKG)_$(VER))
- @echo "# Downloading..."
- uscan --noconf --verbose --rename --destdir=$(CURDIR) --check-dirname-level=0 --force-download --download-version $(VER) $(PKD)
-
-override_dh_auto_configure:
- dh_auto_configure -- --enable-gpl
-
-# work around bug #670796
-override_dh_autoreconf:
- dh_autoreconf --exclude=mkinstalldirs
-
-override_dh_installchangelogs:
- dh_installchangelogs ChangeLog