summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2016-12-20 14:33:23 +0100
committerJörg Frings-Fürst <debian@jff-webhosting.net>2016-12-20 14:33:23 +0100
commite9194cd4196384963a3ce7f62db37c69c9208d31 (patch)
tree08113b339ec4037df303c515b62706342453c582 /debian
parentbd09ecd67b21145aaaf79bcc8748aaebd190a026 (diff)
some systemd issues
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog10
-rw-r--r--debian/files1
-rw-r--r--debian/patches/0710-systemd.patch21
-rw-r--r--debian/patches/series1
-rwxr-xr-xdebian/rules4
5 files changed, 36 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 5a1a411..4e06f03 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,13 @@
+ipmiutil (3.0.0-3) UNRELEASED; urgency=medium
+
+ * Correct some systemd issues (Closes: #848861):
+ - debian/rules: Add dh_systemd_enable_overright to disable
+ ipmi_port at installation.
+ - New debian/patches/0710-systemd.patch to remove supported
+ characters.
+
+ -- Jörg Frings-Fürst <debian@jff-webhosting.net> Tue, 20 Dec 2016 11:55:42 +0100
+
ipmiutil (3.0.0-2) unstable; urgency=medium
* debian/control:
diff --git a/debian/files b/debian/files
deleted file mode 100644
index d432fc6..0000000
--- a/debian/files
+++ /dev/null
@@ -1 +0,0 @@
-ipmiutil_3.0.0-2_20161118T130004z-2bdcd63b.buildinfo utils optional
diff --git a/debian/patches/0710-systemd.patch b/debian/patches/0710-systemd.patch
new file mode 100644
index 0000000..77ddc1b
--- /dev/null
+++ b/debian/patches/0710-systemd.patch
@@ -0,0 +1,21 @@
+Description: Escape not allowed characters at ExecStart
+Author: Jörg Frings-Fürst <debian@jff-webhosting.net>
+Bug-Debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=848861
+Forwarded: https://sourceforge.net/p/ipmiutil/mailman/ipmiutil-developers/thread/1482238056.9870.6.camel%40jff-webhosting.net/#msg35561807
+Last-Update: 2016-12-20
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+Index: trunk/scripts/ipmi_port.service
+===================================================================
+--- trunk.orig/scripts/ipmi_port.service
++++ trunk/scripts/ipmi_port.service
+@@ -6,7 +6,8 @@ After=network.target
+ Type=forking
+ PIDFile=/run/ipmi_port.pid
+ EnvironmentFile=/usr/share/ipmiutil/ipmiutil.env
+-ExecStart=/usr/share/ipmiutil/ipmiutil.setup >/dev/null && /usr/sbin/ipmi_port -b || :
++ExecStartPre=/usr/share/ipmiutil/ipmiutil.setup
++ExecStart=-/usr/sbin/ipmi_port -b
+
+ [Install]
+ WantedBy=multi-user.target
diff --git a/debian/patches/series b/debian/patches/series
index 3c0bdc5..1f4e061 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -3,3 +3,4 @@
0700-init.patch
0600-typo-man.patch
0705-crontab.patch
+0710-systemd.patch
diff --git a/debian/rules b/debian/rules
index f123770..80520ed 100755
--- a/debian/rules
+++ b/debian/rules
@@ -32,3 +32,7 @@ override_dh_installinit:
dh_installinit --name=ipmiutil_asy
dh_installinit --name=ipmiutil_evt
dh_installinit --name=ipmiutil_wdt
+
+override_dh_systemd_enable:
+ dh_systemd_enable --no-enable ipmi_port.service
+