summaryrefslogtreecommitdiff
path: root/doc
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2014-11-12 17:25:25 +0100
committerJörg Frings-Fürst <debian@jff-webhosting.net>2014-11-12 17:25:25 +0100
commit14304e0827cd7de7fc55b1ba587ccdd380525b94 (patch)
treef70c126b91e68b66d7005cfea53b88a82aa0c7fa /doc
parentd279e229635f19852dc829552aa7c7d72d7a4dd2 (diff)
New upstream release
Diffstat (limited to 'doc')
-rw-r--r--doc/Makefile29
-rw-r--r--doc/Makefile.in5
-rw-r--r--doc/UserGuide3
-rw-r--r--doc/icmd.84
-rw-r--r--doc/ilan.82
-rw-r--r--doc/ipmiutil.spec19
-rw-r--r--doc/isel.84
-rw-r--r--doc/isol.82
8 files changed, 46 insertions, 22 deletions
diff --git a/doc/Makefile b/doc/Makefile
index 4ec983d..4016bc3 100644
--- a/doc/Makefile
+++ b/doc/Makefile
@@ -47,14 +47,14 @@ CONFIG_CLEAN_FILES =
SOURCES =
DIST_SOURCES =
DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
-ACLOCAL = ${SHELL} /home/acress/ipmiutil/src/missing --run aclocal-1.9
+ACLOCAL = ${SHELL} /usr/dev/ipmiutil-2.9.5/missing --run aclocal-1.9
AMDEP_FALSE = #
AMDEP_TRUE =
-AMTAR = ${SHELL} /home/acress/ipmiutil/src/missing --run tar
+AMTAR = ${SHELL} /usr/dev/ipmiutil-2.9.5/missing --run tar
AR = ar
-AUTOCONF = ${SHELL} /home/acress/ipmiutil/src/missing --run autoconf
-AUTOHEADER = ${SHELL} /home/acress/ipmiutil/src/missing --run autoheader
-AUTOMAKE = ${SHELL} /home/acress/ipmiutil/src/missing --run automake-1.9
+AUTOCONF = ${SHELL} /usr/dev/ipmiutil-2.9.5/missing --run autoconf
+AUTOHEADER = ${SHELL} /usr/dev/ipmiutil-2.9.5/missing --run autoheader
+AUTOMAKE = ${SHELL} /usr/dev/ipmiutil-2.9.5/missing --run automake-1.9
AWK = gawk
CC = gcc
CCDEPMODE = depmode=gcc3
@@ -97,24 +97,26 @@ LDFLAGS =
LD_SAMX = ../lib/libipmi_lanplus.a -lcrypto
LIBOBJS =
LIBS =
+LIBSENSORS =
LIBTOOL = $(SHELL) $(top_builddir)/libtool
LIB_DIR = /usr/lib64
LN_S = ln -s
LTLIBOBJS =
-MAKEINFO = ${SHELL} /home/acress/ipmiutil/src/missing --run makeinfo
+MAKEINFO = ${SHELL} /usr/dev/ipmiutil-2.9.5/missing --run makeinfo
OBJEXT = o
OS_CFLAGS = -DLINUX -fPIC -fstack-protector --param=ssp-buffer-size=4 -D_FORTIFY_SOURCE=2
OS_DRIVERS = imbapi.c ipmimv.c ipmild.c ipmidir.c
OS_LFLAGS =
PACKAGE = ipmiutil
PACKAGE_BUGREPORT =
-PACKAGE_NAME =
-PACKAGE_STRING =
-PACKAGE_TARNAME =
-PACKAGE_VERSION =
+PACKAGE_NAME = ipmiutil
+PACKAGE_STRING = ipmiutil 2.9.5
+PACKAGE_TARNAME = ipmiutil
+PACKAGE_VERSION = 2.9.5
PATH_SEPARATOR = :
PKG_DIR = /usr/src/redhat
RANLIB = ranlib
+SAM2OBJ = isensor2.o ievents2.o
SED = /bin/sed
SET_MAKE =
SHELL = /bin/sh
@@ -122,7 +124,9 @@ SHR_LINK = libipmiutil.so
STRIP = strip
SUBDIR_S = doc scripts lib util
SYSTEMD_DIR = /usr/share/ipmiutil
-VERSION = 2.9.4
+VERSION = 2.9.5
+WITH_PKG_CONFIG_FALSE = #
+WITH_PKG_CONFIG_TRUE =
ac_ct_AR = ar
ac_ct_CC = gcc
ac_ct_CXX = g++
@@ -153,13 +157,14 @@ host_os = linux-gnu
host_vendor = redhat
includedir = ${prefix}/include
infodir = ${prefix}/info
-install_sh = /home/acress/ipmiutil/src/install-sh
+install_sh = /usr/dev/ipmiutil-2.9.5/install-sh
libdir = ${exec_prefix}/lib
libexecdir = ${exec_prefix}/libexec
localstatedir = ${prefix}/var
mandir = ${prefix}/share/man
mkdir_p = mkdir -p --
oldincludedir = /usr/include
+pkgconfigdir = ${libdir}/pkgconfig
prefix = /usr
program_transform_name = s,x,x,
sbindir = ${exec_prefix}/sbin
diff --git a/doc/Makefile.in b/doc/Makefile.in
index a6825ce..0a8583f 100644
--- a/doc/Makefile.in
+++ b/doc/Makefile.in
@@ -97,6 +97,7 @@ LDFLAGS = @LDFLAGS@
LD_SAMX = @LD_SAMX@
LIBOBJS = @LIBOBJS@
LIBS = @LIBS@
+LIBSENSORS = @LIBSENSORS@
LIBTOOL = @LIBTOOL@
LIB_DIR = @LIB_DIR@
LN_S = @LN_S@
@@ -115,6 +116,7 @@ PACKAGE_VERSION = @PACKAGE_VERSION@
PATH_SEPARATOR = @PATH_SEPARATOR@
PKG_DIR = @PKG_DIR@
RANLIB = @RANLIB@
+SAM2OBJ = @SAM2OBJ@
SED = @SED@
SET_MAKE = @SET_MAKE@
SHELL = @SHELL@
@@ -123,6 +125,8 @@ STRIP = @STRIP@
SUBDIR_S = @SUBDIR_S@
SYSTEMD_DIR = @SYSTEMD_DIR@
VERSION = @VERSION@
+WITH_PKG_CONFIG_FALSE = @WITH_PKG_CONFIG_FALSE@
+WITH_PKG_CONFIG_TRUE = @WITH_PKG_CONFIG_TRUE@
ac_ct_AR = @ac_ct_AR@
ac_ct_CC = @ac_ct_CC@
ac_ct_CXX = @ac_ct_CXX@
@@ -160,6 +164,7 @@ localstatedir = @localstatedir@
mandir = ${prefix}/share/man
mkdir_p = @mkdir_p@
oldincludedir = @oldincludedir@
+pkgconfigdir = @pkgconfigdir@
prefix = /usr
program_transform_name = @program_transform_name@
sbindir = @sbindir@
diff --git a/doc/UserGuide b/doc/UserGuide
index d7eb67c..d6bd83d 100644
--- a/doc/UserGuide
+++ b/doc/UserGuide
@@ -1,6 +1,6 @@
IPMIUTIL USER GUIDE
- VERSION 2.9.4
+ VERSION 2.9.5
An easy-to-use IPMI server management utility
@@ -6161,6 +6161,7 @@ The make rpm produces a binary rpm, and a source rpm, which can be
installed with "rpm -i *.rpm".
To build and install a Debian package, do this:
+# mv debpkg debian
# dpkg-buildpackage
then install it with "dpkg -i *.deb".
diff --git a/doc/icmd.8 b/doc/icmd.8
index f786528..eb98ba8 100644
--- a/doc/icmd.8
+++ b/doc/icmd.8
@@ -3,7 +3,7 @@
ipmiutil_cmd \- a tool to send specific IPMI commands via the command line.
.SH SYNOPSIS
-.B "ipmiutil cmd [-qsx -NUPREFJTVY] bus rsSa netFn/lun cmd [data bytes]"
+.B "ipmiutil cmd [-pqsx -NUPREFJTVY] bus rsSa netFn/lun cmd [data bytes]"
.SH DESCRIPTION
This
@@ -26,6 +26,8 @@ specification, or you have specific pre-written commands to send.
.SH OPTIONS
Command line options are described below.
+.IP "-p"
+Port to use. Defaults to RMCP port 623.
.IP "-q"
Quiet mode. Show only minimal header information.
.IP "-s"
diff --git a/doc/ilan.8 b/doc/ilan.8
index 31b26ae..533f5cf 100644
--- a/doc/ilan.8
+++ b/doc/ilan.8
@@ -185,6 +185,8 @@ The default is to automatically obtain this from the Linux ifconfig.
Nodename or IP address of the remote target system. If a nodename is
specified, IPMI LAN interface is used. Otherwise the local system
management interface is used.
+.IP "-O"
+Observe security. Disables the default null user and disable cipher 0.
.IP "-P rmt_pswd"
Remote password for the nodename given. The default is a null password.
Same as \-R below.
diff --git a/doc/ipmiutil.spec b/doc/ipmiutil.spec
index 245eb44..308289e 100644
--- a/doc/ipmiutil.spec
+++ b/doc/ipmiutil.spec
@@ -3,7 +3,7 @@
# Copyright (c) 2012 Andy Cress
#
Name: ipmiutil
-Version: 2.9.4
+Version: 2.9.5
Release: 1%{?dist}
Summary: Easy-to-use IPMI server management utilities
License: BSD
@@ -13,7 +13,7 @@ URL: http://ipmiutil.sourceforge.net
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
# Suggests: cron or vixie-cron or cronie or similar
%if 0%{?fedora} >= 15
-BuildRequires: systemd
+BuildRequires: systemd autoconf automake
Requires: systemd-units
%endif
%if 0%{?suse_version} >= 1210
@@ -30,7 +30,7 @@ BuildRequires: gcc gcc-c++ libtool systemd
%define systemd_fls %{unit_dir}
# Requires: %{?systemd_requires}
%else
-BuildRequires: gcc gcc-c++ libtool
+BuildRequires: gcc gcc-c++ libtool
%if 0%{?fedora} == 16
%define unit_dir /lib/systemd/system
%else
@@ -55,12 +55,19 @@ detected, ipmiutil will use user-space direct I/Os instead.
%package devel
Group: Development/Libraries
Summary: Includes libraries and headers for the ipmiutil package
-Provides: ipmiutil-static = %{version}-%{release}
%description devel
The ipmiutil-devel package contains headers and libraries which are
useful for building custom IPMI applications.
+%package static
+Group: Development/Libraries
+Summary: Includes static libraries for the ipmiutil package
+
+%description static
+The ipmiutil-static package contains static libraries which are
+useful for building custom IPMI applications.
+
%prep
%setup -q
@@ -167,9 +174,11 @@ rm -rf %{buildroot}
%{_datadir}/%{name}/ievents.h
%{_datadir}/%{name}/Makefile
%{_includedir}/ipmicmd.h
-%{_libdir}/libipmiutil.a
%{_libdir}/libipmiutil.so
+%files static
+%defattr(-,root,root)
+%{_libdir}/libipmiutil.a
%pre
%if 0%{?req_systemd}
diff --git a/doc/isel.8 b/doc/isel.8
index a765e32..62180bb 100644
--- a/doc/isel.8
+++ b/doc/isel.8
@@ -65,9 +65,7 @@ Show output in a nominal/canonical format, with a default delimiter of '|'.
Show the 16 raw hex bytes for each SEL entry. The default is to display
interpreted entries, and include relevant hex event bytes.
.IP "-p"
-By default, all SEL records are displayed. This option
-causes only the Panic events with sensor_type = 0x20 (OS Critical Stop)
-to be displayed.
+Port to use. Defaults to RMCP port 623.
.IP "-s N"
Show only SEL events with severity N or greater. Severity 0=INF, 1=MIN,
2=MAJ, 3=CRT. The default is to show all SEL events.
diff --git a/doc/isol.8 b/doc/isol.8
index 7048f64..d2e594c 100644
--- a/doc/isol.8
+++ b/doc/isol.8
@@ -55,6 +55,8 @@ Use a Trace log. The output_file is created and all SOL screen output is
written to the file, including VT100 escape sequences. If the output_file
exists, the output is appended to it. This can be used to log what the
user has done in an SOL session.
+.IP "-p"
+Port to use. Defaults to RMCP port 623.
.IP "-r"
Use Raw terminal I/O instead of custom VT100 to ANSI translation (in Windows).
Use this option if the server is configured in BIOS and BMC for ANSI and