summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules6
1 files changed, 4 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index 59df3b7..6ed560b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,17 +2,19 @@
# -*- makefile -*-
# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
+# export DH_VERBOSE=1
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+CFLAGS += -fPIC
+CONFPARA = --enable-gpl --enable-useflags --enable-libsensors
%:
dh $@ --with autotools-dev --with systemd
override_dh_auto_configure:
$(CURDIR)/beforeconf.sh
- dh_auto_configure
+ dh_auto_configure -- $(CONFPARA)
override_dh_autoreconf:
dh_autoreconf --exclude=mkinstalldirs