summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2018-03-20 07:26:48 +0100
committerJörg Frings-Fürst <debian@jff-webhosting.net>2018-03-20 07:26:48 +0100
commit8309cf5867aabde511db492366cbbec39d45e0cb (patch)
treef456bb7bf59fb67a8d099eb4dca819e1c71a1d0e /CMakeLists.txt
parent2f7903e9688734698615db5889efa21ffaf59c4d (diff)
parent6c434f095b49a3c33c6e34f27f0bff906f162d85 (diff)
Merge branch 'feature/upstream' into develop
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9e1efe8..1d4d3a7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -4,9 +4,8 @@ cmake_minimum_required(VERSION 2.8)
project(oniguruma C)
set(PACKAGE onig)
-set(PACKAGE_VERSION "6.6.0")
+set(PACKAGE_VERSION "6.8.1")
-set(USE_COMBINATION_EXPLOSION_CHECK 0)
set(USE_CRNL_AS_LINE_TERMINATOR 0)
set(VERSION ${PACKAGE_VERSION})
@@ -40,6 +39,7 @@ check_include_files(stdint.h HAVE_STDINT_H)
check_include_files(stdlib.h HAVE_STDLIB_H)
check_include_files(strings.h HAVE_STRINGS_H)
check_include_files(string.h HAVE_STRING_H)
+check_include_files(limits.h HAVE_LIMITS_H)
check_include_files(sys/times.h HAVE_SYS_TIMES_H)
check_include_files(sys/time.h HAVE_SYS_TIME_H)
check_include_files(sys/types.h HAVE_SYS_TYPES_H)
@@ -80,7 +80,7 @@ install_library(onig)
install_header(src/oniguruma.h src/onigposix.h src/oniggnu.h)
-install_doc(doc/API doc/API.ja doc/RE doc/RE.ja doc/UNICODE_PROPERTIES)
+install_doc(doc/API doc/API.ja doc/RE doc/RE.ja doc/FAQ doc/FAQ.ja doc/CALLOUTS.BUILTIN doc/CALLOUTS.BUILTIN.ja doc/UNICODE_PROPERTIES)
install_data(AUTHORS COPYING HISTORY README.md)
install(FILES ${CMAKE_CURRENT_BINARY_DIR}/oniguruma.pc