summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff.email>2021-04-26 17:40:21 +0200
committerJörg Frings-Fürst <debian@jff.email>2021-04-26 17:40:21 +0200
commitd3a83c35311ec631a46b59b66c38ef8d3a2a629a (patch)
tree28fc4dd524fa29f712020b61e565ab47b1fefd8e /CMakeLists.txt
parent77a04959299aa252579a98655e626d1b8f5f9f34 (diff)
parent98f7065a3f7b386564840bb5b24b94f9335b2e97 (diff)
Update upstream source from tag 'upstream/6.9.7.1'
Update to upstream version '6.9.7.1' with Debian dir c2c92e088b7e91033d7f5bee51ac7827148eaf4b
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 06af497..1944037 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,6 +1,6 @@
cmake_minimum_required(VERSION 3.1)
project(oniguruma
- VERSION 6.9.6
+ VERSION 6.9.7
LANGUAGES C)
set(PACKAGE onig)
@@ -100,6 +100,12 @@ if(MSVC)
$<$<CONFIG:RelWithDebgInfo>:/MTd>
)
endif()
+ if(MSVC_VERSION LESS_EQUAL "1800")
+ # <= VS2013
+ target_compile_definitions(onig PRIVATE
+ -Dinline=__inline
+ )
+ endif()
elseif(CMAKE_COMPILER_IS_GNUCC)
target_compile_options(onig PRIVATE
-Wall