summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff.email>2020-11-08 10:58:36 +0100
committerJörg Frings-Fürst <debian@jff.email>2020-11-08 10:58:36 +0100
commitb4158caf13bc715096c1df7c040c9d25995d76f2 (patch)
treea07d7d0764a8488f4b5ebef1561e2f3d8caacc05 /Makefile.am
parent0f259c3073f341c48468e80e93731daa31698030 (diff)
parentfc9ba4264eafbb5a6ec0f3cc4cd2e1964c9b8fcf (diff)
Update upstream source from tag 'upstream/6.9.6'
Update to upstream version '6.9.6' with Debian dir 111ba939e0875272a460014bdcf030d413ce8f3f
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index fc3885b..0880b2d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -61,6 +61,11 @@ sanitize:
make
make all-test
+debug_out_sanitize:
+ make clean
+ ./configure CFLAGS="-O0 -g -fsanitize=address -DONIG_DEBUG_PARSE -DONIG_DEBUG_COMPILE" LDFLAGS="-fsanitize=address"
+ make
+
cov:
make lcov-clear
cd test; make CFLAGS="--coverage" test