summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff.email>2019-08-07 09:33:20 +0200
committerJörg Frings-Fürst <debian@jff.email>2019-08-07 09:33:20 +0200
commit07b900d0bf8e732a347d27a5936b790a316c3197 (patch)
tree2443bfdda69965757d8ce335cda1a28bb7327834 /Makefile.am
parent80e416a8ea3bd56ec54a74a93ddc2c61a398679a (diff)
parent1fb4b2b100d76cfa362cd021760b7cc0038cf55d (diff)
Merge branch 'feature/upstream' into develop
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 6045eae..a0bbc7b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -39,6 +39,12 @@ pkgconfig_DATA = oniguruma.pc
all-test:
cd test; make test
+sanitize:
+ make clean
+ ./configure CC=clang CFLAGS="-O -g -fsanitize=address"
+ make
+ make all-test
+
cov:
make lcov-clear
cd test; make CFLAGS="--coverage" test