summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff.email>2019-08-07 09:32:54 +0200
committerJörg Frings-Fürst <debian@jff.email>2019-08-07 09:32:54 +0200
commit1fb4b2b100d76cfa362cd021760b7cc0038cf55d (patch)
tree2443bfdda69965757d8ce335cda1a28bb7327834 /Makefile.am
parentb134093d75235a90f09ff591137aed9dbdad6e89 (diff)
parent40f3d0030e6e98bcb02d6523e5ee48497dec49a6 (diff)
Update upstream source from tag 'upstream/6.9.3'
Update to upstream version '6.9.3' with Debian dir 0b54db06b48ebf22a6090f21e4dcc045a1085e11
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 6045eae..a0bbc7b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -39,6 +39,12 @@ pkgconfig_DATA = oniguruma.pc
all-test:
cd test; make test
+sanitize:
+ make clean
+ ./configure CC=clang CFLAGS="-O -g -fsanitize=address"
+ make
+ make all-test
+
cov:
make lcov-clear
cd test; make CFLAGS="--coverage" test