summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff.email>2019-07-12 09:18:45 +0200
committerJörg Frings-Fürst <debian@jff.email>2019-07-12 09:18:45 +0200
commited7b90269a529d90d151969348e55347fae02c0d (patch)
tree7c72e5a49112a844a53a2c10ef1fda47867aee92 /Makefile.am
parent6cac1738b6aebf75b29d225775030d291319f9a2 (diff)
parent5c29b174a11e992dac68553f08645fe4a825c315 (diff)
Merge branch 'feature/upstream' into develop
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am21
1 files changed, 20 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 2f1a6e7..6045eae 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -11,7 +11,7 @@ EXTRA_DIST = oniguruma.pc.in HISTORY README_japanese README.md \
doc/API doc/API.ja doc/RE doc/RE.ja doc/FAQ doc/FAQ.ja \
doc/CALLOUTS.BUILTIN doc/CALLOUTS.BUILTIN.ja \
doc/CALLOUTS.API doc/CALLOUTS.API.ja \
- doc/UNICODE_PROPERTIES \
+ doc/SYNTAX.md doc/UNICODE_PROPERTIES \
src/Makefile.windows src/config.h.windows.in \
src/config.h.win32 src/config.h.win64 \
windows/testc.c contributed/libfuzzer-onig.cpp contributed/makefile
@@ -38,3 +38,22 @@ pkgconfig_DATA = oniguruma.pc
all-test:
cd test; make test
+
+cov:
+ make lcov-clear
+ cd test; make CFLAGS="--coverage" test
+ make lcov
+
+gcov:
+ make CFLAGS="--coverage"
+
+lcov:
+ lcov -c -d src/.libs -o coverage.info
+ genhtml -o coverage coverage.info
+
+lcov-clear:
+ lcov -z -d .
+
+cov-clean: clean
+ rm -rf coverage coverage.info
+ find . -name '*.gcno' | xargs rm -f