summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff.email>2019-11-29 11:26:40 +0100
committerJörg Frings-Fürst <debian@jff.email>2019-11-29 11:26:40 +0100
commit7e149a97d276ce3b4c5e34f965766c8e40e03fef (patch)
tree5f90c63b8ba73f4ecd23d6e642c1ab34dccea033 /Makefile.am
parentc527ea541a9633fb14391c981861e70070d9402f (diff)
parent4216de6a3336cbc6dddb572cb7e6ab6193bf3729 (diff)
Update upstream source from tag 'upstream/6.9.4'
Update to upstream version '6.9.4' with Debian dir 02ee3cf90d9374728e429b9f574cef3b70759f00
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index a0bbc7b..ac5e27f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -14,7 +14,7 @@ EXTRA_DIST = oniguruma.pc.in HISTORY README_japanese README.md \
doc/SYNTAX.md doc/UNICODE_PROPERTIES \
src/Makefile.windows src/config.h.windows.in \
src/config.h.win32 src/config.h.win64 \
- windows/testc.c contributed/libfuzzer-onig.cpp contributed/makefile
+ windows/testc.c
bin_SCRIPTS = onig-config
@@ -39,9 +39,12 @@ pkgconfig_DATA = oniguruma.pc
all-test:
cd test; make test
+archive:
+ git archive --format=tar --prefix=oniguruma/ HEAD | gzip > ../oniguruma-archive.tar.gz
+
sanitize:
make clean
- ./configure CC=clang CFLAGS="-O -g -fsanitize=address"
+ ./configure --enable-posix-api=no CC=clang CFLAGS="-O -g -fsanitize=address" LDFLAGS="-fsanitize=address"
make
make all-test