summaryrefslogtreecommitdiff
path: root/sample/Makefile.am
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff.email>2021-04-26 17:40:21 +0200
committerJörg Frings-Fürst <debian@jff.email>2021-04-26 17:40:21 +0200
commitd3a83c35311ec631a46b59b66c38ef8d3a2a629a (patch)
tree28fc4dd524fa29f712020b61e565ab47b1fefd8e /sample/Makefile.am
parent77a04959299aa252579a98655e626d1b8f5f9f34 (diff)
parent98f7065a3f7b386564840bb5b24b94f9335b2e97 (diff)
Update upstream source from tag 'upstream/6.9.7.1'
Update to upstream version '6.9.7.1' with Debian dir c2c92e088b7e91033d7f5bee51ac7827148eaf4b
Diffstat (limited to 'sample/Makefile.am')
-rw-r--r--sample/Makefile.am8
1 files changed, 5 insertions, 3 deletions
diff --git a/sample/Makefile.am b/sample/Makefile.am
index c2c4596..681cd2a 100644
--- a/sample/Makefile.am
+++ b/sample/Makefile.am
@@ -4,13 +4,13 @@ lib_onig = ../src/libonig.la
LDADD = $(lib_onig)
AM_CFLAGS = -Wall
-AM_LDFLAGS = -L$(prefix)/lib
+AM_LDFLAGS = -L$(libdir)
AM_CPPFLAGS = -I$(top_srcdir)/src
if ENABLE_POSIX_API
-TESTS = encode listcap names posix simple sql syntax user_property callout echo count bug_fix regset scan
+TESTS = encode listcap names posix simple sql syntax user_property callout echo count bug_fix regset scan callback_each_match
else
-TESTS = encode listcap names simple sql syntax user_property callout echo count bug_fix regset scan
+TESTS = encode listcap names simple sql syntax user_property callout echo count bug_fix regset scan callback_each_match
endif
check_PROGRAMS = $(TESTS)
@@ -29,6 +29,7 @@ count_SOURCES = count.c
bug_fix = bug_fix.c
regset_SOURCES = regset.c
scan_SOURCES = scan.c
+callback_each_match_SOURCES = callback_each_match.c
sampledir = .
@@ -49,3 +50,4 @@ endif
$(sampledir)/bug_fix
$(sampledir)/regset
$(sampledir)/scan
+ $(sampledir)/callback_each_match