summaryrefslogtreecommitdiff
path: root/src/Makefile.windows
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2017-12-14 16:55:14 +0100
committerJörg Frings-Fürst <debian@jff-webhosting.net>2017-12-14 16:55:14 +0100
commit7bd40e53626a0ec5621fc5b71cfaf5956b4e6ba9 (patch)
tree4c62db42cffb80511f26e1168a6f54aba5815422 /src/Makefile.windows
parent4fdc47601d9e68343fa6818beda4c6a2012baccd (diff)
parent98ab313fe496ae7c792db29c80bf6b23347484ff (diff)
Update upstream source from tag 'upstream/6.7.0'
Update to upstream version '6.7.0' with Debian dir 14acc711c745d23b05fab9587ac8849fefa02c06
Diffstat (limited to 'src/Makefile.windows')
-rw-r--r--src/Makefile.windows20
1 files changed, 10 insertions, 10 deletions
diff --git a/src/Makefile.windows b/src/Makefile.windows
index 8c22aa9..046345a 100644
--- a/src/Makefile.windows
+++ b/src/Makefile.windows
@@ -158,26 +158,26 @@ ptest: $(testp)
.\$(testp)
$(testc): $(testc).c $(libname)
- $(CC) -nologo -o $(testc) -DONIG_EXTERN=extern $(testc).c $(libname)
+ $(CC) -nologo /Fe:$(testc) -DONIG_EXTERN=extern $(testc).c $(libname)
$(testp): $(testc).c $(dlllib)
- $(CC) -nologo -DPOSIX_TEST -o $(testp) $(testc).c $(dlllib)
+ $(CC) -nologo -DPOSIX_TEST /Fe:$(testp) $(testc).c $(dlllib)
#$(testc)u.c: test.rb testconvu.rb
# ruby -Ke testconvu.rb test.rb > $@
$(testc)u: $(testc)u.c $(libname)
- $(CC) -nologo -o $(testc)u -DONIG_EXTERN=extern $(testc)u.c $(libname)
+ $(CC) -nologo /Fe:$(testc)u -DONIG_EXTERN=extern $(testc)u.c $(libname)
clean:
del *.obj *.lib *.exp *.dll $(testp).exe $(testc).exe $(testc).obj
samples: all
- $(CC) $(CFLAGS) -I. -o simple sample\simple.c $(dlllib)
- $(CC) $(CFLAGS) -I. -o posix sample\posix.c $(dlllib)
- $(CC) $(CFLAGS) -I. -o names sample\names.c $(dlllib)
- $(CC) $(CFLAGS) -I. -o listcap sample\listcap.c $(dlllib)
- $(CC) $(CFLAGS) -I. -o sql sample\sql.c $(dlllib)
- $(CC) $(CFLAGS) -I. -o encode sample\encode.c $(dlllib)
- $(CC) $(CFLAGS) -I. -o syntax sample\syntax.c $(dlllib)
+ $(CC) $(CFLAGS) -I. /Fe:simple sample\simple.c $(dlllib)
+ $(CC) $(CFLAGS) -I. /Fe:posix sample\posix.c $(dlllib)
+ $(CC) $(CFLAGS) -I. /Fe:names sample\names.c $(dlllib)
+ $(CC) $(CFLAGS) -I. /Fe:listcap sample\listcap.c $(dlllib)
+ $(CC) $(CFLAGS) -I. /Fe:sql sample\sql.c $(dlllib)
+ $(CC) $(CFLAGS) -I. /Fe:encode sample\encode.c $(dlllib)
+ $(CC) $(CFLAGS) -I. /Fe:syntax sample\syntax.c $(dlllib)