summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2016-05-10 05:15:59 +0200
committerJörg Frings-Fürst <debian@jff-webhosting.net>2016-05-10 05:15:59 +0200
commite706cbe5496e1829d1ddbe4d5bb0a6728204e510 (patch)
treec72d1848ac6aef07703848d0ffbe80f1336a81cd /test/Makefile.am
parent69ab3addbc2dbbc90c311b2845cd25a2159435cd (diff)
parent5e01a4852b31d537307994248869caf38b4023cc (diff)
new upstream release
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
new file mode 100644
index 0000000..fe48403
--- /dev/null
+++ b/test/Makefile.am
@@ -0,0 +1,28 @@
+## Makefile.am for Oniguruma
+lib_onig = ../src/libonig.la
+
+AM_LDFLAGS = -L$(prefix)/lib
+AM_CFLAGS =
+AM_CPPFLAGS = -I../src -I$(includedir)
+
+TESTS = testc testp testcu
+
+check_PROGRAMS = testc testp testcu
+
+test: testc testp testcu
+ @echo "[Oniguruma API, ASCII/EUC-JP check]"
+ @./testc | grep RESULT
+ @echo "[POSIX API, ASCII/EUC-JP check]"
+ @./testp | grep RESULT
+ @echo "[Oniguruma API, UTF-16 check]"
+ @./testcu | grep RESULT
+
+testc_SOURCES = testc.c
+testc_LDADD = $(lib_onig)
+
+testp_SOURCES = testc.c
+testp_LDADD = $(lib_onig)
+testp_CFLAGS = -DPOSIX_TEST
+
+testcu_SOURCES = testu.c
+testcu_LDADD = $(lib_onig)