summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2018-03-20 07:26:48 +0100
committerJörg Frings-Fürst <debian@jff-webhosting.net>2018-03-20 07:26:48 +0100
commit8309cf5867aabde511db492366cbbec39d45e0cb (patch)
treef456bb7bf59fb67a8d099eb4dca819e1c71a1d0e /test/Makefile.am
parent2f7903e9688734698615db5889efa21ffaf59c4d (diff)
parent6c434f095b49a3c33c6e34f27f0bff906f162d85 (diff)
Merge branch 'feature/upstream' into develop
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 9643bb0..6559a77 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -2,7 +2,7 @@
lib_onig = ../src/libonig.la
AM_LDFLAGS = -L$(prefix)/lib
-AM_CFLAGS =
+AM_CFLAGS = -Wall -Wno-invalid-source-encoding
AM_CPPFLAGS = -I$(top_srcdir)/src -I$(includedir)
TESTS = test_utf8 testc testp testcu
@@ -27,7 +27,8 @@ testc_LDADD = $(lib_onig)
testp_SOURCES = testc.c
testp_LDADD = $(lib_onig)
-testp_CFLAGS = -DPOSIX_TEST
+testp_CFLAGS = -DPOSIX_TEST -Wall -Wno-invalid-source-encoding
+
testcu_SOURCES = testu.c
testcu_LDADD = $(lib_onig)