summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2018-03-20 06:14:54 +0100
committerJörg Frings-Fürst <debian@jff-webhosting.net>2018-03-20 06:14:54 +0100
commit87775e053d9f78506d8b4d3904c5f824c908389e (patch)
tree027c5a2496c7306f0445942537fe70faf52fa785 /test/Makefile.am
parent2f7903e9688734698615db5889efa21ffaf59c4d (diff)
parent10abcf77cc24dfae451d96310b4391dad35906ed (diff)
Update upstream source from tag 'upstream/6.8.1'
Update to upstream version '6.8.1' with Debian dir 4321ce29f0c752eb322b128cd10520c8d9a87991
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 9643bb0..6559a77 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -2,7 +2,7 @@
lib_onig = ../src/libonig.la
AM_LDFLAGS = -L$(prefix)/lib
-AM_CFLAGS =
+AM_CFLAGS = -Wall -Wno-invalid-source-encoding
AM_CPPFLAGS = -I$(top_srcdir)/src -I$(includedir)
TESTS = test_utf8 testc testp testcu
@@ -27,7 +27,8 @@ testc_LDADD = $(lib_onig)
testp_SOURCES = testc.c
testp_LDADD = $(lib_onig)
-testp_CFLAGS = -DPOSIX_TEST
+testp_CFLAGS = -DPOSIX_TEST -Wall -Wno-invalid-source-encoding
+
testcu_SOURCES = testu.c
testcu_LDADD = $(lib_onig)