summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2017-12-14 14:22:27 +0100
committerJörg Frings-Fürst <debian@jff-webhosting.net>2017-12-14 14:22:27 +0100
commitfa131e9ad996d099bb48a3b1302e4a3b3c0f03bd (patch)
tree7b4963ddd27303d1a8e856acdd3a55ce9ed179f7 /test/Makefile.am
parenta89a4ac904bc93b1d93b410394fa05c23260351b (diff)
parentb7ad39361a923207113da1145f8655a1bc50c3aa (diff)
Merge branch 'release/6.6.1-1'6.6.1-1
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am11
1 files changed, 8 insertions, 3 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index fe48403..2930e7f 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -5,11 +5,13 @@ AM_LDFLAGS = -L$(prefix)/lib
AM_CFLAGS =
AM_CPPFLAGS = -I../src -I$(includedir)
-TESTS = testc testp testcu
+TESTS = test_utf8 testc testp testcu
-check_PROGRAMS = testc testp testcu
+check_PROGRAMS = test_utf8 testc testp testcu
-test: testc testp testcu
+test: test_utf8 testc testp testcu
+ @echo "[Oniguruma API, UTF-8 check]"
+ @./test_utf8 | grep RESULT
@echo "[Oniguruma API, ASCII/EUC-JP check]"
@./testc | grep RESULT
@echo "[POSIX API, ASCII/EUC-JP check]"
@@ -17,6 +19,9 @@ test: testc testp testcu
@echo "[Oniguruma API, UTF-16 check]"
@./testcu | grep RESULT
+test_utf8_SOURCES = test_utf8.c
+test_utf8_LDADD = $(lib_onig)
+
testc_SOURCES = testc.c
testc_LDADD = $(lib_onig)