summaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/001-changes_build_sys.diff44
-rw-r--r--debian/patches/0100-source_typos.patch18
-rw-r--r--debian/patches/series2
3 files changed, 64 insertions, 0 deletions
diff --git a/debian/patches/001-changes_build_sys.diff b/debian/patches/001-changes_build_sys.diff
new file mode 100644
index 0000000..5750433
--- /dev/null
+++ b/debian/patches/001-changes_build_sys.diff
@@ -0,0 +1,44 @@
+Description: some buildsystem changes
+Author: Jörg Frings-Fürst <debian@jff-webhosting.net>
+Reviewed-by:
+Last-Update: 2014-05-07
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+Index: trunk/configure.in
+===================================================================
+--- trunk.orig/configure.in
++++ trunk/configure.in
+@@ -1,9 +1,11 @@
+ dnl Process this file with autoconf to produce a configure script.
+ AC_INIT(onig, 5.9.6)
+
++
++AUTOMAKE_OPTIONS=subdir-objects
+ AC_CONFIG_MACRO_DIR([m4])
+
+-AM_INIT_AUTOMAKE
++AM_INIT_AUTOMAKE([foreign])
+ AC_CONFIG_HEADER(config.h)
+
+
+@@ -41,7 +43,7 @@ fi
+ dnl Checks for programs.
+ AC_PROG_CC
+ AM_PROG_LIBTOOL
+-LTVERSION="2:0:0"
++LTVERSION="2:1:0"
+ AC_SUBST(LTVERSION)
+
+ AC_PROG_INSTALL
+Index: trunk/Makefile.am
+===================================================================
+--- trunk.orig/Makefile.am
++++ trunk/Makefile.am
+@@ -3,6 +3,7 @@ encdir = $(top_srcdir)/enc
+ sampledir = $(top_srcdir)/sample
+ libname = libonig.la
+
++AUTOMAKE_OPTIONS=subdir-objects
+ ACLOCAL_AMFLAGS = -I m4
+ #AM_CFLAGS = -DNOT_RUBY
+ AM_CFLAGS =
diff --git a/debian/patches/0100-source_typos.patch b/debian/patches/0100-source_typos.patch
new file mode 100644
index 0000000..fe1bca0
--- /dev/null
+++ b/debian/patches/0100-source_typos.patch
@@ -0,0 +1,18 @@
+Description: Fix typos
+Author: Jörg Frings-Fürst <debian@jff-webhosting.net>
+Last-Update: 2016-11-09
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+Index: trunk/src/regerror.c
+===================================================================
+--- trunk.orig/src/regerror.c
++++ trunk/src/regerror.c
+@@ -65,7 +65,7 @@ onig_error_code_to_format(int code)
+ case ONIGERR_UNEXPECTED_BYTECODE:
+ p = "unexpected bytecode (bug)"; break;
+ case ONIGERR_DEFAULT_ENCODING_IS_NOT_SETTED:
+- p = "default multibyte-encoding is not setted"; break;
++ p = "default multibyte-encoding is not set"; break;
+ case ONIGERR_SPECIFIED_ENCODING_CANT_CONVERT_TO_WIDE_CHAR:
+ p = "can't convert to wide-char on specified multibyte-encoding"; break;
+ case ONIGERR_FAIL_TO_INITIALIZE:
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..5daafd7
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1,2 @@
+#001-changes_build_sys.diff
+0100-source_typos.patch